Project

General

Profile

Bug #16159

Surface collisions on physics start

Added by [email protected] over 3 years ago. Updated about 2 years ago.

Status:
Closed
Severity:
Normal
Assignee:
-
Category:
Physics
Target version:
Start date:
10/13/2017
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

When switching to a vessel from the tracking station the ship bounces on the ground or explodes.

I've been having the issue since the 1.3.1.1981 update. It is happening all the time on my modded career save. I'd really prefer to go back to the previous release surface collisions, it was much more stable.

Attached a save game with no mods installed to check the issue, it was really easy to reproduce it.

persistent.sfs (61.5 KB) persistent.sfs [email protected] [email protected], 10/13/2017 08:51 PM
KerbalJumpSave.zip (1.15 MB) KerbalJumpSave.zip Save with repro michal.rehacek, 10/24/2017 10:04 PM
ksp bouncen480p.mov (4.08 MB) ksp bouncen480p.mov [email protected] unclejace, 10/26/2017 07:31 PM
exploding ship 480p.mov (3.13 MB) exploding ship 480p.mov video of ship exploding unclejace, 10/27/2017 09:21 PM

Related issues

Related to Kerbal Space Program - Bug #16398: Crafts/Objects in the Island Runway's Hangars are being moved up on load or physics range into the roof and explode most of the time.Closed11/03/2017

History

#1 Updated by [email protected] over 3 years ago

Video proof of the bounces in action. Gets worse with medium landing gear and extra large landing gear.

https://www.youtube.com/watch?v=X0t6HetzihQ

Unmodded KSP 1.3.1.

#2 Updated by michal.rehacek over 3 years ago

This is happening to me as well, and it's worse in 1.3.1 than it was in 1.2.2. Attached is a save in which I can reproduce the problem 100%: load the save, go to Tracking Station, switch to the "Mun Tractor 2" rover (need to make rovers visible in the Tracking list first). Within a few seconds of switching to the tractor, the tractor will jump several meters into the air.

The same problem happens in bases, but the rover can repro this every time in this particular save. In 1.2.2, the rovers didn't jump much; the bases did, but Kerbal Joint Reinforcement mod was able to prevent destruction.

#3 Updated by unclejace over 3 years ago

Attached is a video of the bounce even after time warp. Note that it starts right after "physics easing in progress."

#4 Updated by unclejace over 3 years ago

As soon as "physics easing in progress" displays, the ship explodes. Wow! Kinda cool if it didn't mess up my mission.

#5 Updated by Chris_2 over 3 years ago

Can confirm this is happening.

#6 Updated by bubbagump over 3 years ago

This is a duplicate of bug #16090 which was raised 3 weeks ago and contains further information. Given the severity of the issue it's incredible that it hasn't been hot-fixed yet. Not even assigned!

#7 Updated by unclejace over 3 years ago

I can confirm that this issue is ship specific. I had two ships landed on Pol within 450m of each other. After time warp, only one bounced and exploded. Ships have different components though I am unable to determine which component or parts that contribute to the bounce. Using mods KAS 0.6.3, KIS 1.7 and Docking port alignment 6.7.0

Update to this. I was able to get the ships within 80m of each other. Now the bounce and explosion does not happen! Doesn't seem to be any consistency to it.

#8 Updated by Technicalfool over 3 years ago

  • Related to Bug #16398: Crafts/Objects in the Island Runway's Hangars are being moved up on load or physics range into the roof and explode most of the time. added

#9 Updated by Yakuzi over 3 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10
  • Platform deleted (OSX)

I can also confirm in stock 1.3.1.1891(x64).

I also noticed that when you retract/extend the landing gear of a stationary vehicle, the wheels collide through the surface, and the craft appears to rest on the wheel axles rather than the wheels themselves. Whenever the gear is extended and locked, the craft bounces up from the axle height to the wheel height, sometimes quite violently. The change in surface interaction from axle to wheel may also be happening during loading of a save, resulting in this bouncy behaviour.

#10 Updated by Gorebane over 3 years ago

This is happening to me too. Most prominently with SSO craft with aeroplane landing gear, but also (to a lesser extent) with landing struts. Sometimes the craft just bounces high in the air, other times it just explodes. It has happened when loading a game, when exiting time warp, and when switching to a craft from the tracking station. It doesn't make any difference if the ease physics in option is enabled or not.

#11 Updated by NoShadows over 3 years ago

  • Platform Linux added

Also happens with linux, too.

#12 Updated by AstroBalrog over 3 years ago

Same issue here.

I see it when switching-to landed vessels, and EVERY TIME on "rescue from surface" missions - I'll land the rescue ship a short way from the Kerbal, switch to the Kerbal, start walking towards my rescue vessel, and watch the vessel LEAP off the surface... in once instance crashing and burning.

#13 Updated by whale_2 over 3 years ago

While we're waiting for the official fix, I've made an attempt to remedy it in 1.3.1

https://forum.kerbalspaceprogram.com/index.php?/topic/169206-131-worldstabilizer-bugfix-for-vessels-bouncing-on-scene-load/

#14 Updated by Justlooking2 over 3 years ago

Temporary fix: set textures to lowest, set physics computations to lowest, then the moment craft is loaded, activate x2 time warp (not x5). Then return to normal time. This may interrupt the bouncing. Does not fix the bug nor will it help for those craft which explode instantly on load. It may help you load a bouncy plane and retract its landing gear to prevent the bounce until the hotfix is released.

Also try the above by bringing another vehicle within 200m of the bouncing craft by using 2x time warp, then return to normal time.

#15 Updated by Ruedii over 3 years ago

These bugs will always be increased by time warp.

I suspect it has to do with the new wheel module not easing in physics properly, and not remaining fixated across save-state.

#17 Updated by Squelch about 3 years ago

  • Severity changed from Critical to Normal

#18 Updated by jclovis3 about 3 years ago

Please explain reason to change priority back to Normal. This bug makes refueling on Gilly impossible as the ship explodes coming out of warp. You can't expect to sit there for several days watching it refuel in real time. Warp must be fixed to make this playable, which makes this a critical issue. Version 1.4 is soon to be released and there should have been more than 10% progress on this by now. Nobody is going to purchase the Making History expansion if this is not fixed in the base game.

I play pure Vanilla, no mods, on Windows 10 in 64-bit mode. Started a new game with new ships so as not to reuse any old data and bug persists.

#19 Updated by BuzzKerman621 over 2 years ago

I can confirm that this issue still happens on 1.4.5.2243. This is a critical bug and should be fixed above all else. It makes base building almost impossible as vessels on the ground suddenly shoot into the air when visiting them.

Workaround:
For any vessels that form part of a base, I have modified the save game so that damperTweakable = 10 for all landing legs. This seems to have resolved the bouncing issues that result from the physics when coming out of time warp.

#20 Updated by BuzzKerman621 over 2 years ago

I found another workaround which doesn't require editing the save game. Instead, I set auto-struts to the root for all the docking ports which connect the base together. I discovered this after my base would explode when undocking one of the base modules. Now, I'm able to undock safely without the base tearing itself apart.

#21 Updated by [email protected] over 2 years ago

The start-up problems with the physics simulation for landed craft were fixed in 1.4.1.
That is, the save-file attached at the top of the report shows only a 1/4 meter settling when we first switch to the craft, or when we come out of 'on-rails' time-warp.

Possibly the confirmation above for versions after 1.4.1 refers to
the jumping we had before version 1.5 when docking/undocking/command-chair-exiting, #19343 #19402 #19474
edit: which is now back #21432 or never fully fixed
or the smooth bouncing we have with #17830 #19427 #19491
or maybe the kick you can get when bottoming out the landing legs or landing gear #20682

Whale_2's mod addresses the initial physics-startup, and you can see at his thread linked above that he is surprised that people want the mod for KSP versions 1.4+.
If anybody still sees a jump upon the initial load of physics, they should attach a craft file that shows the problem, because the original example no longer shows any problem.

#22 Updated by BuzzKerman621 over 2 years ago

The issue still happens with landed craft as well. I had a base on Mun that was happily planted on the surface. I landed a ship nearby and then saved the game. But, the base now launches into the air when loading the save game.

#23 Updated by chris.fulton about 2 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.0
  • % Done changed from 10 to 80

Changes have been made in 1.7 and we can no longer repro this bug with the attached save. Moving to RTT.

#24 Updated by Yakuzi about 2 years ago

The issue seems to trigger substantially less frequent in KSP 1.7.0.2483(x64), I did experienced it once however with a parked craft after stopping 100x time-warp (haven't been able reproduce it though). The craft bounced up violently and the brakes didn't work afterwards (even after switching them off and on again), resulting in the craft sliding off the runway.

#25 Updated by [email protected] about 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

I retested the save from the original report, and it still shows only one 1/4-meter bounce -- much better than version 1.3.1 and the same since version 1.4.1

It seems the best way to handle the cases where "the issue still happens" is to open another bug with another example file.

#26 Updated by chris.fulton about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF