Project

General

Profile

Bug #19427

Endless bouncing LY-01 Fixed Landing Gear

Added by 4x4cheesecake almost 3 years ago. Updated over 1 year ago.

Status:
Resolved
Severity:
Low
Assignee:
-
Category:
Physics
Target version:
Start date:
07/22/2018
% Done:

100%

Version:
Platform:
Linux, OSX, Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Since the 1.4.4. update, the 'LY-01 Fixed Landing Gear' starts to bounce right after the craft is spawned and will not stop doing so.
There is no difference on different runway upgrade levels and even the weight of the craft doesn't influence this behaviour. I did a quick test and spawned the very same craft in 1.4.3 and 1.4.4. but the bug appears just in 1.4.4.

To reproduce this bug, just spawn any craft with these landing gears attched to.

(To work around it is possible to increase the damper strength to max and reduce the spring strength to ~0.5)

bouncy landing legs.craft (25.5 KB) bouncy landing legs.craft simple plane with LY-01 landing gear 4x4cheesecake, 07/22/2018 08:22 PM
DAMPER_EXAMPLE.craft (57.8 KB) DAMPER_EXAMPLE.craft Leg tester: action groups 1, 2, and 3 Tomator, 08/17/2018 07:55 PM
20180819102329_1.jpg (112 KB) 20180819102329_1.jpg LT-2 contracted by side force Tomator, 08/19/2018 09:37 AM
Player.log (604 KB) Player.log [email protected] ThirdOfSeven, 08/21/2018 11:22 PM
Wobble-1.craft (10.6 KB) Wobble-1.craft [email protected] ThirdOfSeven, 08/21/2018 11:23 PM
Wobble-2.craft (12.5 KB) Wobble-2.craft [email protected] ThirdOfSeven, 08/21/2018 11:26 PM
37451

Related issues

Related to Kerbal Space Program - Bug #19454: Starting landing GearClosed07/28/2018

History

#1 Updated by 4x4cheesecake almost 3 years ago

  • Version changed from 1.4.4 to 1.4.5

Update: Still happens in 1.4.5

#2 Updated by diomedea almost 3 years ago

  • Related to Bug #19454: Starting landing Gear added

#3 Updated by Tomator over 2 years ago

The problem is relevant also to LT-05, LT-1, and LT-2 legs as well as LY-10 and LY-35 landing gear - basically all original KSP landing parts I've checked. Best way to test: set damper to minimum value, 0.05. While the object could swing, this should die out slowly. Instead, the energy grows rapidly. My test craft starts to jump and after two or three jumps legs get destroyed.

Of course 0.05 damper value isn't the one that should be widely used but it shows that energy that should dissipate cumulates rapidly and catastrophically. This is physics (simulation) flaw.

While these parts worked quite well previously, there is a regression. I have a lander like the example craft on the Minmus, "standing" on 3 LT-1. When landed (or when legs are retracted and then extended again) the ship swing for quite long time despite dampers ans springs are set to default 1.0. When swinging dies out, the ship stands tilted like the springs were not strong enough on Minmus while they keep the weight well on Kerbin (where dampers set to 2.0 deal with swinging well but set to 1.0 appear to keep the energy constant).

Also LT-05 seem to support craft's weight even better on Kerbin than on Minmus. It's strange taking int account that Minmus' gravity should barely compress the spring by a tiny amount.

The craft has mounted 3 types of legs, attached to actions 1, 2, and 3. On either set of legs it starts to jump.

#4 Updated by Tomator over 2 years ago

37451

After playing a bit more with base on Minmus I concluded that with legs physics something went really wrong. Found that LT-1 with damper and spring set to 1.0 doesn't work well, I tried to send another part of the base equipped with overkill 2.0/2.0 LT-2 legs. Didn't help. The ship is still unstable. Once landed it was OK, but too far from a base so I flew a bit closer and then one of the legs seemed weaker and the ship would fall to the side if reaction wells wouldn't keep it straight. Got it up and sat down again so it stabilized. Connected with KAS pipe. Ships connected with these links don't swing but this ship didn't stand straight so I unconnected to release tensions... Then it started to swing and suddenly was thrown several hundred meters up into the sky. Certainly LT-2 can absorb and release a lot of energy. Energy basically from nowhere... Maybe it has dark energy converter inside?

Well, after few falls, explosions and insane jumps (legs bounced again and again from the ground) the ship laid on its side rolling left and right. When rolled onto one of it legs some mysterious force was compressing leg's spring (acting sideways on it). The second leg worked similarly but additionally the ship had been rotated on the ground by some dark energy that must have been leaked from damaged converter.

Leg basics are quite simple - the spring should generate force proportional to its compression while the damper should generate force proportional to speed of compression/decompression. These forces should act along the leg while for perpendicular forces the leg should appear stiff. Currently it looks like the solution was rather opposite... And on the Mimnus, where the gravity is so small the slow compressing of the spring proves really low force. Certainly lower than on Kerbin where the same mass acts with much more force still being held up by the same legs. While the player cannot change leg parameters in flight (reasonable - how to change the spring?) why do they fluctuate on their own?

Spring's and damper's strength are unitless values. Why? If one knew that the spring will generate 10kN per m of compression while the leg can contract 0.5m this could be calculated which legs, how much of them with which spring should be used for a ship to land in given range of gravity. Having damper's strength (Ns/m) and leg's endurance (N) one could calculate maximum grounding speed. While earlier legs worked quite well set 1.0/1.0, this wasn't so important. Now they generally don't work well.

This must be fixed.

Mods I've installed:
  • AviationLights
  • Chatterer
  • CommunityCategoryKit
  • CommunityResourcePack
  • EasyVesselSwitch
  • FlagPack
  • KAS
  • KIS
  • PlanetaryBaseInc
  • PolishFlagPack
  • SquadExpansion
  • SurfaceLights
  • TriggerTech

#5 Updated by ThirdOfSeven over 2 years ago

Have same issue with game in Linux with no mods installed. I've tried to disable "Ease in gravity" and "Physics delta per frame" to on/off and from 0.03/0.04 to 0.12 with no luck (it may just slightly change amplitude or number of cycles to explosions).

Unplayable planes having LY-01/LY-05:

0) Of course, oscillating craft is hard to control on take off
1) May oscillate until craft rips apart or hits runway hard shortly after spawning
2) It may end up being in uncontrollable jumping motion to the side when craft is impossible to recover since it is "moving"

Attached Wobble-1 is craft file with absolute minimum to get this triggered.

What is observed: heavier craft is, bigger amplitude is. You need about 3t to make this can on 4 gears to oscillate very noticeable. With second FL-T400 and 5.2t it starts to jump into air. With third FL-T400 (craft Wobble-2) it starts moving on runway and you may not recover it. With 2 more FL-T400 and mass about 12t it will explode after second oscillation.

It was flawless in 1.4.3 (nothing of above happens).

#6 Updated by cstruven over 2 years ago

  • Platform OSX added

Happens on MacOS as well. Sometimes gear/landing strut configurations that function as expected on Kerbin will misbehave in low-gravity environments (i.e., Minmus and Gilly).

#7 Updated by joshua.collins over 2 years ago

  • Status changed from New to Ready to Test
  • Target version set to 1.5.0
  • % Done changed from 0 to 80

The LY-01 should be much more stable in 1.5.0

#8 Updated by shederman over 2 years ago

joshua.collins wrote:

The LY-01 should be much more stable in 1.5.0

Sorry, but no.

Running version 1.5.1.2335 and its unusable. Had a tiny lander come to a 1m/s landing and then bounce repeatedly, losing it's engine in the process, bouncing more and more until it was 1.2km above the surface.

That's screwy physics.

#9 Updated by [email protected] over 2 years ago

  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50

Version 1.5 gives a useful workaround that reduces the frustration from this bug immensely.

Enabling the setting 'Advanced Tweakables' shows a button Spring/Damper {auto, overrride} and if we set it to override, we can adjust the damping as needed with the craft in operation. Previously, the adjustments were available only during construction.

If I were to formally test, though, using the example craft given in the report:
bouncy_landing_legs still bounces (override cures)
DAMPER_EXAMPLE(medium legs) bounces (override cures)
wobble-1 bouncing damps
wobble-2 very slowly damps

#10 Updated by chris.fulton about 2 years ago

  • Status changed from Not Fixed to Ready to Test
  • Target version changed from 1.5.0 to 1.7.0
  • % Done changed from 50 to 80

Improvements have been made up to 1.7 with the landing gear. Setting this bug to RTT to see if the original issue is now fixed.

#11 Updated by [email protected] about 2 years ago

  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50

Results with the example craft are the same in version 1.7.0 as reported for version 1.5.1

#12 Updated by Ponchinizo about 2 years ago

I am getting this exact same bug in the newest Console update. Plz fix, your new update broke my game and i cannot play.

#13 Updated by [email protected] over 1 year ago

  • Status changed from Not Fixed to Resolved
  • % Done changed from 50 to 100

The PC version 1.8.1 has resolved this, presumably from its update to newer Unity engine.
The example craft, with default settings, now damp nicely.
(Possibly that means the console version gets the resolution when a KSP with the new Unity engine reaches consoles.)

1) The default springs on the lightest landing gear are set for a very light craft, so 'bouncy landing legs.craft' bottoms-out the landing gear, but no longer bounces. Increasing the spring strength to 2 makes them more appropriate for this aircraft, and they still damp out any bouncing.

2) The spring/damper settings now persist, so toggling the right-click option to 'auto' merely hides the sliders, leaving the effect as it was when sliders were shown. That means, the 'DAMPER_EXMPLE.craft' retains its very low damping that it was saved with. Returning the damping sliders to their default, or adding fresh landing legs from the VAB, results in quickly damped bouncing.

#14 Updated by abc over 1 year ago

There are at least two newer bugs for this basic issue in 1.8.1 with the LT-1 and LT-2, bugs #24218 (LT-2 plus 3PT Telescoping Hydraulic Cylinder) and #24614 (LT-1 plus G-00 Hinge and G-01L Alligator Hinge). Also just an OKTO plus 4x LT-1 or LT-2 bounces endlessly, although the base from the craft in #24218 is stable with both LT-1 and LT-2.

Also available in: Atom PDF