Project

General

Profile

Bug #16090

Related to prerelease bug #15796 Non-active vessels jumping on load still happening on 1.3.1

Added by Anth12 over 3 years ago. Updated over 2 years ago.

Status:
Closed
Severity:
Critical
Assignee:
-
Category:
Physics
Target version:
Start date:
10/08/2017
% Done:

100%

Version:
Platform:
Linux, OSX, Windows
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

This is happening not only on non-active vessels within physics range but also to the main craft that was loaded.
If I move out of range of a craft that jumps on load (say to over 400m) then move back into physics range (200m) the craft will jump again.

The log file shows a negative direction of the craft loaded and ones in physics range.

What can be seen on the flat most of the time is that the craft is actually in the right position and then for a fraction of a second the craft is moved into the ground
which landing gear or wheels or landing legs compensates for and propells the craft into the air either by a lot or a little bit.

It can happen randomly at times with certain wheels, meaning I F9 a save again and again and then sometimes they are moved into the ground, sometimes they arent.

It can be ok on the flat....but being on a hill can make it happen,
The craft is on the ground in the correct position and then moves into the ground instantly which is confirmed by the log file.

I suspect that it is due to old code that has been turned on or off?
Or is it an update to unity?

Look back to #15796 for information. Watching EJ_SA on twitch and his ships jumping into the air says this needs to be fixed soon...

LY-35 Medium Landing Gear will jump the craft everytime on flat ground, hills whereever.
LY-10 Small Landing Gear will be fine on the flat in 1.3.1 but jumps on hills
TR-2L Ruggedized Vehicular Wheel on the flat will on F9ing randomly move into the ground and jumps the rover. on a hill it will load in the air and then be moved into the ground and jump a little.

Please...Please fix this...

screenshot21.png (786 KB) screenshot21.png [email protected] Anth12, 10/08/2017 05:20 AM
screenshot34.jpg (426 KB) screenshot34.jpg [email protected] unclejace, 10/20/2017 12:32 PM
KerbalJumpSave.zip (1.15 MB) KerbalJumpSave.zip Save with repro michal.rehacek, 10/24/2017 10:02 PM
ksp bouncen480p.mov (4.08 MB) ksp bouncen480p.mov [email protected] unclejace, 10/26/2017 12:24 PM
quicksave.sfs (1.6 MB) quicksave.sfs Spaceplane safely landed on Ike jumps on load Kasuha, 12/02/2017 01:03 PM
ksp_gif.gif (1.62 MB) ksp_gif.gif [email protected] Sunkanx, 01/31/2018 07:35 PM
1_3_1 Flat Test Post.png (1.75 MB) 1_3_1 Flat Test Post.png [email protected] Anth12, 03/17/2018 06:03 AM
1_3_1 Hill Test Post.png (1.79 MB) 1_3_1 Hill Test Post.png [email protected] Anth12, 03/17/2018 06:03 AM
1_3_1 Save used in 1.4.1.png (1.74 MB) 1_3_1 Save used in 1.4.1.png [email protected] Anth12, 03/17/2018 06:03 AM
1_3_1 Save used in 1_4_1.png (1.62 MB) 1_3_1 Save used in 1_4_1.png [email protected] Anth12, 03/17/2018 06:03 AM
1_3_1 Flat Test Post.sfs (713 KB) 1_3_1 Flat Test Post.sfs [email protected] Anth12, 03/17/2018 06:12 AM
1_3_1 Hill Test Post.sfs (714 KB) 1_3_1 Hill Test Post.sfs [email protected] Anth12, 03/17/2018 06:12 AM
31775
31938
33213
34559
34560
34561
34562

Related issues

Related to Kerbal Space Program - Bug #16398: Crafts/Objects in the Island Runway's Hangars are being moved up on load or physics range into the roof and explode most of the time.Closed11/03/2017

History

#2 Updated by evanerv over 3 years ago

This seems to always happen with larger crafts on landing gear. It seems when the game is loaded, for the very first few frames, the wheels will clip into the ground and thus create the bounce.
Hopefully the extra bit of info helps...

https://www.youtube.com/watch?v=yCpDecrqiLA&t=19s

#3 Updated by Anth12 over 3 years ago

In case of the LY-35 Medium Landing Gear:

I suspect there are 3 'objects' at play.

1. There is an object that determines where the wheel should be in contact with the ground
2. There is the collider.
3. There is the visual part we can see.

What I believe is going on in relation to it being on a Flat surface (more seems to be happening when wheels are on the hills):
1. LY-35 appears to load into the correct position above the ground initially.
2. LY-35 then drops into the ground to the approximate position of the collider object (2) INSTEAD of the object that determines the position of the wheel on the ground (1)
3. Then the suspension realises its compressed according to where the object that determines to the position of the wheel (1) in relation to the collider (2) and propels the craft into the air.

#4 Updated by IronTomato over 3 years ago

This is happening to me whenever I timewarp with medium landing gears. For some reason, it only happens if all my gears are extended. If I only retract the front landing gear, or only the back, or I have none extended at all (in other words, if part of the plane's body is touching the ground) this does not happen.

#5 Updated by unclejace over 3 years ago

31938

Happening on Mac too. Spacecraft bounces off surface right after "physics easing in progress" is displayed. Attached screenshot shows the craft in initial bounce with physics easing displayed. No landing gear deployed. Craft was resting on its engines.

#6 Updated by bubbagump over 3 years ago

  • Severity changed from High to Critical

Please consider raising the priority of this bug to critical. It's making large parts of the game unplayable e.g. refuelling on moons, base construction.

#7 Updated by [email protected] over 3 years ago

More examples, again medium and XL landing gear are worse offenders:

https://www.youtube.com/watch?v=X0t6HetzihQ

#16159 is a duplicate of this issue.

#8 Updated by jrodriguez over 3 years ago

bubbagump wrote:

Please consider raising the priority of this bug to critical. It's making large parts of the game unplayable e.g. refuelling on moons, base construction.

I'm trying to understand why this issue has not been hotfixed already.

I'm a senior software engineer and this is one of those bugs that requires an immediate solution, stopping other work until is fixed.

#9 Updated by michal.rehacek over 3 years ago

This is happening to me as well, and it's worse in 1.3.1 than it was in 1.2.2. Attached is a save in which I can reproduce the problem 100%: load the save, go to Tracking Station, switch to the "Mun Tractor 2" rover (need to make rovers visible in the Tracking list first). Within a few seconds of switching to the tractor, the tractor will jump several meters into the air.

The same problem happens in bases, but the rover can repro this every time in this particular save. In 1.2.2, the rovers didn't jump much; the bases did, but Kerbal Joint Reinforcement mod was able to prevent destruction.

#10 Updated by unclejace over 3 years ago

This bounce occurs after time warp, but also occurs after save or when loading from tracking station. On Bop. Similar ship is mining Dres and not experiencing the bounce in the same game.

#11 Updated by catbus over 3 years ago

jrodriguez wrote:

bubbagump wrote:

Please consider raising the priority of this bug to critical. It's making large parts of the game unplayable e.g. refuelling on moons, base construction.

I'm trying to understand why this issue has not been hotfixed already.

I'm a senior software engineer and this is one of those bugs that requires an immediate solution, stopping other work until is fixed.

I concur. This is outright game-breaking.

#12 Updated by unclejace over 3 years ago

I can confirm that this issue is ship specific. I had two ships landed on Pol within 450m of each other. After time warp, only one bounced and exploded. Ships have different components though I am unable to determine which component or parts that contribute to the bounce. Using mods KAS 0.6.3, KIS 1.7 and Docking port alignment 6.7.0

Update to this. I was able to get the ships within 80m of each other. Now the bounce and explosion does not happen! Doesn't seem to be any consistency to it.

#13 Updated by unclejace over 3 years ago

There definitely seems to be some issues with physics. Beside the ship jump as described above, I noticed issues on EVA. Kerbal was carrying a container. Mobility changed accordingly with added mass of container, but when the container was no longer part of kerbal's inventory, her mobility became erratic, including violent uncontrolled spin. I was able to stop the spin by shutting off RCS and then turning it on again, but not consistently.

Secondly, container on the back of the kerbal seems to be an apparition, not a solid, as it passes through ship components while on the kerbal's back. As soon as the container was no longer in the inventory, it interacted normally with other solids. Quantum container?

#14 Updated by Technicalfool over 3 years ago

  • Related to Bug #16398: Crafts/Objects in the Island Runway's Hangars are being moved up on load or physics range into the roof and explode most of the time. added

#15 Updated by DannoVonDanno over 3 years ago

I am having this problem with a lander on Bop - my design is based on spending a few days on the surface to refuel before moving on. Every time I switch away from the lander and switch back, or go to time warp and then come out, the lander bounces off the surface. I can land it again and continue, but it's annoying.

The total mass of the lander is 91,707 kg and is sitting on four LT-2 struts. All stock parts. I'm on a hill at about a 15 degree angle from vertical, according to the navball.

Mod list: Kerbal Alarm Clock 3.8.5.0, Kerbal Engineer Redux 1.1.3.0, Kerbal Joint Reinforcement 3.3.3, KSP AVC 1.1.6.2, Navball Docking Alignment Indicator CE-2 1.0.3, TAC Fuel Balancer 2.14, TriggerAu Flags 2.9.2.0.

Help me, Obi-wan Kerman.

#16 Updated by midgetsl4yer over 3 years ago

As a short term solution i resolved this issue by editing the config file for the LT-2 Landing Struts, the ones that gave me the most bounce on load issues. I changed damperRatio = 1 to damperRatio = 10 and this caused the strut to spring back quicker which solved the problem. Maybe the force of the bounce is relating to the length of time the part is clipped? Might be why the problem is more pronounced on heavier ships.

G:\Steam\steamapps\Common\Kerbal Space Program\GameData\Squad\Parts\Utility\landingLegLT-2

Relevant lines:

targetPosition = 1.0                  <-- not sure            
        springRatio = 6                   <-- when set to 0 the strut sags to the ground, I think a high number would make them ridgid(maybe they would break on                                                                       landing)
        damperRatio = 10              <-- at 0 the bounce never ends, at 10 it stabilizes quickly with minimal bounce
        boostRatio = 0.6                 <-- not sure     

#17 Updated by unclejace over 3 years ago

Another weird bounce situation. Landed ship on Minmus within 1.5 km of kerbonaut to be rescued. Kerbonaut uses jetpack to reach ship. When kerbonaut is about 300 m away the rescue ship bounces off moon falls back and destructs.

Note: the ship had a stable landing and I used bracket keys < [,] > to switch to kerbonaut.

#18 Updated by Kasuha over 3 years ago

Here's another quicksave with a ship jumping on load. Losing a ship on return to it is not challenge or fun, it just drives players off from the game that's supposed to be finished.

Especially since with drilling ships you HAVE to switch away from it as the process will switch off during night but will not start up again in the morning in time warp. Which is another bad and game spoiling design decision in the game.

#19 Updated by NoShadows over 3 years ago

  • Platform Linux added

Also happens with linux.

#20 Updated by AstroBalrog over 3 years ago

unclejace wrote:

Another weird bounce situation. Landed ship on Minmus within 1.5 km of kerbonaut to be rescued. Kerbonaut uses jetpack to reach ship. When kerbonaut is about 300 m away the rescue ship bounces off moon falls back and destructs.

Note: the ship had a stable landing and I used bracket keys < [,] > to switch to kerbonaut.

YUP! I've seen the exact same thing.

#21 Updated by DevonKiwi over 3 years ago

This just happenned to me for the second time. First time was on a rescue mission, with the rescue ship leaping from the ground as the rescuee approached. This latest time was even more frustrating - a mining mission on Gilly. I built a harvesting lander that could also be used to supply ore to a refuelling station in orbit, and left it drilling for the mission's 3000 units while I did some other missions. When I switch back to the lander after a few Kerbal weeks, it jumps into the air and breaks up. This has only happenned to me in 1.3.1. Please fix it!

Edit: One point occurred when reading other posts. On the rescue mission, if I could land my rescue ship close to my Kerbal (within 100 metres), the problem didn't occur. My mining lander remains unuseable, though, even if I fiddle with the landingLegLT-2.cfg file as someone suggested.

#22 Updated by TimZ over 3 years ago

This is still happening on 1.3.1.1891

Landed craft bounce on loading and usually blow up or flip over and are damaged. Game is unplayable like this - haven't been able to play since this started in October.

Open since 10/8, critical priority and 0% done. WTF - I guess I'll check back again in a month.

#23 Updated by Sunkanx over 3 years ago

33213

Have the same issue. On load the craft jumps skyhigh on minmuss and falls back down and destroys itself. It is making the game unplayable. :(

#24 Updated by midgetsl4yer over 3 years ago

  • Platform deleted (Linux, OSX)

#25 Updated by midgetsl4yer over 3 years ago

  • Platform Linux, OSX added

Has anybody tried disabling all mods? Is this a vanilla issue?

Edit: Sorry I didn't mean to change the platforms.

#26 Updated by michal.rehacek over 3 years ago

midgetsl4yer wrote:

Has anybody tried disabling all mods? Is this a vanilla issue?

Yes, it is happening without any mods.

#27 Updated by midgetsl4yer over 3 years ago

I cannot believe that they have not addressed this. The game is completely unplayable. Jeb has been stranded on the Mun for over three months... his rescue craft flips over and explodes when I switch back to the ship.

#28 Updated by IronTomato about 3 years ago

Valentina currently on permanent vacation to Laythe for me.

The fact that they haven't even acknowledged the existence of this pug yet is almost amazing.

#29 Updated by Squelch about 3 years ago

  • Status changed from New to Ready to Test
  • Target version set to 1.4.0
  • % Done changed from 0 to 80

#30 Updated by midgetsl4yer about 3 years ago

It's a miracle, progress has been made!

A comment from a dev would be appreciated.

Edit:

=================================== v1.4.0 ============================================================
+++ Bugfixes
Improve vessel Jumping/positioning coming off rails.

We shall see...

#31 Updated by SpannerMonkey about 3 years ago

  • Version changed from 1.3.1 to 1.4.0

Although diminished the problems still exist in 1.4.0 . tested all stock craft in both quicksave and revert and all wheeled vehicles do indeed jump around half a meter on scene load .
This obviously in a clean unmodded fresh build of KSP

#32 Updated by Anth12 about 3 years ago

I need to do some more testing, but the problem has been significantly reduced even on hills.
Not sure if I can say its resolved, but its way closer to fixed that it was

#33 Updated by Anth12 about 3 years ago

34559
34560
34561
34562

Steam 1.3.1 Clean Install
Steam 1.4.1 (plus MH though no new parts used)

Tested every wheel/landing leg/landing gear in the screenshots and game saves.
Post is in reference to the landing legs and wheels are extended and ready to load

Tested on the flat outside KSC
Tested on the hill near KSC
Did a little testing on the Mun and Eve

Created everything in 1.3.1 and then tested in 1.3.1 to prove the bug. Then copied the entire save over the 1.4.1 and tested to see if the problem is fixed

Screenshots show how the bug affected 1.3.1 and then affected 1.4.1.

The crafts are named after what wheels or landing legs they are testing and show up in the debug menu and how they are being affected

The LY-60 and LY-99 are still bouncing but isnt related to the problem on this bug report (might be just because the craft is too light for what they were designed for)

The screenshots for 1.4.1 show that the problem is fixed. A little testing on the Mun and Eve also prove that its fixed.

Resolved.

#34 Updated by Anth12 about 3 years ago

GOG 1.4.1
Steam 1.4.1 MH

Works in both 1.4.1 and MH

#35 Updated by Squelch about 3 years ago

  • Status changed from Resolved to Closed

#36 Updated by BuzzKerman621 over 2 years ago

This issue is definitely not fixed. It still happens in 1.4.5.2243. See Bug #16159.

Also available in: Atom PDF