Project

General

Profile

Bug #19474

Landing legs still breaking in 1.4.5; extreme bouncing

Added by squackenbush 12 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Gameplay
Target version:
Start date:
08/03/2018
% Done:

100%

Version:
Platform:
Linux
Expansion:
Core Game
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

Thanks to those who worked on this issue since 1.4.2, now it only happens sometimes!

Undocking craft on the surface still causes landing legs to explode in many situations, at least on Kerbin (other bodies not tested).

To reproduce:
1) Launch craft from hangar
2) Drive for several craft lengths down the runway (I usually take it up to 10 m/s and hit the brakes)
3) Stop and extend landing legs
4) Retract landing gear
5) Undock, legs explode

Decoupling from the start location (same procedure, no driving) does not result in an explosion. If one extends the legs before moving from the launch location, decouples, recouples, and then performs the drive/decouple test there is no explosion.

When the legs survive one or other half of the craft bounces violently on decoupling or recoupling. This is extreme if there is a large mass difference between halves.

Not being careful in general also results in an explosion: raising the wheelbase to introduce a slight misalignment or simultaneously retracting wheels while extending legs will produce a craft that explodes on undocking.

Surface docking was smooth in 1.4.1, but legs always explode 1.4.2-1.4.4. The issue seems intermittent in 1.4.5. May be related to Bug #19343 and others; reporting because these issues were claimed fixed in the 1.4.5 changelog.

20180802195703_1.jpg (575 KB) 20180802195703_1.jpg Screenshot of craft squackenbush, 08/03/2018 12:13 AM
Docking Test.craft (34.5 KB) Docking Test.craft 555-555-0199@example.com squackenbush, 08/03/2018 12:15 AM
37276

History

#1 Updated by joshua.collins 9 months ago

  • Status changed from New to Ready to Test
  • Target version set to 1.5.0
  • % Done changed from 0 to 80

#2 Updated by k-ohara5a5a@oco.net 7 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100
  • Language 简体中文 (Chinese Simplified) added

1.5.1

#3 Updated by k-ohara5a5a@oco.net 7 months ago

  • Language deleted (简体中文 (Chinese Simplified))

The example undocks with no unrealistic bounce in version 1.5.1. (probably same fix that fixed #19343)

#4 Updated by joshua.collins 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF