Project

General

Profile

Bug #23924

Terrier engine not shielded by heatshields

Added by AHHans over 1 year ago. Updated 9 months ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
Physics
Target version:
Start date:
10/17/2019
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Core Game
Language:
English (US), Español (Spanish)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Something seems to be broken with the 10m heatshield in KSP 1.8.0
One issue is that the "reentry heating plasma effects" show up around all the parts that are supposed to be shielded by the heatshield.
The other (and more problematic) is that a terrier engine inside the stack that the heatshield is supposed to protect experiences significant heating by "Conv Flux". (In the attached example it (and Valentina) survives, in my career save they weren't that lucky.) No other part in the stack gets heated by "Conv Flux".

Attached is:
- a savefile in which a test-craft is on a suborbital trajectory and about to enter Eve's atmosphere (A 1.7.3 save, so it can be loaded in both 1.7.3 and 1.8.0)
- screenshot from both 1.7.3 and 1.8.0 during reentry of said craft, showing the thermal
- the "Player.log" and "KSP.log" from my 1.8.0 in which I load the savefile and watch the craft enter Eve's atmosphere.

I run KSP on Linux, Ubuntu 18.04, via Steam. With Kerbal Alarm Clock as the only Mod.

10mHeatshieldTest.sfs (74.3 KB) 10mHeatshieldTest.sfs AHHans, 10/17/2019 08:02 PM
10mheatshield_Eve_1-7-3.png (635 KB) 10mheatshield_Eve_1-7-3.png AHHans, 10/17/2019 08:03 PM
10mHeatshield_Eve_1-8-0.png (1.25 MB) 10mHeatshield_Eve_1-8-0.png AHHans, 10/17/2019 08:04 PM
1-8-0_KSP.log (417 KB) 1-8-0_KSP.log AHHans, 10/17/2019 08:05 PM
1-8-0_Player.log (647 KB) 1-8-0_Player.log AHHans, 10/17/2019 08:06 PM
10mHeatshield_Eve_1-8-1.png (1.44 MB) 10mHeatshield_Eve_1-8-1.png AHHans, 10/29/2019 07:50 PM
10mHeatshield_Eve_1-0-0.png (1.53 MB) 10mHeatshield_Eve_1-0-0.png AHHans, 02/13/2020 08:36 AM
20200228164401_1.jpg (431 KB) 20200228164401_1.jpg Ryborg10000, 02/28/2020 05:08 PM
screenshot2.png (1.74 MB) screenshot2.png Anth12, 02/28/2020 10:06 PM
Old Terrier.png (1.15 MB) Old Terrier.png Anth12, 02/28/2020 10:16 PM
screenshot907.png (1.83 MB) screenshot907.png just_jim, 03/02/2020 02:02 PM
terrier_heat-test_21m.png (1.58 MB) terrier_heat-test_21m.png two terrier engines, one a bit more than 21m from the heatshield one a bit less. AHHans, 03/02/2020 09:43 PM
terrier_heat-test_retro.png (1.61 MB) terrier_heat-test_retro.png AHHans, 03/07/2020 01:49 PM
1.9.1.png (2.15 MB) 1.9.1.png Anth12, 07/07/2020 01:21 AM
1.10.0.png (1.95 MB) 1.10.0.png Anth12, 07/07/2020 01:21 AM
49499
49500
50040
51335
51578
51582
51583
51603
51633
51732
53463
53464

Related issues

Related to Kerbal Space Program - Bug #23966: Major Temperature Differences between 1.7.3 and 1.8Closed10/19/2019

History

#1 Updated by klesh over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10
  • Platform Windows added

I can confirm seeing this, and on Windows(10) as well. Stock install with both DLC.

#3 Updated by AHHans over 1 year ago

  • Subject changed from 10m heatshield doesn't really shield to Terrier engine not shielded by heatshields

I did some more testing, and it looks like only(?) the Terrier engine is affected by the extra heating problem. If I replace the Terrier with a Twitch, Reliant, Vector, Poodle, or Cheetah engine then none of that extra "Conv Flux" heating is there. If I place more than one Terrier engine in the stack, then only the lowermost (i.e. first in the airflow) Terrier engine is affected. It does get some shielding from parts (heatshields, tanks, or other engines) below it in the stack.
Also, if I replace the 10m heatshield with another heatshield (I tested the 3.75, 2.5, and 1.2m heatshields) then the effect is essentially the same. (I obviously need to adjust the craft to test that...)

Is the model for the "aerodynamic size" for the Terrier too big? I.e. larger than an inflated 10m heatshield?
Edit: I just did another test: the Terrier does not seem to generate excessive drag. At least not as much at an inflated 10m heatshield.

#4 Updated by [email protected] over 1 year ago

The model for size for purposes of heat occlusion is, in fact, too big
'PartDatabase.cfg' for KSP 1.8.0 says the LV-909 Terrier has dimensions 1.25m, 21m (sic), 1.25m
where previous versions had 1.25m, 0.8m, 1.25m.

Many entries in 'PartDatabase.cfg' are changed in ways that look like errors.
If I copy that file from a previous installation (version 1.7.3) and delete the line with "version = ..." then I avoid the aerodynamics errors of 1.8.0 --- and probably this one as well; I haven't tried yet.

#5 Updated by just_jim over 1 year ago

  • Related to Bug #23966: Major Temperature Differences between 1.7.3 and 1.8 added

#6 Updated by just_jim over 1 year ago

  • Assignee set to just_jim

#7 Updated by vrampal over 1 year ago

Looks like the following issues are all related:

https://bugs.kerbalspaceprogram.com/issues/23924
https://bugs.kerbalspaceprogram.com/issues/23961
https://bugs.kerbalspaceprogram.com/issues/23966
https://bugs.kerbalspaceprogram.com/issues/23997

Fairing, heat-shield or any other part does not deflect the re-entry air flow.

#8 Updated by AHHans over 1 year ago

50040

Unfortunately this does not seem to be fixed in KSP 1.8.1. (See the attached screenshot.)

When I look into the PartDatabase.cfg then I find the following in there:

PART
{
        url = Squad/Parts/Engine/liquidEngineLV-909_v2/liquidEngineLV-909_v2/liquidEngine3_v2
        DRAG_CUBE
        {
                cube = 0, 1.078,0.7414,0.6625, 1.078,0.7414,0.6625, 1.25,0.8731,0.8318, 1.25,0.8512,20.88, 1.078,0.7414,0.6625, 1.078,0.7414,0.6625, 0,-10.49,4.768E-07, 1.269,21.01,1.269
                cube = 1, 1.077,0.7422,0.6539, 1.077,0.7422,0.6539, 0.6467,0.7605,0.8314, 0.6467,0.8417,21.03, 1.077,0.7422,0.6539, 1.077,0.7422,0.6539, 0,-10.5,0, 1.25,21,1.25
                cube = 2, 1.077,0.7422,0.6539, 1.077,0.7422,0.6539, 0.6217,0.7978,0.8314, 0.6217,0.8477,20.87, 1.077,0.7422,0.6539, 1.077,0.7422,0.6539, 0,-10.5,0, 1.25,21,1.25
        }
}

P.S. I also deleted the PartDatabase.cfg and had KSP re-create the file, and I got it again from Steam (via "Verify integrety of game files"). Neither did help.

KSP 1.8.1.2694 Linux (Ubuntu 18.04) MH 1.8.1 BG 1.3.1 (Via Steam)

#9 Updated by [email protected] over 1 year ago

The ModuleManager patch attached to bug-report #20683 replaces those long lists of dimensions with the correct values for the LV-909,
so that patch is also a workaround for this bug.

#10 Updated by AHHans about 1 year ago

51335

So at least when I run the test scenario from the save-file attached to this report, then I still see the same problem in 1.9.0. (See attached screenshot.)

#11 Updated by just_jim about 1 year ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#12 Updated by just_jim about 1 year ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.9.0
  • % Done changed from 30 to 80

This should be fixed. You may have to delete the PartDatabase.cfg so KSP can write a new one... see comment #8
Thank you

#13 Updated by [email protected] about 1 year ago

  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50
  • Language Español (Spanish) added

No. KSP 1.9.0 ships with a PartDatabase.cfg that contains the errant 21-meter dimensions shown in comment 8.
If we do delete PartDatabase.cfg the regenerated file again contains the errant dimensions.
And, the screen shot in comment 10 shows the symptom persisting in version 1.9.0.

#14 Updated by Anth12 about 1 year ago

21 metres? is that why my craft with a new terrier explodes even if its higher up on a craft hitting the water?

Meaning a Terrier that is near the top of the craft explodes and the top of the craft then falls off, when parts above it are fine and parts below are fine.

#24255 is my bug report for this issue in regards to the revamped terrier being destroyed when it was nowhere near to the ground/splash down

#15 Updated by AHHans about 1 year ago

just_jim wrote:

This should be fixed. You may have to delete the PartDatabase.cfg so KSP can write a new one... see comment #8
Thank you

Well, my PartDatabase.cfg semms to get rebuilt each time I start KSP, at least the file gets a new time stamp. Anyhow, I did delete the file before doing the test which lead to comment #10.

But thanks for looking into it!

#16 Updated by MechBFP about 1 year ago

I can confirm as well that this is still broken. Deleted partsdatabase file and re-verified. Same problem with the "21" in there.

Please note the problem is with the liquidEngineLV-909_v2/liquidEngine3_v2 engine (note the V2), not the original V1 version.

#17 Updated by victorr about 1 year ago

  • Status changed from Not Fixed to Ready to Test
  • Target version changed from 1.9.0 to 1.9.1
  • % Done changed from 50 to 80

We've made some changes in the latest build and would like some input on this issue please. Thanks.

#18 Updated by victorr about 1 year ago

  • Assignee deleted (just_jim)

#19 Updated by Ryborg10000 about 1 year ago

51578

victorr wrote:

We've made some changes in the latest build and would like some input on this issue please. Thanks.

Hi, I've just tested this bug in 1.9.1 with my own eve lander and I'm still experiencing this issue.

#20 Updated by FishMittens about 1 year ago

I too had this issue with 1.9.1 whilst trying to land on Eve.

Until there is an official fix, I made the following changes to PartDatabase.cfg to fix the problem:

PART
{
    url = Squad/Parts/Engine/liquidEngineLV-909_v2/liquidEngineLV-909_v2/liquidEngine3_v2
    DRAG_CUBE
    {
        cube = 0, 1.078,0.7414,0.6625, 1.078,0.7414,0.6625, 1.25,0.8731,0.8318, 1.25,0.8512,0.88, 1.078,0.7414,0.6625, 1.078,0.7414,0.6625, 0,-0.0949,4.768E-07, 1.269,0.88,1.269
        cube = 1, 1.077,0.7422,0.6539, 1.077,0.7422,0.6539, 0.6467,0.7605,0.8314, 0.6467,0.8417,0.73, 1.077,0.7422,0.6539, 1.077,0.7422,0.6539, 0,-0.095,0, 1.25,0.73,1.25
        cube = 2, 1.077,0.7422,0.6539, 1.077,0.7422,0.6539, 0.6217,0.7978,0.8314, 0.6217,0.8477,0.87, 1.077,0.7422,0.6539, 1.077,0.7422,0.6539, 0,-0.095,0, 1.25,0.87,1.25
    }
}

#21 Updated by Anth12 about 1 year ago

51582

Created a test craft with a better weight distribution to stop the craft from flipping or ending up with any obvious exposure to the heat.

The terrier is definitely getting toasty as if there was no heat shield at all.

#22 Updated by Anth12 about 1 year ago

51583

This last picture is of the old terrier to show them working perfectly in regards to temperature

How hard would it be just to tell KSP that the new terriers have the same drag cube information as the old terriers?

Might be an easy fix? (still not entirely sure how drag cubes work)

#23 Updated by FishMittens about 1 year ago

Anth12 see my note : #23924-20 for a temporary fix

#24 Updated by Anth12 about 1 year ago

I saw that. Certain bugs I find quite interesting.
This bug is concerning to me but its not the end of the world.

Using the old terrier is a way of giving Squad more information on possibly how to fix the issue.

I will just use the old terrier until this issue is fixed, no idea what your adjustment to the partsdatabase file actually does specifically

Your information is also more information to squad im betting. Lets hope the fix is coming at some point

#25 Updated by AHHans about 1 year ago

victorr wrote:

We've made some changes in the latest build and would like some input on this issue please. Thanks.

Does it work correctly when you run the test scenario that I attached to this bug report? (The "10mHeatshieldTest.sfs") I feel a bit like a broken record repeating the same stuff over and over. :-(

#26 Updated by Anth12 about 1 year ago

Didnt work for me AHHans. Even after deleting the partsdatabase file.

But I am almost OCD with bugs I test.
Thats why I made a new craft that doesn't flip or rotate.
Then I added another one with the old terrier that does work correctly to indicate to Squad differences...

Still...why are bugs being set to "Ready to Test" when they are obviously still broken?
We spend a lot of time creating bug reports, and then testing to see if they are fixed. Then retesting to confirm they aren't fixed...

Its good to have the public reporter confirm they are fixed....but only really if Squad have already confirmed they are fixed themselves. Right?

Edit:Oh...yours only flipped when I was physwarping. Doesnt matter, still not fixed

#27 Updated by just_jim about 1 year ago

51603

I just did a few different tests in 1.9.1... I don't know exactly what's happened, if it's a regression, or a secondary issue separate of the partdatabase issue mentioned above (which I now suspect) but I am seeing the same issue with just the terrier engine
I am so sorry, but yes, I agree this is not fixed.

#29 Updated by just_jim about 1 year ago

  • Assignee set to just_jim

#30 Updated by AHHans about 1 year ago

51633

just_jim wrote:

I just did a few different tests in 1.9.1... I don't know exactly what's happened, if it's a regression, or a secondary issue separate of the partdatabase issue mentioned above (which I now suspect) but I am seeing the same issue with just the terrier engine

I also only see it with the terrier engine.
I just did a quick test: a craft with two terrier engines, one a bit more than 21m from the heat-shield, and one a bit less. Guess which one gets hot and which doesn't. ;-) (See attached screenshot.)
So, yes, the 21m that show up in the PartDatabase do play a role somehow.

I am so sorry, but yes, I agree this is not fixed.

No problem. As long as it does get fixed.

#31 Updated by Anth12 about 1 year ago

Wow, I love that craft AHHans. Testing it for the length. Genius.

#32 Updated by AHHans about 1 year ago

51732

Another quick test that came to my mind: turning the terrier around. As you can see in the attached screenshot a terrier that is turned around does not get the extra heating.

#33 Updated by just_jim 10 months ago

  • Status changed from Not Fixed to Ready to Test
  • % Done changed from 50 to 80

This should be working now in 1.10

#34 Updated by Anth12 10 months ago

53463
53464

From my testing it seems to be working correctly now.

The heating is correct + my other craft which had the terrier explode on collision with the water when it wasnt near the water survives.

AHHans what do you think?

#35 Updated by AHHans 10 months ago

just_jim wrote:

This should be working now in 1.10

Indeed. I only did a quick test, but this seems to be fixed now in 1.10.

#36 Updated by just_jim 9 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

It looks good on my end, and based on comments #34 &35, I think it's safe to call this one resolved.

Also available in: Atom PDF