Project

General

Profile

Bug #23966

Major Temperature Differences between 1.7.3 and 1.8

Added by Anth12 over 1 year ago. Updated over 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
Category:
Physics
Target version:
Start date:
10/19/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US), Italiano (Italian)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

KSP 1.7.3 + MH + BG
KSP 1.8 + MH + BG

Following two Screenshots show a major issue with temperature differences on entering the atmosphere

Physics Test 1-7-3.sfs is the save I used for both versions. wait for 50000m to see the same result

I deleted the PartDatabase.cfg, Physics.cfg and settings.cfg so that KSP would rebuild them for both versions. settings was then adjusted for audio and version watermark only.

Physics Test 1-7-3.sfs (135 KB) Physics Test 1-7-3.sfs Anth12, 10/18/2019 10:49 PM
1.7.3.png (767 KB) 1.7.3.png Anth12, 10/18/2019 10:50 PM
1.8.png (830 KB) 1.8.png Anth12, 10/18/2019 10:50 PM
SSTO small V2.craft (93.8 KB) SSTO small V2.craft [email protected], 10/18/2019 11:43 PM
screenshot136.png (1.8 MB) screenshot136.png SiWalder, 10/19/2019 11:45 AM
SSTO Hawk v2_1 Crewship.craft (103 KB) SSTO Hawk v2_1 Crewship.craft SiWalder, 10/19/2019 11:45 AM
KSP.log (1.62 MB) KSP.log Anth12, 10/22/2019 05:10 AM
Player.log (2.38 MB) Player.log Anth12, 10/22/2019 05:11 AM
49564
49565
49590

Related issues

Related to Kerbal Space Program - Bug #23978: Parachute drag is different from 1.7.3 to 1.8.0 Closed

Related to Kerbal Space Program - Bug #23924: Terrier engine not shielded by heatshieldsResolved10/17/2019

History

#1 Updated by [email protected] over 1 year ago

Confirmed, with a similar craft, attached.
As a temporary compensation, players can reduce 'Convection Factor' in alt-F12 settings or machConvectionFactor in physics.cfg from 7 down to 1.

As a workaround, players who have 'PartDatabase.cfg' from an older working version can copy that file into the KSP-1.8.0 directory and edit to say "version = 1.8.0.2686" delete the line with "version = ..."

#3 Updated by SiWalder over 1 year ago

49590

Confirmed with all my SSTO planes. I posted this in the forum and found others had been having the same issue.

"on re-entry the right wing begins to overheat almost immediately upon getting under 70k.
If I'm returning from LKO it survives, but remains right on the brink of exploding all the way to landing, even when stationary having landed the gauge is still there and is still over 70% of the way to exploding.
some other parts of the plane have a similar issue but to a lesser degree. the left wing has the issue but doesn't get as close to exploding as the right wing. I've messed around with the angel and whatever I try the wind or components on the right side of the screen are always hotter than the left. I rebuilt the craft from scratch in the new build I still got the identical issue.
If returning from anywhere beyond LKO (i.e Mun, Minmus even HKO) I can kiss the wings goodbye."

#4 Updated by hihosilver28 over 1 year ago

I don't know if this can be changed, but I would recommend changing the priority for this from "Low" -> "Normal". This is something that does not break the game, but it does severely affect the ability to play it as intended.

#5 Updated by Anth12 over 1 year ago

Getting into the Kerbin Atmosphere is one thing, getting into the Eve Atmosphere is way harder in pre 1.8. Now its considerably harder than it should be

#6 Updated by Kergarin over 1 year ago

In combination with the drag bug(?) this breakes the game and should be both rated high.

Example:
a booster reentering from 72km at almost orbital speed when crossing 30km from same savegame:

1.7: surface speed 1.872m/s, drag 25,730 kN, convective heat 707.852.000kJ

1.8: surface speed 2060m/s, drag 11,861kN, convective heat 2.040.896.000kJ

#7 Updated by BeanThruster over 1 year ago

  • Expansion Breaking Ground, Making History added
  • Language Italiano (Italian) added

Kergarin wrote:

In combination with the drag bug(?) this breakes the game and should be both rated high.

Example:
a booster reentering from 72km at almost orbital speed when crossing 30km from same savegame:

1.7: surface speed 1.872m/s, drag 25,730 kN, convective heat 707.852.000kJ

1.8: surface speed 2060m/s, drag 11,861kN, convective heat 2.040.896.000kJ

Agree with that. I confirm this behavior.
I would also mention the asymmetric overheating, that is, the right wing on a ssto ((both ascending or descending) is more prone to overheating. I’m not completely confident with this, but I would also add that this happens when the nose is pointing above the prograde marker. If you pitch down below the prograde marker, then the “preferred “ overheated side becomes the left one.
This bug however is not only about overheating in an atmosphere, but it is probably related with weaker drag and, as such, it strongly affects two of the main phases of a mission, that is, ascending and descending. I would recommend rising its priority, since it completely breaks the game balance.

#8 Updated by [email protected] over 1 year ago

Many entries in 'PartDatabase.cfg' are changed in ways that look like errors.

If I copy that file from a previous installation (version 1.7.3) and delete the line with "version = ..." then I avoid the aerodynamics errors, including the excessive heating on re-entry.

#9 Updated by Anth12 over 1 year ago

So both the drag and the temperature issues are related, probably the same issue. Hopefully makes for an easy fix

#10 Updated by just_jim over 1 year ago

  • Assignee set to just_jim

#11 Updated by just_jim over 1 year ago

  • Related to Bug #23978: Parachute drag is different from 1.7.3 to 1.8.0 added

#12 Updated by just_jim over 1 year ago

  • Related to Bug #23924: Terrier engine not shielded by heatshields added

#13 Updated by Anth12 over 1 year ago

just_jim maybe these logs will help?

I was entering into the atmosphere and checked the console and found errors as the following were spamming

ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
at System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgument argument, System.ExceptionResource resource) [0x00029] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
at System.ThrowHelper.ThrowArgumentOutOfRangeException () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
at KSP.UI.Screens.Flight.TemperatureGaugeSystem.Update () [0x001b8] in <5b6ca6486e0b47a1bce39cde5a91b986>:0

#14 Updated by vrampal over 1 year ago

Looks like the following issues are all related:

https://bugs.kerbalspaceprogram.com/issues/23924
https://bugs.kerbalspaceprogram.com/issues/23961
https://bugs.kerbalspaceprogram.com/issues/23966
https://bugs.kerbalspaceprogram.com/issues/23997

Fairing, heat-shield or any other part does not deflect the re-entry air flow.

#15 Updated by SiWalder over 1 year ago

I've just tested the 1.8.1 update and can confirm the issue is resolved for me. I appreciate the speedy fix, thanks x

#16 Updated by Anth12 over 1 year ago

Im not so sure yet. I had a craft blow up when it shouldn't have in one of my tests.

#17 Updated by hihosilver28 over 1 year ago

I second @SiWalder that this seems to have fixed the issue for me. Granted, I believe that the aerodynamics still behaves differently between 1.7.3 -> 1.8.1, but I think that it falls well within reasonable bounds. I'm no longer seeing the right wing heat first, or massive heat right at reentry. Everything seems to behave as expected. Thank you, Squad!

#18 Updated by Anth12 over 1 year ago

I have had issues with the temperature on testing, but it doesn't happen all of the time.
Not entirely sure how to reproduce it. Thought it changed while playing ksp for a while but that didnt work.

Anything in the code that could somehow have the game change the temperature/drag after the game has started
or am I just going crazy?

#19 Updated by just_jim over 1 year ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#20 Updated by just_jim over 1 year ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.8.1
  • % Done changed from 30 to 80

#21 Updated by Anth12 over 1 year ago

Hold off resolving this one please. I am doing more testing

#22 Updated by Anth12 over 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Testing done. I cant get the problem to happen again. Maybe I was in 1.8.0 thinking I was in 1.8.1.
My Eve Rocket can get into the atmosphere and out again as per 1.7.3
Resolved

#23 Updated by chris.fulton over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF