Project

General

Profile

Bug #23997

Some parts are not being shielded from airstream by the fairings

Added by iulianf over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
Physics
Target version:
Start date:
10/21/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

After the last release (1.8.0) I noticed that some parts ("MK2 cockpit", and MK2 to 1.25 Adapter Long" among them) are not being shielded by the fairings, even they are fully enveloped by the fairings.

screenshot631.png (2.66 MB) screenshot631.png iulianf, 10/21/2019 05:04 PM
screenshot633.png (2.6 MB) screenshot633.png iulianf, 10/21/2019 05:04 PM
Fairing_bug 1_0.craft (33.2 KB) Fairing_bug 1_0.craft iulianf, 10/21/2019 05:12 PM
1.7.3 Fairing Bug.png (951 KB) 1.7.3 Fairing Bug.png Anth12, 10/22/2019 01:55 AM
1.8.0 Fairing Bug.png (1.01 MB) 1.8.0 Fairing Bug.png Anth12, 10/22/2019 01:55 AM
Anth1256 1_7_3 Version.craft (24.7 KB) Anth1256 1_7_3 Version.craft Anth12, 10/22/2019 01:56 AM
Fairings not shielding larger parts.png (2.33 MB) Fairings not shielding larger parts.png victorr, 10/22/2019 03:48 PM
49643
49644
49671
49672
49694

History

#2 Updated by Anth12 over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Confirmed, but this isn't straight forward.
I can put 2 longer girder segments on top of each other and the top one will show drag and the one on the bottom wont.

I tested a few of the other fairings and they didnt have any problem at all.

I will look into this a big later, I want to see if the drag cubes are different from 1.7.3 and 1.8

Definitely doesnt happen in 1.7.3

#3 Updated by Anth12 over 1 year ago

49671
49672

Here is an additional 2 screen shots that might put light on this issue for comparison.

Plus a craft that is compatible with 1.7.3.

I wonder if this is related to the drag/heat issues?

#4 Updated by Anth12 over 1 year ago

Further testing shows the next fairing 1.875 does have some issues.

#9 Updated by casualMLG over 1 year ago

I discovered that from certain height upwards the fairings don't shield anything. The height is different for different fairing models and seems to start from the distance where interstage nodes end for every fairing respectively. Here is my reddit post about it: https://www.reddit.com/r/KerbalSpaceProgram/comments/dkmpsm/fairings_are_bugged_from_certain_height_upwards/?utm_source=share&utm_medium=web2x

Edit: Seems to be fixed in 1.8.1

#10 Updated by vrampal over 1 year ago

Looks like the following issues are all related:

https://bugs.kerbalspaceprogram.com/issues/23924
https://bugs.kerbalspaceprogram.com/issues/23961
https://bugs.kerbalspaceprogram.com/issues/23966
https://bugs.kerbalspaceprogram.com/issues/23997

Fairing, heat-shield or any other part does not deflect the re-entry air flow.

#11 Updated by victorr about 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.9.0
  • % Done changed from 10 to 80

We have made changes in this last release and would like your feedback please.

#12 Updated by [email protected] about 1 year ago

It does seem to have been fixed in release 1.8.1, mentioned in comment #9, but then

victorr wrote:

We have made changes in this last release and would like your feedback please.

What are these changes in 1.9.0? Do you suspect a regression ?

#13 Updated by [email protected] about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

I cannot find any relevant change, and the behaviour remains the same as on 1.8.1 on the example craft.

Also available in: Atom PDF