Project

General

Profile

Bug #27204

Place Anywhere 1 Linear RCS Port wrong thrust direction

Added by Pkunzipper 28 days ago. Updated 11 days ago.

Status:
Confirmed
Severity:
Low
Assignee:
Category:
Parts
Target version:
-
Start date:
02/01/2021
% Done:

10%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Patch 1.11.1 has introduced a new bug on Place Anywhere 1 Linear RCS Ports.
In 1.11.0 they worked fine but now they have the wrong thrust vector or maybe just fire with the wrong translation command.
In example I had a craft that worked fine in 1.11.0, but now the 4 little RCS ports pointing "forward" don't work anymore when I press H key, instead they fires whan I press J key for left translation.

Every other RCS port part seems to work fine, I guess the problem has been introduced when the Devs worked at the new shrouded variant.

1.11.0 Press J.png (923 KB) 1.11.0 Press J.png Anth12, 02/13/2021 02:06 AM
1.11.1 Press J.png (930 KB) 1.11.1 Press J.png Anth12, 02/13/2021 02:06 AM
QS 1_11_0 RCS Tester.sfs (170 KB) QS 1_11_0 RCS Tester.sfs Anth12, 02/13/2021 02:06 AM
RCS Tester 1_11_0.craft (96.2 KB) RCS Tester 1_11_0.craft Anth12, 02/13/2021 02:06 AM
RCS Test.craft (184 KB) RCS Test.craft vtk, 02/17/2021 03:47 PM
56172
56173

History

#1 Updated by victorr 19 days ago

  • Assignee set to victorr

#4 Updated by RafaHdz 16 days ago

  • Status changed from New to Need More Info

#6 Updated by RafaHdz 16 days ago

We can't reproduce this issue. The particles come out straight from the nozzle. A video or screenshot would be nice.

#7 Updated by antivalenz 16 days ago

does this link help? the size of the video file is a little more than 100MB.

https://ufile.io/z9qi5oan

#8 Updated by freebirth_toad 16 days ago

RafaHdz wrote:

We can't reproduce this issue. The particles come out straight from the nozzle. A video or screenshot would be nice.

I'm experiencing the same bug in Linux, so it's not a platform-dependent problem.

The animation is correct, it's that the wrong RCS control activates the thruster. Steps to reproduce:

  1. Build a simple probe with a single one of these RCS ports on the bottom, then cheat it into orbit.
  2. Turn on RCS and then press 'h' (to activate foreward translation via RCS).
  3. Note that the thruster does not fire. One of the port/starboard or dorsal/ventral controls ('i','j','k','l') will though.

#9 Updated by Anth12 16 days ago

56172
56173

GOG KSP 1.11.0 (no mods/no DLCs)
GOG KSP 1.11.1 (no mods/no DLCs)

1.11.0 Press J.png shows what happens when J is pressed using 1.11.0
1.11.1 Press J.png shows what happens when J is pressed using 1.11.1

QS 1_11_0 RCS Tester.sfs is the quicksave loaded for the above test

RCS Tester 1_11_0.craft is the craft I used to test it. (its similar to the one in antivalenz because I used it to test his video)

Note I took the RCS port and rotated it to see its range.
There is definitely a problem

#10 Updated by Anth12 16 days ago

The ones on the 1.11.1 Press J.png firing up and down think they are firing port/starboard

#11 Updated by Snark 12 days ago

I've observed the same problem myself, in 1.11.1. Reproduces.

Here's someone on the KSP forum who ran into the problem and posted it:
https://forum.kerbalspaceprogram.com/index.php?/topic/200403-how-can-i-get-the-new-place-anywhere-1-linear-rcs-port-working/

#12 Updated by RafaHdz 12 days ago

  • Status changed from Need More Info to Confirmed
  • % Done changed from 0 to 10

#15 Updated by vtk 11 days ago

I've confirmed this bug, and can also detail some specifics. While the particle animation is oriented as the user expects, the part behaves as if the nozzle is pointed in a ship's "forward" direction if placed in its default orientation on the side of a part with the same orientation as the root part (let's call this the logical thrust vector). This behavior is expressed in two ways: the RCS port activates when it would be appropriate to do so according to its logical thrust vector and position on the ship; and the actual force applied to the ship is opposite the logical thrust vector.

I notice that in the part .cfg file, the MODEL_MULTI_PARTICLE node has the line localRotation = -90, 0, 0, while the MODULE node with name = ModuleRCSFX contains no such rotation information. On the other hand, the same seems to be true in the mutli-nozzle thruster blocks, and I can't find the .cfg file for the Place Anywhere 7 to compare, so maybe the problem isn't in the .cfg file.

I've attached a craft file which clearly demonstrates the problem. There are 80 thrusters mounted to the side of an RCS propellant tank, oriented such that they appear to point outwards but their logical thrust vector is downwards. They are all set to "fore by throttle" so as soon as RCS is turned on, the craft lifts off from the pad. If the problem is corrected, these thrusters should not respond to the throttle, as they are facing perpendicular to the vessel's forward direction; nor should they cause the vessel to lift off the pad when activated, as they are facing horizontally at launch.

Also available in: Atom PDF