Project

General

Profile

Bug #25881

Can no longer perform many-to-one or one-to-many fuel transfers as of KSP 1.10

Added by Dunbaratu 7 months ago. Updated 2 months ago.

Status:
Resolved
Severity:
Normal
Assignee:
-
Category:
Fuelflow
Target version:
Start date:
08/01/2020
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I don't know if this is caused by the same thing as bug #25694, but just in case it isn't, I'm mentioning it separately.

Select 3 or more fuel tanks in flight with ALT (so all their PAWs stay open). All the fuel tank's PAWs show the fuel transfer buttons "In" and "Out".

What it used to do prior to KSP 1.10:
  • If you click on "out" on one of the tanks, it sends fuel to all the other tanks that have their PAWs open.
  • If you click on "in" on one of the tanks, it sucks fuel from all the other tanks that have their PAWs open.
What it started doing in KSP 1.10 (and KSP 1.10.1):
  • If you click on "out" on one of the tanks, it only sends fuel to one of the other tanks. The rest of the tanks with their PAWs open do not participate in the fuel transfer at all.
  • If you click on "in" on one of the tanks, it only sucks fuel from one of the other tanks. The rest of the tanks with their PAWs open do not participate in the fuel transfer at all.

History

#1 Updated by ZeroG 7 months ago

I have the same behvaior; I seem to be able to clear the "caching" problem from 25694 by timewarping, but I can't at all transfer from multiple tanks to a single tank evenly (which occasionally can be a really big problem, as that feature is needed to keep COM balanced).

#3 Updated by Robert.Keech 7 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#4 Updated by jclovis3 7 months ago

To add to the details on this, I can sometimes transfer from many to one, but I have to select the source tank first, then lock the PAW and select all the destination tanks. Start the OUT push from the source tank, and the fuel transfers into the destination tanks evenly. The same can be done if the source tank were to pull from the other tanks. What breaks is when I then change the selection to other tanks, either source or destination, and the conditions vary at that point.

I've noticed that during the transfer, when all the destination tanks are full, the source tank continues to show the STOP button while all the others revert to normal non-transfer indications. Seems to be the case regardless of weather I use warp to speed up the transfer. Having to deselect and reselect all the desired tanks over and over is really tedious, and most of the time, I have to go to warp for a quick and then drop out when no tanks are selected.

Maybe it's about time we introduce ship to ship fuel transfers through docking ports and grabbing units that simply say IN or OUT on the port's PAW (saving us from having to select multiple tanks in the first place) and all fuel is drained from one ship in order of priority, and refilled into the other ship in reverse order of priority. The converters need to be fixed to also work in reverse order of priority when refueling from ore as well.

#5 Updated by Technicalfool 6 months ago

  • Severity changed from Low to Normal

#7 Updated by Chemist933 6 months ago

  • Expansion Breaking Ground, Making History added

I am having this same issue on the un-modded version of my game especially when trying to transfer fuel from a fuel tank on an orbital station to a smaller craft and vis versa. I have found that sometimes switching between the craft that is having the fuel transfer issue to another craft on a different planetary body and back again fixes it for the first few tanks, but the bug always returns and prevents further fuel transfer. That being said, I have also noticed that some tanks when reselected will display the "stop" command even though it had stopped transferring and returned to the default "in" "out" screen. Lastly, I have found that this bug will effect monopropellant tanks of all varieties and will also display the odd "stop" bug as well.

#8 Updated by Anth12 3 months ago

related to Bug #25694

#9 Updated by Anth12 3 months ago

So switching between two vessels can stop the bug from happening. interesting

#10 Updated by Anth12 3 months ago

Using GOG KSP 1.10.1 (no DLCs)

It happens with just the core game. its not Making History or Breaking Ground related

#11 Updated by victorr 2 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.11.0
  • % Done changed from 10 to 80

#12 Updated by Dunbaratu 2 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

The many-to-one and one-to-many transfers now seem to work again. I think this is fixed.

Also available in: Atom PDF