Project

General

Profile

Bug #25694

Action menus are incorrectly remembering each other when related to fuel transfer.

Added by Anth12 10 months ago. Updated 4 months ago.

Status:
Resolved
Severity:
Low
Assignee:
-
Category:
UI
Target version:
Start date:
07/03/2020
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

https://youtu.be/mkF6INzcWzA

The video shows that the action menus are remembering information
which breaks the menus when closing them while transferring fuel.

Once a menu is closed, it and all other menus open should forget they are related.

History

#1 Updated by Anth12 10 months ago

Directly related to #25680

#2 Updated by dxmason87 9 months ago

I have tried to reproduce this on 1.9.1 and was unable to reproduce this. I find that on 1.10 this is very easily reproducible.

#3 Updated by Dunbaratu 9 months ago

KSP 1.10's changelog notes that lots of new caching logic was added to the part action windows. This issue feels exactly like a dirty cache bug - as if stopping a fuel transfer leaves a leftover cached variable value somewhere.

#5 Updated by victorr 4 months ago

  • Status changed from New to Ready to Test
  • Target version set to 1.11.0
  • % Done changed from 0 to 80

We've made some changes to the game in this latest version and would like to have some feedback on this issue. Thanks.

#6 Updated by Anth12 4 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Retested it in 1.10 and then 1.11. Its working well now

Also available in: Atom PDF