Project

General

Profile

Bug #25680

Fuel Transfer stops working after the amount of fuel in the tank has changed.

Added by dok_377 11 months ago. Updated 3 months ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Gameplay
Target version:
Start date:
09/07/2020
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

The fuel transfer can just stop working randomly after the amount of fuel in the tanks has changed (by draining or if the engine was running). At least I think that's what causes it.

Don't really sure about the cause, but I recorded a video and gathered all the log files, hope you guys can figure this one out.
I'm sorry about the lack of information in this one, but I really don't know what causes it.

Video with possible reproduction steps: https://youtu.be/3dgfEm_npcA

Fuel Transfer Craft.craft (25.3 KB) Fuel Transfer Craft.craft dok_377, 07/02/2020 02:16 PM
Logs.zip (143 KB) Logs.zip dok_377, 07/02/2020 02:23 PM

History

#1 Updated by dok_377 11 months ago

For some reason log files don't want to attach here. Attaching the zip archive instead, it contains KSP.log and Player.log files.

#2 Updated by dok_377 11 months ago

  • Description updated (diff)

#3 Updated by dok_377 11 months ago

It can be fixed by simply timewarping for a second (as shown in the video) or by changing scenes.

#5 Updated by RafaHdz 10 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#7 Updated by Anth12 10 months ago

Nice dok_377. I have been trying to figure this out too.

In my case the easiest way to get it to work is the following
1. Open the two tank action menus
2. Transfer fuel
3. Close either/both of the menus while transferring fuel
4. Open both menus and attempt to transfer fuel

Your video shows that there might be multiple causes.

#8 Updated by Anth12 10 months ago

I added a bug report #25694 which should be directly related to this one with a bit more information

#9 Updated by MechBFP 10 months ago

I've also experienced this. No mods, clean install. Sometimes just closing the tank menus and trying again will cause it to work.

#10 Updated by boolybooly 10 months ago

  • Expansion Breaking Ground, Making History added

I can confirm this is a problem in 1.10.0.2917 unmodded.

e.g. I just docked a craft with three tanks in one section to another craft which also had three tanks in one section.

Call them tanks A,B,C and A' B' C'.

I transferred fuel from C' to C OK.
Then I tried to transfer B' to C but it would not transfer.
A' to A would transfer OK.
B' to any tank ABC would not transfer but would transfer to A'.
A' would not now transfer to any tank ABC though it has previously done so.

I returned to tracking and then back to the craft and was able to complete transfers OK.

#11 Updated by problemecium 10 months ago

  • Expansion deleted (Breaking Ground, Making History)

I too confirm experiencing this bug.
To add more complexity and confusion, sometimes fuel will transfer, but not among the currently selected group of tanks, rather the tanks that had been transferring fuel previously, continuing as if I had not changed the selection but simply hit the button again.
At least one time fuel transfer failed to work to begin with when I entered the Flight scene and selected more than two tanks. Transfer only seemed to work between pairs of tanks.
The F5/F9 technique restores fuel transfer functionality temporarily, but the bug remains so in order to perform multiple transfers it is necessary to do this over and over. Since KSP has various memory leaks, this inevitably leads to high memory usage and poor stability and performance, necessitating a restart of the program or inviting a crash.
I do not have any DLC installed, so I can confirm this is not a DLC-related issue.
I did not see any messages in the Alt+F12 window or KSP.log related to fuel transfer or any error messages appearing to correlate with attempts to transfer fuel, so in all likelihood this is not a case of a runtime exception.

My apologies if I wasn't supposed to delete the notes on expansions. I thought it would only affect my update to the bug rather than the whole thing.

#12 Updated by digitao 10 months ago

  • Platform Linux added
  • Expansion Breaking Ground, Making History added

Seeing this on linux too, the specific repeatable ways I have found to break it are....

Let the tank fill and / or drain - no more transfers to / from either tank until warp / view change

click away from transfer without stopping it.

#13 Updated by dxmason87 10 months ago

problemecium wrote:

I too confirm experiencing this bug.
To add more complexity and confusion, sometimes fuel will transfer, but not among the currently selected group of tanks, rather the tanks that had been transferring fuel previously, continuing as if I had not changed the selection but simply hit the button again.
At least one time fuel transfer failed to work to begin with when I entered the Flight scene and selected more than two tanks. Transfer only seemed to work between pairs of tanks.
The F5/F9 technique restores fuel transfer functionality temporarily, but the bug remains so in order to perform multiple transfers it is necessary to do this over and over. Since KSP has various memory leaks, this inevitably leads to high memory usage and poor stability and performance, necessitating a restart of the program or inviting a crash.
I do not have any DLC installed, so I can confirm this is not a DLC-related issue.
I did not see any messages in the Alt+F12 window or KSP.log related to fuel transfer or any error messages appearing to correlate with attempts to transfer fuel, so in all likelihood this is not a case of a runtime exception.

My apologies if I wasn't supposed to delete the notes on expansions. I thought it would only affect my update to the bug rather than the whole thing.

I have this same issue mentioned here. The video in Bug#25694 displays this behavior (https://youtu.be/mkF6INzcWzA). From the conversation here, these appear to be separate observations, but may be related.

#14 Updated by bitnick 9 months ago

This bug is really annoying. Has someone come up with a work-around for multiple-tank transfers (e.g. if I want to fill all four radially-mounted tanks of my lander halfways, so a 1-to-4 transfer)?

For 1-to-1 transfers (and sometimes 1-to-2?) a short timewarp is a working work-around.

#15 Updated by flherne 9 months ago

I also experience this, on Linux with 1.10.1. Can confirm it's really annoying.

Hitting pause/unpause quickly seems effective as a workaround. Presumably for the same reason as timewarp, but slightly easier.

#16 Updated by Anonymous 8 months ago

  • Start date changed from 07/02/2020 to 09/07/2020

#17 Updated by HansAcker 8 months ago

FYI, I can work around the bug by quickly mousing over the resource panel. Opening and closing a PAW of a part that does not contain the same resources allows transfers once more:

https://www.youtube.com/watch?v=esS2hC2kbSk

Didn't the transfer buttons disappear in this case in earlier versions? I seem to remember that the buttons for a resource would only be visible if it could be transferred to/from all other selected parts and that I sometimes had to use the resource panel trick to get them back.

#18 Updated by maxsmacker 7 months ago

Just bumping this issue. It's not just fuel, it's any resource can be subject to this, and I don't think that you necessarily need the resource to be draining to get it. This hits spaceplanes especially hard, since there's no current way to know whether your center of mass is behind your center of lift except your spaceplane becomes uncontrollable. The usual cure is to frantically transfer fuel... When the fuel refuses to move randomly and none of the work-arounds (e.g. timework, save/restore) are available because you're in a spaceplane, well, crashes ensue.

#19 Updated by whitekvs 7 months ago

Severity: Low

I wonder, why this bug are marked as low-prioritized and still even not started fixing? It's totally annoying and brokes mid and late parts of game.
I am already started 2 or 3 new games in science mode at summer 2020; but my progress stopped at Kerbin orbit level on each attempt, because I can't refuel rockets. I tried save/load/etc, but without any stable results.
Last time I decided to wait while this bug will be fixed before next start; some time was passed, but this bug still have no progression. So sad.

#20 Updated by dok_377 7 months ago

whitekvs wrote:

Severity: Low

I wonder, why this bug are marked as low-prioritized and still even not started fixing? It's totally annoying and brokes mid and late parts of game.
I am already started 2 or 3 new games in science mode at summer 2020; but my progress stopped at Kerbin orbit level on each attempt, because I can't refuel rockets. I tried save/load/etc, but without any stable results.
Last time I decided to wait while this bug will be fixed before next start; some time was passed, but this bug still have no progression. So sad.

Maybe they can finally fix it in 1.11, which is going to be released probably before the end of the year. But I wouldn't count on it, considering the history of the several past releases.

#21 Updated by ZeroG 5 months ago

whitekvs wrote:

Severity: Low

I wonder, why this bug are marked as low-prioritized and still even not started fixing? It's totally annoying and brokes mid and late parts of game.
I am already started 2 or 3 new games in science mode at summer 2020; but my progress stopped at Kerbin orbit level on each attempt, because I can't refuel rockets. I tried save/load/etc, but without any stable results.
Last time I decided to wait while this bug will be fixed before next start; some time was passed, but this bug still have no progression. So sad.

Seriously, in what universe is this "low priority"? It breaks the game for any non-trivial mission. When's the last time anyone did a stock interplanetary mission without using fuel transfer? I get that it sometimes works and at the game is still basically playable without it, but this is beyond ridiculous at this point. How would I ever recommend this game to a friend if they're just going to get smacked in the face with a bizarre bug like this? I've got two thousand hours in this game; I knew quickly this was a bug when I hit it. How would a new player know the difference between doing something wrong and a bug? I don't at all understand how they just leave this bug hanging out. It's crazy.

#22 Updated by victorr 5 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.11.0
  • % Done changed from 10 to 80

We've made some changes to the game in this latest version and would like to have some feedback on this issue. Thanks.

#23 Updated by dok_377 5 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Don't see any problems with it.

#24 Updated by victorr 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF