Project

General

Profile

Bug #21915

Interstage fairings now hold on to decoupled parts

Added by dok_377 about 2 years ago. Updated 5 months ago.

Status:
Resolved
Severity:
Normal
Assignee:
Category:
Parts
Target version:
Start date:
04/17/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

How to reproduce: take a fairing, attach either a heatshield with enabled staging or some decoupler with a part beneath it to the fairing. It can be the main fairing node or interstage node, doesn't matter. Then close the fairing on a heatshield or a part. Launch craft, then try to decouple. Parts that supposed to be decoupled stay attached as if they are still on the same vessel, but they are not. You can switch to them as shown in the second video, but they behave as if they are still attached. When you enable time warp, physics completely fail and decoupled parts just fall to the ground and explode.
Video #1: https://youtu.be/7JU48QKtN8Q
Video #2: https://youtu.be/wvLroh3tsSc

And apparently it doesn't work only in one direction. Only if you try to decouple something from the fairing. If you decoupling the fairing itself, it works as intended.
Video #3: https://youtu.be/cuT0zviOW2M

Also, rcs doesn't work until you leave the render range of the fairing.

Video #4: https://youtu.be/PlzA5X7PfmQ

I think it has something to do with the root part of the vessel. If the fairing stays with the root part of the vessel, nothing is decoupling from it. If the fairing decouples from the root of the vessel (i.e. interstage of the rocket on the first stage with the root part on the second stage), then it's fine. See the attached video for demonstration.

Video #5: https://youtu.be/SgZHApejBs4


Related issues

Related to Kerbal Space Program - Bug #24798: Just a reminder. #21915Duplicate02/06/2020

Has duplicate Kerbal Space Program - Bug #24852: Interstage fairings now hold on to decoupled partsDuplicate02/13/2020

History

#1 Updated by dok_377 about 2 years ago

  • Description updated (diff)

#2 Updated by [email protected] about 2 years ago

  • File fairing.craft added

Before the fix to #20354, when a fairing spanned two parts of a craft, and those parts decoupled, the fairing would be dropped from the physics simulation.

Now, in version 1.7.0:
1) Such an interstage fairing remains physically active, and snugly holds the part on the detached craft that it was 'closed' onto (video 1 and 2 above)
if the fairing base is connected to the root part before decoupling.

2) The fairing continues to shield its contents from airflow, which in general is good because allows creative things like rescuing and recovering craft by re-entering them in cargo bays of other craft, and that shielding also generally prevents RCS from thrusting (video 4 above). Here, however, the fairing becomes open at one end, which generally turns off the shielding. KSP would preferably notice that the decoupling event has made the fairing ineffective.

Fairings do not have a decouple action---they never let go of attached parts---they only deploy their fairing shell. It looks like the designers' intention for using an interstage fairings was to deploy the shell before decoupling the craft that it joins.

Workarounds:
(1) if the fairing is closed on a part, probably we should be required to deploy it before it lets the part fly free. The workaround with putting root in the detached section depends on something that other players are likely to call a bug.
(2) after the craft are clear of each other, we can induce KSP to notice that the fairing no longer encloses the RCS thrusters by reloading physics (save/reload, or switch out of physics range and back). Alternatively, Module Manager can change the rules on shielded RCS
@PART[*]:HAS[@MODULE[ModuleRCSFX]] { @MODULE[ModuleRCSFX] { %shieldedCanThrust = True }}

#3 Updated by [email protected] about 2 years ago

  • File cylindricalFairing.craft added
  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

I was confused by the posts above with "If you decouple the fairing itself..". I see now that the situation there is "if the decoupler separates the fairing from the root part..."
By "fairings do not have a decoupler action" I only meant that there is no button to push on a fairing to say "let-go", only the button to say "open".

If the interstage fairing is a simple cylinder, appearing to go from the flat end of one stage to the flat end of the next (attached craft) it certainly looks like the fairing should allow separation, and usually it does. But, if the root part is on the side with the fairing base, after decoupling some strong force hold the two separate craft in position, until the fairing is deployed. Maybe a fairing has a function like struts between the base an part it is closed on, that is meant to auto-release when the parts are separated, and that auto-releasing no longer happens in some cases.

#4 Updated by [email protected] almost 2 years ago

  • File cylindricalFairing.jpg added
  • File cylindricalFairing.craft added
  • Subject changed from Interstage fairings broken. to Interstage fairings now hold on to decoupled parts

The way fairings hold on, to the part on which they were closed, will cause difficulty if anyone makes a traditional inter-stage fairing on a rocket with the root part below the fairing (as cylindrical Fairing attached) because the discarded stage has no control with which to deploy the fairing as is now needed.
This came up recently on the forum at https://forum.kerbalspaceprogram.com/index.php?/topic/187777-stuck-in-undeployed-fairing/

The problem with enclosed parts being considered stowed (which is resolved after a quicksave/quickload) came up recently on the forum https://forum.kerbalspaceprogram.com/index.php?/topic/185821-parachutes-not-deploying-while-stowed/ and https://forum.kerbalspaceprogram.com/index.php?/topic/187957-my-parachute-cant-open-up/

#5 Updated by [email protected] almost 2 years ago

  • File deleted (cylindricalFairing.craft)

#7 Updated by [email protected] over 1 year ago

This bug-tracker has never been a good place to get information from Squad, but it is useful for getting updates and workarounds from other players.

In version 1.8.1, the secondary problem mentioned above is solved: when we decouple from an interstage fairing, things like RCS that were unusable inside the fairing become usable. (With bug #23997, fairings sometimes fail to have any effect, but I made sure to test a case where the fairing does work.)

The primary bug remains: an un-deployed interstage fairing continues to hold on to decoupled parts, if the root part of the joined craft is on the part that stays with the fairing base after decoupling.

So, if we want to decouple from interstage fairings in 1.8.1 (without first 'deploying' the fairing to detach the fairing sides) then we need to set the root part of the craft to be one of the parts that detaches from the fairing base.

#8 Updated by Technicalfool over 1 year ago

  • Related to Bug #24798: Just a reminder. #21915 added

#9 Updated by dok_377 about 1 year ago

  • Subject changed from Interstage fairings now hold on to decoupled parts to 2
  • Description updated (diff)
  • Category deleted (Parts)
  • Private changed from No to Yes

#10 Updated by dok_377 about 1 year ago

  • File deleted (fairing.craft)

#11 Updated by dok_377 about 1 year ago

  • File deleted (cylindricalFairing.jpg)

#12 Updated by dok_377 about 1 year ago

  • File deleted (cylindricalFairing.craft)

#14 Updated by TriggerAu about 1 year ago

  • Has duplicate Bug #24852: Interstage fairings now hold on to decoupled parts added

#15 Updated by TriggerAu about 1 year ago

  • Subject changed from 2 to Interstage fairings now hold on to decoupled parts
  • Description updated (diff)
  • Category set to Parts
  • Severity changed from Low to Normal
  • Private changed from Yes to No

Looking at this bug it is being duped into new bugs (#24972 and #24852) which changes where it sits in the triage process/queue. Am restoring this ones content and voting it up to help it come up higher in triage as the original issue.

For reference info - the new copy has less votes, is set as being a bug found in 1.9.1 and has no history. This bug with more votes, constant comments and more history will receive attention earlier than new copies

#16 Updated by [email protected] about 1 year ago

51734

We lost the example craft, I think accidentally, so I attached a version of the stock example craft 'Kerbal 1' modified with an inter-stage fairing to demonstrate the issue.

If the root part is the booster tank, the fairing fails to let go of the upper stage.
If the root part is somewhere in the upper stage, the craft works as desired as in the screen shot.

Players who have this problem can escape it by selecting as root part something on the section of craft that leaves the fairing,
root part not in the section that is left connected to the fairing base.

#17 Updated by TriggerAu about 1 year ago

wrote:

We lost the example craft, I think accidentally, so I attached a version of the stock example craft 'Kerbal 1' modified with an inter-stage fairing to demonstrate the issue.

If the root part is the booster tank, the fairing fails to let go of the upper stage.
If the root part is somewhere in the upper stage, the craft works as desired as in the screen shot.

Players who have this problem can escape it by selecting as root part something on the section of craft that leaves the fairing,
root part not in the section that is left connected to the fairing base.

Unfortunately they dont appear to have been lost accidentally, thanks so much for attaching the craft file, will be super useful

#18 Updated by dok_377 about 1 year ago

This bug with more votes, constant comments and more history will receive attention earlier than new copies

Somehow I highly doubt that. There's a whole section of bugtracker that contains forgotten or lost bugs. You just need to check what was reported and if it was fixed or not. The percentage is not that great.

#19 Updated by dok_377 about 1 year ago

TriggerAu wrote:

wrote:

We lost the example craft, I think accidentally, so I attached a version of the stock example craft 'Kerbal 1' modified with an inter-stage fairing to demonstrate the issue.

If the root part is the booster tank, the fairing fails to let go of the upper stage.
If the root part is somewhere in the upper stage, the craft works as desired as in the screen shot.

Players who have this problem can escape it by selecting as root part something on the section of craft that leaves the fairing,
root part not in the section that is left connected to the fairing base.

Unfortunately they dont appear to have been lost accidentally, thanks so much for attaching the craft file, will be super useful

Because I basically wanted to create a new report so this bug received some attention at least, but even if I try to delete the previous report (which I tried to do here) - somebody just comes in and reinstates it and closes the more recent one. By doing that this bugreport is not going to receive attention AGAIN and will be lost forever without a fix.

#20 Updated by dok_377 about 1 year ago

I think it has something to do with the root part of the vessel. If the fairing stays with the root part of the vessel, nothing is decoupling from it. If the fairing decouples from the root of the vessel (i.e. interstage of the rocket on the first stage with the root part on the second stage), then it's fine. See the attached video for demonstration.

Video #5: https://youtu.be/SgZHApejBs4

And again, there IS information about there being an issue with the root node and its location right there in the bugreport. Not like this bug happens only on a particular craft or something. If you can't just take that info and build a simple craft (which takes less that a minute, for god's sake) using the attached video (which I DIDN'T DELETE) - I don't even know how to help you anymore.

#21 Updated by TriggerAu about 1 year ago

It feels like theres a few things being raised here, and Im happy to share insights;
  • Im sorry if you feel that you dont know what to do, but I tried to help by explaining that closing the older version and reporting as a newer bug that started in a newer version is detrimental to this report getting attention.
  • We dont simply look at the creation date or bug number of a report. Add comments if a new release comes out indicating that you feel this one deserves more attention, etc. It will be seen - as demonstrated by when this one was edited/closed we investiogated and got it back in the state where it is most likely to get triageds/assessed for assignment.
  • Whether an individual report is picked or not is a prioritization decision Im unable to discuss as im sure everyone understands
  • Having player created craft is immensely valuable as it helps us to confirm when fixing that we've solved the reporters issue more directly. I never said I was unable to create it myself, I simply expressed thanks to by for providing something we ask for and find very useful as a double up

Hopefully that gives you a little more, and we do appreciate the time and passion you spend on identifying bugs like this

#22 Updated by [email protected] 10 months ago

There is a change-log item for version 1.10 that sounds like it might pertain to this bug,
"* Fixed Interstage fairings holding onto the payload in certain use cases."
but it does not. There is no change to the behavior of the example craft.

Workarounds remain: (1) in the VAB, choose a part that stays attached to the fairing base to be the root part, (2) quicksave/quickload or switch to a distant craft and back to free the parts

#23 Updated by victorr 10 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.10.0
  • % Done changed from 10 to 80

We've made some changes in this latest version and would like some feedback on this issue.

#24 Updated by dok_377 10 months ago

victorr wrote:

We've made some changes in this latest version and would like some feedback on this issue.

Still present, but now it relates to the open-ended fairings as well, see #25660.

Also, I have a question. When the bug is not fixed like in this example, what are we supposed to set it to? "Not Fixed" or "Updated"? Or maybe don't touch it at all?

#25 Updated by [email protected] 10 months ago

  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50

#28 Updated by victorr 9 months ago

  • Assignee set to victorr

#29 Updated by victorr 5 months ago

  • Status changed from Not Fixed to Ready to Test
  • Target version changed from 1.10.0 to 1.11.0
  • % Done changed from 50 to 80

We've made some changes to the game in this latest version and would like to have some feedback on this issue. Thanks.

#30 Updated by dok_377 5 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Seems to be working well. Somebody should update and close #25660 as well, since it's related.

Also available in: Atom PDF