Project

General

Profile

Bug #13153

Maneuver Node Bug when two orbiting ships get close to each other

Added by Anth12 over 4 years ago. Updated over 2 years ago.

Status:
Closed
Severity:
Normal
Assignee:
-
Category:
Gameplay
Target version:
Start date:
10/31/2016
% Done:

100%

Version:
Platform:
Windows
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Steam 1.2.0.1586 64bit Clean Install. Kerbal Engineer 1.1.2: Career
GOG KSP 1.2.0.1586 64bit Clean Install. No Mods: Sandbox

Both saves were created in 1.2.0.1586
Steam:
1. Playing in Career with kerbal engineer 1.1.2
2. Two ships in orbit close together and I changed to the other ship.
3. Go to the map screen. Create a maneuver node
4. The maneuver node appears but the required deltaV and the estimated time does not.

GOG: So I tried this in Sandbox with a clean install using GOG version.

1. Playing in Sandbox
2. Tested two ships in close orbit of Mun. Bug confirmed
3. Tested two ships in close orbit of Kerbin. Bug Confirmed

Attached files:
screenshot0.png is to show the problem
screenshot1.png is how it should look
KSP.log GOG version
output_log.txt GOG version
QuickSave PreIntercept Kerbin/QuickSave PreIntercept Mun are before the ships are in range of each other but are on an intercept course
QuickSave Two Ships Close Kerbin/QuickSave Two Ships Close Mun are when both ships are close together. Use these to test bug


Related issues

Related to Kerbal Space Program - Bug #13005: Placing a Maneuver Node bugged after rescued Kerbal boards craft via EVAClosed10/14/2016

History

#1 Updated by Nebbie over 4 years ago

I believe I've encountered this, but just not narrowed it to the rendezvous being the cause. I had only noticed it after doing an EVA crew transfer or docking.

#2 Updated by EvilBroccoli over 4 years ago

can confirm this bug, and like Nebbie i found it also related to EVAs (haven't tried docking though)

in addition to losing the d/v and time to node i also lose the navball marker i figure you just forgot to mention it

#3 Updated by Anth12 over 4 years ago

GOG KSP 1.2.1.1604 64bit Clean Install. No Mods: Sandbox

Just updated my GOG version to the latest, the issue is resolved.

This is mentioned in the ChangeLog and I quote:

"Fix Maneuver Nodes not showing dV when target changes."

#4 Updated by bewing almost 4 years ago

  • Related to Bug #13005: Placing a Maneuver Node bugged after rescued Kerbal boards craft via EVA added

#5 Updated by bewing almost 4 years ago

  • Status changed from New to Ready to Test
  • Target version set to 1.3.0
  • % Done changed from 0 to 80

#6 Updated by MechBFP about 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Confirmed this is fixed.

#7 Updated by Anth12 about 3 years ago

Completely missed this. Sorry about that.

#8 Updated by joshua.collins over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF