Project

General

Profile

Bug #26922

EVA construction mode while on the surface lets left-shift "bleed through" to thrust the jetpack when placing or adjusting a part.

Added by Dunbaratu 5 months ago. Updated 3 months ago.

Status:
Ready to Test
Severity:
Low
Assignee:
Category:
Controls and UI
Target version:
Start date:
12/24/2020
% Done:

80%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

When an EVA engineer is in construction mode, you are supposed to have full access to the construction widgets and presumably that includes holding left-shift down in order to make angle-snap use smaller increments. (i.e. angle-snap without left-shift rounds to 15 degrees, but with left-shift it rounds to only 5.)

But if you entered construction mode while RCS was on, that left-shift key still causes your kerbal jetpack to thrust upward, defeating the purpose since you can't hold the camera still to adjust the part because your Kerbal is accelerating away.

What it does: In EVA construction mode while a part is being placed, moved, or rotated, left-shift activates BOTH fine-grain angle-snap and thrusts the jetpack upward.

What it should do: In EVA construction mode while a part is being placed, moved, or rotated, left-shift only activates fine-grain angle-snap and does NOT also thrust the jetpack. Once the part is no longer in hand, then it's okay to make the jetpack controls start working again.

screenshot4.png (1.08 MB) screenshot4.png Anth12, 12/25/2020 03:24 AM
55476

History

#1 Updated by Anth12 4 months ago

55476

Confirmed.

Work Around: turn off RCS.

#2 Updated by victorr 4 months ago

  • Subject changed from EVA construction mode lets left-shift "bleed through" to thrust the jetpack when placing or adjusting a part. to EVA construction mode while on the surface lets left-shift "bleed through" to thrust the jetpack when placing or adjusting a part.

#4 Updated by just_jim 4 months ago

  • Assignee set to just_jim

#5 Updated by Dunbaratu 3 months ago

The subject was changed by victorr and I can't change it back. The edit inserted the phrase "while on the surface". I want to make it explicitly clear that the reported bug did not occur on the surface. When I submitted this ticket I had experienced the bug while floating in space, NOT on the surface. The screenshot showing it happening on the surface was added later by Anth12.

It would be more correct to say it happens BOTH on the surface and not on the surface, and being on the surface has nothing to do with it. That's just pure coincidence that that's where the screenshot is taken from.

In fact, being floating in space is precisely why I had the RCS enabled. It was because I had just moved the kerbal over toward the area I wanted to construct things.

#6 Updated by victorr 3 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.11.1
  • % Done changed from 10 to 80

We've made some changes in the latest version of the game and would like some feedback on this issue. Thanks.

#7 Updated by Anth12 3 months ago

Jet Pack now doesnt work when Left Shift is used if a part is being gizmoed, and starts working again when a part isnt being gizmoed.
Space or on Land

Resolved.

#8 Updated by Dunbaratu 3 months ago

victorr wrote:

We've made some changes in the latest version of the game and would like some feedback on this issue. Thanks.

I agree with Anth12 - this seems to be fixed now when I tried it in 1.11.1.

Also available in: Atom PDF