Project

General

Profile

Bug #23962

MK3 Cockpit Lights Broken

Added by Muddr over 1 year ago. Updated over 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
10/18/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

The MK3 Cockpit (Shuttle) 'Toggle Lights' button is broken. It only says 'Toggle' and will throw an NullReferenceException when clicked.

When adding the part to SPH/VAB, the console prints the following message:

ModuleAnimateGeneric: Could not find animation component 'Mk3Cockpit_Shuttle' - on part mk3Cockpit.Shuttle failed to load! Check the model file

screenshot1.png (900 KB) screenshot1.png Anth12, 10/19/2019 02:39 PM
screenshot2.png (1.24 MB) screenshot2.png Anth12, 10/19/2019 02:39 PM
screenshot3.png (819 KB) screenshot3.png Anth12, 10/19/2019 02:39 PM
screenshot0.png (1.11 MB) screenshot0.png Anth12, 10/29/2019 10:48 PM
screenshot1.png (1.13 MB) screenshot1.png Anth12, 10/29/2019 10:50 PM
screenshot2.png (1.04 MB) screenshot2.png Anth12, 10/29/2019 10:50 PM
49595
49596
49597
50048
50049
50050

History

#1 Updated by Anth12 over 1 year ago

49595
49596
49597

Confirmed

Screenshot 1: shows the can not find animation component
Screenshot 2: shows that the action menu doesnt even have the option for lighting
Screenshot 3: shows exception when trying to turn on the light via the key 'U'

#2 Updated by jclovis3 over 1 year ago

Could be related to Bug #23915 "Lights won't turn on with keyboard shortcut or lights icon from next to altimeter"

#4 Updated by Cybot over 1 year ago

  • Expansion Breaking Ground, Making History added

the mk3 cockpit is also causing excessive 'bouncing' when any landing gear is used. no stress on landing gear is registered during the bouncing.

#5 Updated by vrampal over 1 year ago

Looks like the following issues are related:
https://bugs.kerbalspaceprogram.com/issues/23915
https://bugs.kerbalspaceprogram.com/issues/23962

Cockpit Mk3 lights are broken.

#6 Updated by klesh over 1 year ago

I can confirm that this is fixed in 1.8.1. I cannot move Status to Resolved.

#7 Updated by victorr over 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.8.1
  • % Done changed from 10 to 80

#8 Updated by Anth12 over 1 year ago

50048
50049
50050

No NullRefs or unusual log entries. Resolved

#9 Updated by chris.fulton over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF