Project

General

Profile

Bug #435

Unable to map non-English keys

Added by martscht about 8 years ago. Updated almost 5 years ago.

Status:
Updated
Severity:
Normal
Assignee:
-
Category:
Controls and UI
Target version:
-
Start date:
03/18/2013
% Done:

10%

Version:
Platform:
Linux
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I reported this in the forums, but was told to report it here. So here it is:

Problem:
I am unable to map keys specfic to the German language keyboard. Specifically, I am unable to map "ü", "ö", or "ä", which have designated keys on the german keyboard. When I try, the mapped key window says "none" and I am unable to use the key in-game.

Reproducability:
For all I have tried it seems that I am unable to map any character that is not included in English standard encoding. English characters that can be obtained on my German keyboard with some typing-gymnastics are mappable (e.g. the "]" which requires my AltGr + 9).

Version Specifics:
This is new to the Linux build of .19, because I was able to map these keys in .18.4 under Windows. I must admit though, that I have not tried it in .19 under Windows.

System Specs:
Running Ubuntu 12.04 (Precise) on Dell XPS 15z with German standard keyboard. I have checked out some stuff to ensure that is (most likely) not a system issue, i.e. the keys are mappable in other games and applications.


Related issues

Related to Kerbal Space Program - Bug #1561: Keyboard map is wrong with Italian layoutAcknowledged10/17/2013

Related to Kerbal Space Program - Feedback #3324: Full-Thrust Hotkey interferes with german Keyboard-LayoutNeeds Clarification10/08/2014

History

#1 Updated by martscht about 8 years ago

I knew I forgot something important, but in this setup of the bugtracker I seem to be unable to edit my original post, so here's an addition to the system specs: My Ubuntu 12.04 is setup as an English (US) locale - but it runs on a laptop I bought in Germany so the keyboard is German standard.

#2 Updated by SinPistones about 8 years ago

The game won't recognize the special character "Ñ" wich is present in spanish keyboards either.

#3 Updated by sr over 7 years ago

  • Platform Linux added

#4 Updated by Voidi over 7 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

can confirm this for ä, ö, ü and [, ] (changing vessel doesn't work with this standartmapping)
toggling navball in mapview (Period on the Numpad) doesn't not work either

#5 Updated by Lysius about 7 years ago

I can not map any keys that are not also present as a key on the US layout (öäüß´+#<) (although some are included in ASCII).
Most of the keys are located somewhere to the very right of the keyboard on the german standard layout and rarely used in games. But I normally use the german neo2 layout for typing, which has üöä on the keys that normally hold yxc (zxc on US layout) and so I have to change keyboard layout when playing KSP.
Currently have this problem with 0.23 on Linux (Fedora 20).

#6 Updated by TriggerAu almost 5 years ago

  • Status changed from Confirmed to Needs Clarification
  • % Done changed from 10 to 0

#7 Updated by ___ almost 5 years ago

  • Status changed from Needs Clarification to Updated
  • % Done changed from 0 to 10

Still an issue on 1.1.3 with both ASCII and non-ASCII keys.

Also available in: Atom PDF