Bug #27234

A EVA construction bug that moves the entire craft (pretty severe)

Added by Anth12 3 months ago. Updated 2 months ago.

Controls and UI
Target version:
Start date:
% Done:


Breaking Ground, Core Game, Making History
English (US)
Mod Related:
Arrow u r green
Arrow d r red


Steam 1.11.1 + DLCs

Video Evidence.

How to reproduce:
1. Load CraftMoverQS.sfs (which is attached to bug report)
2. Enter EVA construction mode
3. Grab the Small I-Beam
4. Press I to get out of EVA construction
5. Press I again.
6. Grab the Small I-Beam again

This is where I saw this happening:

If the part is clipped into the craft it will cause a violent reaction
That's why I had the small I-Beam gizmoed out from it.

CraftMoverQS.sfs (135 KB) CraftMoverQS.sfs Anth12, 02/08/2021 12:46 PM


#1 Updated by Anth12 3 months ago

Just need to watch the first 10 seconds of the YouTube video to see what happens.

#2 Updated by Anth12 3 months ago

Any testing on the ground ends with explosions

#3 Updated by [email protected] 3 months ago

This happened to me twice in the first days of 1.11 . I wanted to know what happened and now you showed me, thank you.

I made my own ship and tested it. It worked with an Ant, a Terrier, a cone, a small tank, but didn't work with a solar panel for some reason. Rapidly moving the ship doesn't destroy it, but some large Kraken forces happen when the ship collides with the engineer, either by sliding the ship into him or if you do the test while he is on the stairs. The highest forces I got accelerated Bill to 250m/s relative velocity.

#4 Updated by Krazy1 3 months ago

Me too. While the engineer was standing on the craft, I placed an Octo2 on a cubic octagonal strut and my whole craft was thrown and destroyed.

#6 Updated by RafaHdz 3 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#8 Updated by Anth12 3 months ago

Same bug different part
Though you did make me doubt myself for a moment (response to deleted post) so I retested with EJ_SA's part. same result

#9 Updated by Krazy1 2 months ago

Huge explosions happened again on a station in Mun orbit with the engineer on a ladder. Placing a part has about a 5% chance of destroying the entire station. Happened (1) while attaching a OX-4L 1x6 panel to a Jumbo-64 fuel tank. (2) attaching an Ant engine to a cubic octagonal strut.
NOTE: for case (2) the Esc key stopped working. I couldn't access the pause menu. I had to Ctrl-Alt-Del and kill KSP. This is bad.
Added more photos to [[]]
Also reference bug #27194

Also available in: Atom PDF