Project

General

Profile

Bug #27043

EVA Construction causes continuous Nullref when kerbal is holding onto the side of a pod and then attaches a ladder nearby. Also the Kerbal cant move after this is done

Added by Anth12 4 months ago. Updated 3 months ago.

Status:
Ready to Test
Severity:
Low
Assignee:
-
Category:
Gameplay
Target version:
Start date:
01/14/2021
% Done:

80%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

GOG KSP 1.11.0 (no mods/no dlcs)

Video Proof:
https://youtu.be/ItkRDSLthkA

First part of the video shows issue.
End of video shows work around which is to use rendevous (under setorbit) to move the kerbal away from the craft

'Test Save.sfs' for fast confirmation.

Saw this on EJ_SA's twitch channel

Test Save.sfs (136 KB) Test Save.sfs Anth12, 01/14/2021 09:36 AM

History

#1 Updated by Anth12 4 months ago

This also seems to happen when on a standard ladder as well

#3 Updated by Anth12 4 months ago

Clarifying last comment:

1. Kerbal on pod + adding ladder close to kerbal is the bug report
2. Kerbal on Ladder + adding ladder close to kerbal has a similar result but not quite the same

#4 Updated by Anth12 4 months ago

  • Subject changed from EVA Construction causes continuous Nullref when kerbal is holding onto the side of a pod and then attaches a ladder nearby to EVA Construction causes continuous Nullref when kerbal is holding onto the side of a pod and then attaches a ladder nearby. Also the Kerbal cant move after this is done

#5 Updated by Anth12 4 months ago

Kerbal cant move,
Quick Save wont work
Going to the main menu doesnt work
Going to KSC doesnt work.

#6 Updated by Anth12 4 months ago

Correction.

Quick Save wont work
Going to the main menu doesnt work
Going to KSC doesnt work.

#7 Updated by victorr 3 months ago

  • Status changed from New to Ready to Test
  • Target version set to 1.11.1
  • % Done changed from 0 to 80

We've made some changes in the latest version of the game and would like some feedback on this issue. Thanks.

#8 Updated by Anth12 3 months ago

1. Ladder shows up as Red restricting positioning close radially to the kerbal so I would say that its resolved.

2. #27044 which I reported about removing a ladder a kerbal is currently using is still happening (I am assuming this bug was internalized as I am getting a 403 error)

Also available in: Atom PDF