Project

General

Profile

Bug #26961

Unable to Save game in KSP 1.11

Added by djr5899 21 days ago. Updated 11 days ago.

Status:
Confirmed
Severity:
Low
Assignee:
Category:
Controls and UI
Target version:
-
Start date:
01/03/2021
% Done:

10%

Version:
Platform:
OSX, Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I am experiencing what looks to be a bug in KSP 1.11 where I cannot Save the game, and it appears the entire Escape menu system is not usable. I have removed any mods that I have installed, and I can still reproduce the issue. The issue appears to be related to the MK1-3 Command Pod and the RCS thrusters. By default, I disable the RCS thrusters on the pod, however, when attempting to redock with the Command Pod, the RCS thrusters visually look like they are enabled and thrusting (even though no thrusting forces are being exerted). It is at this point that I can no longer Save (or return to Tracking Station/Space Center).

How I am able to reproduce the issue (this is career mode, but I don't believe this makes a difference):

  1. I launch a craft that uses an MK1-3 Command pod, and has a lander craft attached via Clampotron docking port.
  2. I put my craft in orbit of the Mun, transfer Pilot and Scientist to Lander craft, and leave Engineer on return craft in orbit.
  3. Lander craft lands on Mun. I can save at this point.
  4. Lander craft leaves Mun surface and has an intercept point with MK1-3 Command Pod craft.
  5. While controlling the lander, with intercept but no visual on MK1-3, I am still able to Save.
  6. As soon as the lander craft gets within visual range of the MK1-3 Command Pod, I can see the visual RCS thruster on the MK1-3, and at this point, I can no longer save. I can also no longer hit Escape to go to Tracking Station/Space Center, and, if I do manage to get back to Kerbin surface, if I click Recover craft, nothing happens. Finally, the game also no longer auto-saves to the persistent save game.

Here is what I have tried to correct the problem, none of which has worked:

  • Attempted to use Quicksave
  • Attempt to enable, or enable and disabled, the RCS thruster setting on the MK1-3 command pod.
  • Use Alt-F12 and attempt to clear input locks.

I have attached two screenshots, 1 which shows the RCS thrusters firing while the MK1-3 command pod settings show that they are disabled, and the 2nd screenshot shows a NullReferencePointer error in the debug console.

This thread I created on the forums makes mention of at least one other person seeing a similar issue: https://forum.kerbalspaceprogram.com/index.php?/topic/199281-unable-to-save-game-in-111/

20210103144814_1.jpg (388 KB) 20210103144814_1.jpg djr5899, 01/03/2021 08:30 PM
20210103144753_1.jpg (390 KB) 20210103144753_1.jpg djr5899, 01/03/2021 08:30 PM
55563
55564

History

#1 Updated by victorr 19 days ago

  • Status changed from New to Confirmed
  • Assignee set to victorr
  • % Done changed from 0 to 10

Although I was able to escape the game and quicksave etc, I did get a number of NREs. We'll be investigating further. Thanks.

#3 Updated by nosdok 16 days ago

victorr wrote:

Although I was able to escape the game and quicksave etc, I did get a number of NREs. We'll be investigating further. Thanks.

I'm Alberto (login name 'nosdok')
I'm editing the quote from victorr because I don't know how to add my own comment.
I want to say that I have the same saving problem but in a different situation as victorr. If I try to save the game jsut nothing happens. When I press escape I return to the game but the game is not saved. In my case some ships also dissapear from my game as I press the [] buttoms and some menus become blank, like one on top right with summary of the fuels (Fx,Ox,Electricity,Xenon).

The game turned unplayable for me. I think this bug should be upgraded to Severity High.

I hope somebody is listening here about this problem.

#4 Updated by nosdok 16 days ago

  • Platform OSX added
  • Platform deleted (Windows)
  • Expansion deleted (Breaking Ground)

I just want to add that I'm using a MAC OS laptop with a eGPU Radeon RX 5700 XT in case that is relevant.

#5 Updated by maddog59d 16 days ago

  • Expansion Breaking Ground added

I'm editing because like 'nosdok' I don't see how to add my own independent comment.

I've run into the same problem while on EVA, not with any ships (so far): I've got Bill floating around with an SC-62 container on his back. I was able to do some construction (pulled parts out and mounted them w/ construction mode) w/o any problems, and was able to save games (Alt+F5) as normal. I got another part from a storage unit on another ship, put it in the container, and all seemed well until I tried to save the game (Alt+F5). Although I was able to input the save name, it wouldn't actually save the game; just no response from the menu. ESC closed the menu, but left the game paused; I had to tap ESC again to get it running. I tapped ESC again to bring up the 'Resume/Load/Save/Quit' menu and while I could Resume, Load, or go to Settings, the other menu buttons wouldn't work (Save, Quit, Space Center, Tracking Center). Reviewing the 'Load' menu, I could see that the save name that I'd input wasn't there.

#6 Updated by GewoonLukas_ 11 days ago

  • Platform Windows added

I have had the same issue on Windows. The following topic: https://bugs.kerbalspaceprogram.com/issues/27025 seems to relate to this topic.

Also available in: Atom PDF