Project

General

Profile

Bug #25930

Surface Deployed Science picking up bug

Added by inna.ironheart about 2 months ago. Updated about 1 month ago.

Status:
Confirmed
Severity:
Low
Assignee:
-
Category:
Deployed Science
Target version:
-
Start date:
08/07/2020
% Done:

10%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

For some reason I cannot pick up previously deployed science modules more than one time per scene load: the first one goes smooth, kerbal picks it up from the ground and places it into the cargo bay of the nearby spacecraft. When it comes to second time, a bug appears: module plays it's shutdown animation, but the inventory is empty. And also the game probably thinks that this module is currently in kerbal's inventory and the "Pick Up Part" button for any other module is inactive.

How to reproduce:
1. We need a kerbal on EVA, a craft with a cargo bay and some deployed science modules working.
2. Pick up the first one, place it into a cargo bay and return for next.
3. Press "Pick Up Part" button for any other module and here we go.

I have to reload the scene completely to regain the possibility of picking up these science parts or see second one that was placed in inventory (originally it was erroneusly "invisible").

History

#1 Updated by inna.ironheart about 2 months ago

Mods used: Scatterer, Chatterer, Tracking Station Evolved, Kerbal Alarm Clock, Texture Replacer and a bit of custom-painted flags, so none of my mods are tampering the gameplay mechanics.

#2 Updated by dok_377 about 2 months ago

Observing the same behavior. Might be related to issue #25701, which didn't get fixed in 1.10.1.

#4 Updated by just_jim about 1 month ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Also available in: Atom PDF