Project

General

Profile

Bug #25677

Comet Harvester not working

Added by ShadowZone 10 months ago. Updated 3 months ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Resources
Target version:
Start date:
07/02/2020
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I grabbed onto a comet with a vessel.
"Start Comet Harvester" does not do anything, I also don't get an information what's wrong or missing in the PAW.

I then cheated the exact same vehicle to the same comet and attached it, it works.
Then I transfered crew to the new vehicle, scuttled the old and then the new vehicle exhibits the same weird behavior.

Problem in action:
https://www.youtube.com/watch?v=AbW051h9ziA

Attached:
Craft file
Save game

Comet Catcher.craft (642 KB) Comet Catcher.craft ShadowZone, 07/02/2020 12:30 PM
persistent.sfs (764 KB) persistent.sfs ShadowZone, 07/02/2020 12:30 PM
tmp.craft (317 KB) tmp.craft ShadowZone, 07/02/2020 12:47 PM
Asteroid Miner 2.craft (230 KB) Asteroid Miner 2.craft Technophant, 07/05/2020 01:46 AM
persistent.zip (447 KB) persistent.zip Technophant, 07/05/2020 01:46 AM
Untitled.png (405 KB) Untitled.png simyo, 07/13/2020 12:02 AM
53560

History

#1 Updated by ShadowZone 10 months ago

Second craft file without mods. This is the one that worked at first but then did not after detaching the older one.

#2 Updated by RafaHdz 10 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Confirmed. Drill works normally when grabbing an Asteroid. Grabbing a Comet, the drill moves briefly and then stops.

#4 Updated by Technophant 10 months ago

Created an account to say ME TOO and this should be moved up in priority. Cheated a rendezvous with two different comets in this craft and once attached, the drill lowers, says "harvest comet", starts for half-second then quits, does not mine any ore. I troubleshooted any issues including contact locations and angles. Tried this craft with two other asteroids and it works fine.

The save file has one miner attached to a comet that's leaving the system and two attached to an asteroid orbiting Ike.

There's also an error with naming the comets. once I attached my craft it went from comet S-something to a random asteroid name. Mods used in craft, none. Mods used in game EVE, Lynx. Career mode not part of contract. Have not tried in other modes or as mission.

#5 Updated by arctangent 10 months ago

  • Platform Linux added

I think the problem is that the comet harvester copied the ImpactRange from the mini drill rather than from the large drill's asteroid harvester (1.5 rather than 5). .../GameData/Squad/Parts/Resources/RadialDrill/RadialDrill.cfg line 135

#6 Updated by simyo 10 months ago

53560

I did test this and the range seems to be an issue here.
Please consider this screenshot:

#7 Updated by ShadowZone 9 months ago

I was able to harvest a comet in 1.10.1

Anyone else can confirm that it is fixed?

#8 Updated by arctangent 9 months ago

Seems fixed for me too.

#9 Updated by just_jim 8 months ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#10 Updated by just_jim 8 months ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.10.1
  • % Done changed from 30 to 80

#11 Updated by just_jim 8 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#12 Updated by victorr 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF