Project

General

Profile

Bug #25666

The ability to "Merge" two crafts in the VAB/SPH no longer works in 1.10 in most situations.

Added by Anth12 3 months ago. Updated about 1 month ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
Editor
Target version:
Start date:
07/02/2020
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Using the merge button in the load screen in the Editor does nothing.

How to Test:
1. Dont use a new save to test this bug.
2. Use an existing save with existing crafts.
3. In the editor load one craft
4. Bring up the load screen and try to merge the current craft with another.

Additional Information:
Reason for not using a new save was that I was able to get merge to work with a new save with new parts.

Thanks goes to Thomas199920 on EJ_SA's discord for finding this

Recommend this bug be higher in priority.

History

#1 Updated by akslfak 3 months ago

  • Expansion Breaking Ground, Making History added

I also have seen this bug, vanilla KSP, no mods. Recommending a higher priority as it can be a game-breaking issue, especially when making larger craft. I can provide my game save if necessary, I'm just not sure what files are required to debug.

#2 Updated by ShadowZone 3 months ago

I have encountered this as well.

Neither craft from pre-1.10 nor craft directly created in 1.10 were willing to merge.

Seems like it's already being worked on: https://bugs.kerbalspaceprogram.com/issues/25725

#3 Updated by just_jim 3 months ago

  • Status changed from New to Confirmed
  • Assignee set to just_jim
  • % Done changed from 0 to 10

#4 Updated by Anth12 3 months ago

Work around:

1. Go into the SPH/VAB
2. Load a craft
3. Launch Craft
4. Revert to SPH/VAB
5. Merge works

Going into the editor has two states by the looks of it.
1. It remembers what craft you had in there
2. It reset the editor and is empty when you enter it.

E.G.
1. If the craft you were working is in there still then it will remember to merge
2. If the craft is gone then the editor has reset and the merge wont work unless you do the above.

Hope that helps

#5 Updated by akslfak 3 months ago

The above workaround worked perfectly for me. Thanks! That will help until the issue is patched out.

#6 Updated by dok_377 3 months ago

You can also just open a craft in the editor, then leave and re-enter the editor. This seems to fix the issue as well.

#7 Updated by just_jim about 1 month ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#8 Updated by just_jim about 1 month ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.10.1
  • % Done changed from 30 to 80

We've made some more changes in this latest 1.10.1 version and would like some feedback on this issue. Thanks.

#9 Updated by Anth12 about 1 month ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Is working again.
Went in and out the SPH/VABTRACKINGSTATION/KSC as additional testing

Resolved

Also available in: Atom PDF