Project

General

Profile

Bug #24855

Small asteroids get incorrect mass property (e.g. Class A mass always = 150t, well outside the legal range for Class A)

Added by tjandreas about 1 year ago. Updated 5 months ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
Parts
Target version:
Start date:
02/14/2020
% Done:

100%

Version:
Platform:
Linux, OSX, Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

DESCRIPTION: Small asteroids (less than 150t mass) spontaneously increase in mass to 150t upon opening the vessel.

STEPS TO REPRODUCE using the attached save file:
1. Enter Tracking Station.
2. Select the vessel "3.8t asteroid". The Info tab shows the total mass of the asteroid + tractor to be 15.68t, as expected. [Fig 1]
3. Fly this vessel.
4. Right-click on the asteroid. This shows the expected mass of 3.8t. [Fig 2] However...
5. Switch to the Map screen. Now the Info icon shows a total mass of 161t! [Fig 3]
6. Return to the Tracking Station. The total vessel mass now registers as 161t. [Fig 4]
7. Save and exit KSP. The updated save file shows the affected PotatoRoid part now has a mass property of 150t.

The save file includes two other small asteroids <150t that show this behavior, as well as two large asteroids >150t which are apparently not affected.

OTHER INFO:
  • Right-clicking on affected asteroids shows the expected mass; it is the "mass" property of the PotatoRoid part that is incorrectly clamped to 150t.
  • Drilling an affected asteroid creates ore as expected, but does not reduce the mass property of the PotatoRoid part below 150t... leading to vessel mass increasing as you drill!
  • Behavior first observed after updating to 1.9.
  • 64-bit Windows, Steam, no mods.
fig1.jpg (224 KB) fig1.jpg tjandreas, 02/14/2020 02:59 AM
fig2.jpg (334 KB) fig2.jpg tjandreas, 02/14/2020 02:59 AM
fig3.jpg (219 KB) fig3.jpg tjandreas, 02/14/2020 02:59 AM
fig4.jpg (236 KB) fig4.jpg tjandreas, 02/14/2020 02:59 AM
persistent.sfs (465 KB) persistent.sfs tjandreas, 02/14/2020 03:27 AM
51361
51362
51363
51364

History

#1 Updated by just_jim about 1 year ago

  • Status changed from New to Confirmed
  • Assignee set to just_jim
  • % Done changed from 0 to 10

#3 Updated by Dunbaratu about 1 year ago

I can confirm - this just happened to me and is causing me to lose a contract and a lot of funds (I built a ship that could capture a Class A asteroid, but the mass of 150t is never what any Class A asteroid should be so of course I didn't build for that and the mission can't be completed.)

I first noticed the problem when the delta-V meter went from my ship having 1500 m/s dV to about 115 m/s dV as soon as I docked with the asteroid. The PAW claims the asteroid was only 2.5 tonnes and the resources on it were only 2.22 tonnes. But the actual part's real mass is 150 tonnes, despite the lie the PAW display is showing. I confirmed it was 150 tonnes by comparing the difference in my ship's total mass when docked to it versus not docked to it.

Since the problem will happen on ALL class A asteroids - I cannot complete the contract properly ("Land a newly discovered Class A asteroid on Kerbin") without building a ship that costs more than the contract reward (the reward thinks it's an easy task when it's actually very hard because of the 150t bug).

#4 Updated by Dunbaratu about 1 year ago

  • Subject changed from Small asteroids get incorrect mass property to Small asteroids get incorrect mass property (Class A mass always = 150t, well outside the legal range for Class A)

#5 Updated by Dunbaratu about 1 year ago

  • Subject changed from Small asteroids get incorrect mass property (Class A mass always = 150t, well outside the legal range for Class A) to Small asteroids get incorrect mass property (e.g. Class A mass always = 150t, well outside the legal range for Class A)

#6 Updated by tjandreas about 1 year ago

POSSIBLE WORKAROUND by editing game data files:
1. Make a backup of your primary save file.
2. In your KSP install directory, navigate to the directory {$KSP_ROOT}/GameData/Squad/Parts/Misc/PotatoRoid/
3. Make a backup of the part data file part.cfg.
4. Open part.cfg in a text editor. Around line 21, a section begins
21: // --- standard part parameters ---
22: mass = 150
23: dragModelType = default

5. Comment out the mass property on line 22 with two backslashes.
21: // --- standard part parameters ---
22: //mass = 150
23: dragModelType = default

6. Save and exit.

After making these changes, I can now launch KSP and do the following:
  • Fly a craft attached to an existing Class-A/C asteroid. Assuming this asteroid did not already have the incorrect mass written to the save file, the asteroid keeps the expected mass.
  • Dock with a new Class-C asteroid. As far as I can tell, the asteroid gets the expected mass.

@Dunbaratu, can you try this workaround and see if it helps your situation?

#7 Updated by dave-m about 1 year ago

  • Platform Linux added

Hi,

thanks for this hint. I tried it an it apparently solved the problem for me.

tjandreas wrote:

POSSIBLE WORKAROUND by editing game data files:
5. Comment out the mass property on line 22 with two backslashes.
21: // --- standard part parameters ---
22: //mass = 150
23: dragModelType = default

#8 Updated by KerbalabreK about 1 year ago

It happened on mine too. Definitely destroyed my mission. It shows that the asteroid is 3t but in fact it's way over 100t.

#9 Updated by channsoden 12 months ago

I also got this bug. As it was my first ever asteroid I was quite confused and I struggled for a long time before realizing it's mass was 30x larger than I thought. The work-around worked for me, and although it should be obvious I should note for others that a game restart is required.

#10 Updated by Neilski 12 months ago

Wow, over 3 months now... where does the time go.
I chose to just stop playing (I had a bunch of asteroid missions) and wait for the fix to come in, rather than patch the data. Turns out I've been waiting a lot longer than I expected :-S

#11 Updated by niquil 11 months ago

  • Platform OSX added

#12 Updated by krillz 11 months ago

This happened to me as well. Said mass was 2.7 tons when I right clicked on the captured asteroid, but my delta-v went from like 1000 to 50 and kerbal engineer mod said my ship mass went up by 150 tons.

#13 Updated by Wolvyreen 11 months ago

I wasted 3 days trying to figure out why I was not able to complete the scenario only to find that this bug was causing all my headaches. I see now that update 1.10 has dropped without this being attended to.
Very frustrating indeed!!

#14 Updated by tjandreas 11 months ago

This bug appears RESOLVED by the 1.10 update.

I was fully ready to come on and put Squad on blast if it was true this issue was not resolved in 1.10. However...

The asteroid mass issue is mentioned in the 1.10 Release Notes:
Bug fixes
...
  • Fix asteroids having incorrect mass when docking.

To verify this, I launched the game and docked with an undisturbed Class C asteroid under the 150t limit. The save file shows the asteroid mass is correct.

@Wolvyreen, the bugfix in 1.10 only stops asteroids being assigned incorrect mass from this point forward. If you docked with an affected asteroid before the bugfix, the incorrect mass has already been written to your save file. The bugfix does not automatically undo this (my guess is it would complicate the fix and risk unintended changes). If you want to fix an asteroid that already has the incorrect mass, you can try manually editing the PotatoRoid's mass property in the save file (make a backup first).

Any other users can confirm this issue is resolved?

#15 Updated by just_jim 11 months ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#16 Updated by just_jim 11 months ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.10.0
  • % Done changed from 30 to 80

This should be working now in 1.10

#17 Updated by Wolvyreen 10 months ago

tjandreas, Thank you for your explanation :-) That is indeed what had happened. All is good in the world again.

#18 Updated by tjandreas 10 months ago

The fix for this bug has introduced a related bug in 1.10, #25730. Every asteroid in the game is affected.

#19 Updated by just_jim 9 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#20 Updated by svpluto2 5 months ago

tjandreas wrote:

The fix for this bug has introduced a related bug in 1.10, #25730. Every asteroid in the game is affected.

This hasn't been fixed on console yet.

Also available in: Atom PDF