Project

General

Profile

Bug #23172

Continuous stream of deployed science Screen Messages

Added by AstroBalrog almost 2 years ago. Updated about 1 year ago.

Status:
Closed
Severity:
High
Assignee:
-
Category:
Bug Tracker
Target version:
Start date:
07/12/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

In 1.7.2, I was getting a LOT of deployed science screen messages (that annoyingly need to be cleared one-at-a-time...)

When I just launched 1.7.3, I am now getting an continuous, unending stream of deployed science screen messages - hundreds every minute; when I stopped the game, I had over 3000 messages (that all need to be cleared one-at-a-time...)

persistent.sfs (4.17 MB) persistent.sfs Bob Trembley's game save - started with v1.7.1 AstroBalrog, 07/12/2019 02:17 PM
Screenshot from 2019-07-12 14-57-25.png (1.28 MB) Screenshot from 2019-07-12 14-57-25.png drvoke, 07/12/2019 09:59 PM
persistent.sfs (4.27 MB) persistent.sfs drvoke, 07/12/2019 09:59 PM
screenshot751.png (1.8 MB) screenshot751.png Look at the screen messages and the messages button in the upper right. jjansen, 07/13/2019 10:07 PM
44108 Messages.png (2.93 KB) 44108 Messages.png Screen shot of thousands of screen messages AstroBalrog, 07/15/2019 12:54 PM
workaround.png (86.2 KB) workaround.png Bugsquasher, 07/23/2019 03:19 PM
Don_t Jump The Shark.zip (1.19 MB) Don_t Jump The Shark.zip JustMeHere, 07/24/2019 08:30 PM
47921
47934
47945
48009

Related issues

Related to Kerbal Space Program - Bug #22757: This is a PRIMARY GAME ENDING BUG!Closed06/03/2019

Related to Kerbal Space Program - Bug #23901: Deployed science notification spamClosed10/16/2019

Has duplicate Kerbal Space Program - Bug #23269: Surface Science is spamming my messages menu like crazyDuplicate07/28/2019

History

#1 Updated by Robert.Keech almost 2 years ago

  • Status changed from New to Need More Info

How many deployed science stations do you have deployed?
Could you provide your save file.

#2 Updated by AstroBalrog almost 2 years ago

9 deployed stations: 3 on Kerbin, 3 on the Mun, 3 on Minmus.

I've attached my save; I'm using a crap-ton a mods tho... I'd be willing to start a new game using no mods, and re-create the deployments.

A couple of my early deployments on the Mun and Minmus did not have comms stations (hadn't researched them yet), and were spamming messages that science was generated and being stored.

A new message that I'm seeing today is "Mystery Goo has generated and transmitted 0.00 Science."

#3 Updated by Robert.Keech almost 2 years ago

Thanks for the info and save file.
Don't worry about creating a new save.
Because you are using a lot of mods there is a high chance that it is a mod issue.

#4 Updated by drvoke almost 2 years ago

47921

Got this on Linux, Steam version running on Ubuntu 18.04. My only mod is Precise Editor, but I've tried it without Precise Editor and it still happens. I've provided a screenshot demonstrating the amount of messages received in a Kerbal day on my save. I've also provided my persistent save.

#5 Updated by msebregts almost 2 years ago

I can confirm this happening on KSP 1.7.3.2594 with 1.7.1 Making History & 1.2.0 Breaking Ground on Linux (64-bit Ubuntu 18.04). I don't use any mods.

With two active surface experiments (an Ion Collector on Mun and Minmus), about 40 screen messages are generated when warping one day. Generated science varies between 0.04 and 0.1 per message.

#6 Updated by jjansen almost 2 years ago

  • File screenshot751.png screenshot751.png added
  • Status changed from Need More Info to Confirmed
  • % Done changed from 0 to 10
  • Expansion deleted (Core Game, Making History)
47934

I can confirm; it looks like the ground science announcement time resolution was upped by two orders of magnitude; I'm getting announcements for transmitted science in amounts under 0.002 science every few in-game minutes.

I run a low-medium modded game; with the exception of SCANSat and (technically) MechJeb, I run no parts mods.

Please see attached pic for more info.

This did not happen in 172: minimum resolution of messages was like once per day and about 30 science per instance.

#7 Updated by jjansen almost 2 years ago

  • Expansion Core Game, Making History added

#8 Updated by Centaurus87 almost 2 years ago

I too run a load of mods. But the stream of messages is getting insane. I've started a new game to try out all the Breaking Ground stuff and back and forth to Minmus I'm already getting about 250-300 messages, each way.
I'm currently making a Duna transfer with 2 scansats and 3 kerbals in a boat. 'Luckily' the counter broke at 551 after alt+tabbing to report this.

#9 Updated by AstroBalrog almost 2 years ago

47945

Update: After being in-game for about an hour, I have 44,108 messages on the toolbar icon; I'm not sure if it's related, but the time it's taking to switch from the VAB to the Launchpad, or to revert to VAB while in-flight has greatly increased.

Interesting note: If I shutdown KSP and restart, the screen messages start at about 5 (messages from contracts I have not cleared yet); just sitting at the KSC (without time accelerating), after about 15 seconds the messages start pouring in.

#10 Updated by rrowland almost 2 years ago

Also seeing this. Built a base of 3 next to launchpad to test it out, noticed that I was getting notifications of 0.000 science very often, drowning out any useful notifications. Unfortunately this is annoying enough that I turned them off and basically refuse to build any until these are fixed, going through 50+ messages every launch isn't fun. I'm excited about using this feature of this expansion I just paid for, so anything above "Low" priority would be great.

If this is intended to fire every day, I'm also worried that "fixing it" by reverting to daily will still have a similar effect when speeding up time for long transfers. I'd like to suggest removing it as a notification altogether and leaving it as a screen message only, once per day. In fact, it seems like that may have been the intention. The title of the message is "Screen Message" so maybe whomever implemented intended this to only be a screen message and not a notification.

Lastly, a related general ask: A feature to filter notifications out. May help alleviate the impact of similar issues in the future.

#11 Updated by jjansen almost 2 years ago

Welp, I found a way to at least get around the spam until the issue is fixed. I know this a far-from-ideal coarse workaround (or a blunt hack if you like), but at the very least we can continue to play in peace, though not with active ground science transmission.

In the persistent.sfs, changing ALL instances of the lines:

name = ModuleGroundExpControl
isEnabled = True

to

name = ModuleGroundExpControl
isEnabled = False

(or just turning off the ground science controllers in-game) will stop the experiments from communicating in any way, thus eliminating the message spam but also all associated science. Reversing the operation (in-game will take a kerbal physically at the experiments, which defeats the purpose) in Notepad will turn them back on.

Disabling the ground communicator in the same way didn't seem to have any effect (at all? I know I tried it but I don't think the ground comms have the same mechanics as the experiment controls, and I think I saw that when a ground controller has a nearby antenna, it changes its own comms power, so...).

To the best of my understanding, there's nothing that changed in the .sfs that would cause this, and my own and rrowland's experimentation shows that newly deployed modules react with the same bug, in old saves or new (I checked).

Please make no mistake: I do not consider this to be any kind of acceptable fix. This is a simple hack to allow play until the bug is addressed in a patch.

#12 Updated by fezzik almost 2 years ago

  • Platform Linux added
  • Platform deleted (Windows)

This bug makes the game unplayable. I had a single experiment on kerbin and after a mission past mun I ended up with nearly 1k messages with no real way of clearing them other than closing each one by hand. The 1k messages lagged the game to the point where burns are almost impossible not to overshoot.

#13 Updated by fezzik almost 2 years ago

  • Platform Windows added

#14 Updated by kaa253 almost 2 years ago

Clicking 100s of messages to clear them is highly annoying. This should be priority HIGH!

#15 Updated by AstroBalrog almost 2 years ago

I tried this but it had no effect - after 30 secs the screen messages began to pour in again.

jjansen wrote:

Welp, I found a way to at least get around the spam until the issue is fixed. I know this a far-from-ideal coarse workaround (or a blunt hack if you like), but at the very least we can continue to play in peace, though not with active ground science transmission.

In the persistent.sfs, changing ALL instances of the lines:

name = ModuleGroundExpControl
isEnabled = True

to

name = ModuleGroundExpControl
isEnabled = False

(or just turning off the ground science controllers in-game) will stop the experiments from communicating in any way, thus eliminating the message spam but also all associated science. Reversing the operation (in-game will take a kerbal physically at the experiments, which defeats the purpose) in Notepad will turn them back on.

Disabling the ground communicator in the same way didn't seem to have any effect (at all? I know I tried it but I don't think the ground comms have the same mechanics as the experiment controls, and I think I saw that when a ground controller has a nearby antenna, it changes its own comms power, so...).

To the best of my understanding, there's nothing that changed in the .sfs that would cause this, and my own and rrowland's experimentation shows that newly deployed modules react with the same bug, in old saves or new (I checked).

Please make no mistake: I do not consider this to be any kind of acceptable fix. This is a simple hack to allow play until the bug is addressed in a patch.

#16 Updated by JustMeHere almost 2 years ago

Please fix. Almost 500 messages from 1 deployed station while going to Minmus and back. I remember an issue very much like this in the past. This probably should be considered a regression bug. Breaking

Robert.Keech wrote:

How many deployed science stations do you have deployed?
Could you provide your save file.

I remember something like this from a prior release. Please hot patch. Breaking ground should be considered broken. Near 500 messages in a simple trip to Minmus and back. One science station deployed.

#19 Updated by Bugsquasher almost 2 years ago

48009

I had the same issue on Windows, and looked around in the files, and figured out this workaround:

In "\saves\default\persistent.sfs" (your main save) and in "\GameData\SquadExpansion\Serenity\Resources\DeployedScience.cfg", change the line
"ScienceTimeDelay = 60" to "ScienceTimeDelay = 6000000".

This makes it generate science about once every 50 ingame days, which would be about 8.8 science each time, (as measured with Minmus).

Ideally, there should just not be any message, or it should be disabled by default, with a sub-screen in the experiment overview showing how much has been generated ect.
And there should also be a "batch-dismiss" button in the message-menu, so that the player can dismiss evey message all at once.

#20 Updated by jjansen almost 2 years ago

AstroBalrog wrote:

I tried this but it had no effect - after 30 secs the screen messages began to pour in again.

Make sure to go to each station and turn them off manually. I had 2 of 4 survive the notepad termination fix, using notepad is more for restarting them.

#21 Updated by Aelipse almost 2 years ago

I also have this. A game-breaking experience as I have to exit and reload the whole game after each interplanetary transfer. Game version 1.7.3, both expansion packs and a ton of mods, but I am fairly sure the mods are innocent as none of them alters the frequency at which the science data is transmitted.

#22 Updated by JustMeHere almost 2 years ago

JustMeHere wrote:

Please fix. Almost 500 messages from 1 deployed station while going to Minmus and back. I remember an issue very much like this in the past. This probably should be considered a regression bug. Breaking

Robert.Keech wrote:

How many deployed science stations do you have deployed?
Could you provide your save file.

I remember something like this from a prior release. Please hot patch. Breaking ground should be considered broken. Near 500 messages in a simple trip to Minmus and back. One science station deployed.

Save attached. Just one station active.

#23 Updated by maxim almost 2 years ago

  • Platform deleted (Linux, XBoxOne)

AstroBalrog wrote:

In 1.7.2, I was getting a LOT of deployed science screen messages (that annoyingly need to be cleared one-at-a-time...)

I have no mods.
I did one thing on install, which was to add a seed number to my existing install according to some instructions on how to keep previous game and also add random features (rocks trees?)

I have two ground locations with ground experiments - one on Mun East crater, one at launchpad for learning purposes.
I have over 5000 screen messages and game is now at a crawl performance wise.

#24 Updated by bigtshades almost 2 years ago

I'm surprised this isn't getting any attention... It's been 2 weeks!

I play 100% vanilla, and in 1.7.2 I was getting a bunch but it wasn't game breaking. Just my flights to Jool were generating a LOT of messages that had to be manually cleared.

Now with 1.7.3, I get about 15 a second at regular speed. I took off from minimus, and my sismic detector started to go nuts. By the time I left min's SOI my game was unplayable.

#25 Updated by AstroBalrog almost 2 years ago

BUMP!

bigtshades wrote:

I'm surprised this isn't getting any attention... It's been 2 weeks!
... my game was unplayable.

#26 Updated by SlickStretch almost 2 years ago

  • Expansion deleted (Core Game, Making History)

This is happening to me too. Has there been any way to fix it?

KSP x64: 1.7.3.2594
Breaking Ground: 1.2.0

#27 Updated by AHHans almost 2 years ago

  • Platform Linux added
  • Platform deleted (Windows)

This problem affects me too.
I just tried the workaround suggested by Bugsquasher, setting ScienceTimeDelay in the *.sfs file to a higher value. (I only changed my save-file, not the config file.)
By setting "ScienceTimeDelay = 20000" I got 1 message per station per day (== one click on "Warp to Next Morning"), interestingly not the 13 messages per 12 days that I was somewhat expecting...

[And I just noticed that the "station stops working if it encounters a temporary interruption of communication" issue seems to be independent of the ScienceTimeDelay setting.]

My Configuration:
Linux x86_64
KSP: 1.7.3.2594
Making History: 1.7.1
Breaking Ground: 1.2.0
The "only" mod I use is Kerbal Alarm Clock

#28 Updated by AHHans almost 2 years ago

  • Platform Windows added

#29 Updated by coredumpster almost 2 years ago

  • Platform OSX added

#30 Updated by Robert.Keech almost 2 years ago

  • Related to Bug #22757: This is a PRIMARY GAME ENDING BUG! added

#31 Updated by Robert.Keech almost 2 years ago

  • Has duplicate Bug #23269: Surface Science is spamming my messages menu like crazy added

#32 Updated by Robert.Keech almost 2 years ago

  • Severity changed from Low to High

#33 Updated by Kerbolnaut over 1 year ago

I'm also getting horribly spammed by these in-game messages as well. I play 100% vanilla, using the Steam version with current updates for both KSP and the Breaking Ground DLC. I'm surprised it's taking so long to fix this bug.

#34 Updated by litemaster over 1 year ago

bigtshades wrote:

Now with 1.7.3, I get about 15 a second at regular speed. I took off from minimus, and my sismic detector started to go nuts. By the time I left min's SOI my game was unplayable.

I got the same today after crashing an obsolete lander into Minmus (3 Grand Slams total). Deployed science on the far side had no connection to Kerbin and started spamming messages, more than 10 per second.

The game was getting sluggish after 10k messages. I wanted to quicksave-load (as it cleared those messages before), but the game locked up on load with 14k messages.

Workaround: I found that I can clear the spam issue by switching to all my Experiment Control Stations on Minmus (wasn't sure which one was buggy) through the Tracking Station.
I've now edited the save file to get rid of the remaining messages (4410 identical).

#35 Updated by Calan over 1 year ago

I've had this issue too, twice. I am not running any mods, this is a recent install from Steam, 64 bit Windows.

After an impact on the Mun, I would get about 15 messages per second at 1x time, rapidly accumulating to tens of thousands of messages. With that many messages, the game would slow and freeze randomly, or if I accidentally moused over the messages icon. The same thing happened in another save with Minmus.

The workaround that I found was to make sure comms were in place, and then impact the Mun again. Worked on my other save with Minmus too. It was painful and difficult to do this with the constant crashing/freezing. Litemaster's workaround (which I have not tried) is much simpler, if it does work.

#36 Updated by Volvox over 1 year ago

  • Platform deleted (Linux, OSX)

I'm also having this problem. Minmus (1) and Mun (1) bases are sending a lot of messages (100+ daily). Recently I've put base on Kerbin (it's near north pole and seems to be constantly out of power because even if I see sun, solar panels don't) and after one of my rocked crashed to Kerbin I got massive spam of messages from seismic experiment (0 science send). Around 100+ a second.
I cannot even close them because game lags when trying to open preview.

#37 Updated by victorr over 1 year ago

  • Related to Bug #23901: Deployed science notification spam added

#38 Updated by victorr over 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.8.0
  • % Done changed from 10 to 80

We've made some changes in this latest version and would like some feedback on this issue. Thanks.

#39 Updated by jjansen over 1 year ago

victorr wrote:

We've made some changes in this latest version and would like some feedback on this issue. Thanks.

I tried loading my old save from a few months ago, seems like the surface science is accumulating about once every other Earth day, per experiment. Much much slower, but still a lot of messages.

The "delete all" messages button is a nice addition.

Maybe add a tab in Mission Control to corral this data, and just strike it from the onscreen popups?

I can see the use of knowing about it, somewhere, but to know that I just got 23.45234q43w25rq23 science from my Dunar weather station isn't something that NEEDs to be mentioned in the middle of an ascent burn.

#40 Updated by chris.fulton about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#41 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF