Project

General

Profile

Bug #22757

This is a PRIMARY GAME ENDING BUG!

Added by Geschosskopf almost 2 years ago. Updated about 1 year ago.

Status:
Closed
Severity:
High
Assignee:
-
Category:
Parts
Target version:
Start date:
06/03/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Problem: If a surface science set-up loses power, it spams messages saying it cannot transmit because it has no power. Such messages appear multiple times per second and quickly load the message inbox with dozens of duplicate messages, all listed as "screen message". When this started, I immediately went to the tracking station and terminated the surface science stuff. This took only 10 seconds or so, yet I had about 150 "cannot transmit" messages in my message inbox.

Situation: I put a surface science set-up on the crawler path between the VAB and launchpad. This consisted of the control unit, the solar power unit, and the goo unit. For 20 or so days, it worked fine, transmitting a little bit of data every few days. But then the Kraken ate the solar power unit while I was warping at max speed maneuvering a probe out beyond Minmus. That's when the spam barrage started. When I terminated the rest of the set-up, it was only the control unit and the goo unit.

Replication: Create a surface science set-up, let it run for a while, then terminate the power unit.

Suggested Fix: Reduce the frequency of the "can't transmit because no power" message to either the same as normal science transmissions, or make it once only. Also, if the set-up has multiple experiments, make it so the set-up as a whole only sends 1 message instead of each experiment sending messages individually.


Related issues

Related to Kerbal Space Program - Bug #23172: Continuous stream of deployed science Screen MessagesClosed07/12/2019

History

#1 Updated by solune almost 2 years ago

Hi, I have a similar problem. However my science setup is ok on power; it just happens to be out of line-of-sight of kerbin.

https://forum.kerbalspaceprogram.com/index.php?/topic/185093-screen-message-spam-in-breaking-ground/

#2 Updated by MechBFP almost 2 years ago

Yup same problem. In my case it was also because it wasn’t able to communicate. About 114 messages between the time it took to time warp from Kerbin to Minmus.

#3 Updated by MechBFP almost 2 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#5 Updated by Geschosskopf almost 2 years ago

MechBFP wrote:

Yup same problem. In my case it was also because it wasn’t able to communicate. About 114 messages between the time it took to time warp from Kerbin to Minmus.

Yup, I just had the same spam issue due to the communication dish sliding too far away from the rest of the set-up due to the usual "things slide on the ground" issues. Which I'll post as another bug if somebody hasn't already.

#6 Updated by chris.fulton almost 2 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.2
  • % Done changed from 10 to 80

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.2.2555?

#7 Updated by Tanaaris almost 2 years ago

Tested today with the brand new 1.7.3
Situation is now worse. when in 1.7.2 I had about 10 spam message a minute, I now have about 5 a seconds (reached 20 000 message in a few minute flight). Spam start a few moment after launch (around 1 minute after)
After a lot of messaging, game simply crash. Make it unplayable now.

#8 Updated by [email protected] almost 2 years ago

Mine are connected to the comm grid and have power, but update all stations once every ten minutes Kerbal time. 1.7.3.2594

#9 Updated by tiriss almost 2 years ago

Geschosskopf wrote:

Problem: If a surface science set-up loses power, it spams messages saying it cannot transmit because it has no power. Such messages appear multiple times per second and quickly load the message inbox with dozens of duplicate messages, all listed as "screen message". When this started, I immediately went to the tracking station and terminated the surface science stuff. This took only 10 seconds or so, yet I had about 150 "cannot transmit" messages in my message inbox.

Situation: I put a surface science set-up on the crawler path between the VAB and launchpad. This consisted of the control unit, the solar power unit, and the goo unit. For 20 or so days, it worked fine, transmitting a little bit of data every few days. But then the Kraken ate the solar power unit while I was warping at max speed maneuvering a probe out beyond Minmus. That's when the spam barrage started. When I terminated the rest of the set-up, it was only the control unit and the goo unit.

Replication: Create a surface science set-up, let it run for a while, then terminate the power unit.

Suggested Fix: Reduce the frequency of the "can't transmit because no power" message to either the same as normal science transmissions, or make it once only. Also, if the set-up has multiple experiments, make it so the set-up as a whole only sends 1 message instead of each experiment sending messages individually.

I verified this this weekend and so did the developers BUT it also happens on just normal work and usage. These guys are spamming messages all the time, most of them .0078345 science earned from Minmus etc. If it is that small and trickling in... it should wait to transmit until it gets to 80% full and start spamming to empty it. ...

The last time this happened it was a bug introduced about mission resolution, where EVERY time you were stable for 10 seconds it would bury you in mission parameter complete. With 15+ active missions ouch.

I have two science packages set up and both generate tons of messages, making the actual mission completions difficult to find.
Clicking 250+ messages when I warped 8 days is now no longer fun... it's work!

#10 Updated by rrowland almost 2 years ago

Please consider upping the priority on this. This is pretty breaking for those of us affected.

#11 Updated by tiriss almost 2 years ago

rrowland wrote:

Please consider upping the priority on this. This is pretty breaking for those of us affected.

This is paramount to fix................... I shouldn't have to click 1500+ times to get to the contract parameter completes or contract completes I need to know.

STOP THE SPAM!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! (but thanks for the free research modules).
THIS IS TORTURE (NOT REAL TORTURE, BUT PAINFUL) AND I'M GETTING CARPAL TUNNEL!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

#12 Updated by tiriss almost 2 years ago

Seriously,
stop making me click my mouse button!!!!!!!

200 is a number. 400 is an annoyance. 600 is a pest. 800 is just wrong. 1000 is now close to quitting the game completely because it's not just work, it's a plague upon the game.

frigging 2125!?!?!?!?!?!?!?!?!?!?!?!!?!?!?!!?!?!!? STOP THIS!
or go back to working to fix this bug.

NOW 3250!?!?!?!!?!?!?!?!!?!?!!?!?

#13 Updated by tiriss almost 2 years ago

I'm sorry at 3460 now...............................
Even if I was able to click twice per second... that's 28.833333333333333333333333333333 minutes.

That's a big Die in a fire................................... I'm not doing that!
Fix this bug!

#14 Updated by Leaky_Dwarf almost 2 years ago

Hey guys,

Not sure where I saw this fix but it totally works and you don't have to disable your science operations!! All it does is extend the time delay between when those stations calculate and send science, from what I've gathered.

Locate and open both of these files: \yourKSPinstallDir\GameData\SquadExpansion\Serenity\Resources\DeployedScience.cfg and \yourKSPinstallDir\Saves\Your_Save\Persistent.sfs

Find and update both ScienceTimeDelay and DataSendFailedTimeDelay from the stock 600 to a higher number. The number is how many seconds between science being sent so do the math on how often you want those messages :) (I think this is in Kerbal game seconds because it doesn't really math out to real time seconds, but I did 6000000 and it works great, get about 8.5 science every sooooo very long!) Hope this helps everyone out there and maybe it'll be a setting in a future update!

#15 Updated by tiriss almost 2 years ago

Thanks for the advice Leaky_Dwarf, but this is a massive game-breaking bug!

No USER or GAME PLAYER should ever need to modify game mechanics files to fix what is a serious FLAW!

I expect better. I'll try your workaround Leaky_Dwarf, but still this is very bad! If I bought a car and had to reboot it 3 times a day, I'd buy a different car. When I buy a piece of software and it requires me to click 3000 times in one setting, I choose not to play that game.
User's don't sign up to debug software, but now that seems to be the normal expectation?

It's not our job to debug your software, FIX IT!

#16 Updated by tiriss almost 2 years ago

Saving a game called "f***ing clicking" is a big f***ing clue, you're doing something wrong! FIX THE F****NG GAME!

#17 Updated by tiriss almost 2 years ago

If I held down the click button and it repeated, that would actually fix the problem.

#18 Updated by tiriss almost 2 years ago

  • Subject changed from Breaking Ground: Surface Science Spams "Cannot Transmit" Messages if Loses Power to This is a PRIMARY GAME ENDING BUG!
  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50

Users are required to click 1-3500+ times when science experiments are deployed on any planet, most recently Mun and Minmus.

#19 Updated by Robert.Keech almost 2 years ago

  • Related to Bug #23172: Continuous stream of deployed science Screen Messages added

#21 Updated by Robert.Keech almost 2 years ago

  • Severity changed from Low to High

#22 Updated by Tanaaris over 1 year ago

This is crazy.
This game breaking bugs is still not fixed!
I can safely admit that this has simply stopped me from playing KSP anymore.
this should have been an overnight fix after developer realize how serious this is breaking the game.
no computer can withstand ten thousand message during a single flight without ultimately crashing out of memory.
the way I see it, the main feature brought by this extension, installed science, is making it so that once used (and loose power, communication, access, etc...) you lose possibility of playing anymore.
so basically, we paid for an extension that if used prevent us to continue playing...

I petition for a refund from this point on!

#23 Updated by victorr over 1 year ago

  • Status changed from Not Fixed to Ready to Test
  • Target version changed from 1.7.2 to 1.8.0
  • % Done changed from 50 to 80

We've made some changes in the latest version and would like some feedback on this. Thanks.

#24 Updated by jclovis3 over 1 year ago

I had applied the number changes to my persistent file as recommended before 1.8 came out. I don't remember what the original settings were. Will this fix you're requesting feedback on reset those values to something new or do I need to change them back? What values should they be reset to? I have noticed that messages show up on screen but don't get saved for me to click anymore so that is a relief, but there is one other issue with the science experiments that probably should be put in the click log. When they have reached 100%, they shut down. We should be notified of this at least so we can plan to reset them. I don't know what the "interact" feature is with them but they should probably either transmit anything on queue, allow you to collect the science, or allow you to reset them with current skill level rather than having to pick up and put it back down.

On the note of modifying the persistent and save files, is there a way to insert comments, like preceding with // or single quote or something like in programming languages? I don't know how inserting extra lines of unintended text might affect reading the file but should the game be saved again, I don't want those comments to be wiped either. They would make it easier to keep track of manual changes and original values so I wouldn't have to ask my first question.

#25 Updated by chris.fulton about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#26 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF