Project

General

Profile

Bug #20758

Right-click menus fail during first launch after changes to PartDatabase.cfg

Added by k-ohara5a5a@oco.net about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
12/24/2018
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Core Game, Making History
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

Reported (as an observation, not necessarily a bug) at https://forum.kerbalspaceprogram.com/index.php?/topic/50533-15x-module-manager-311-november-12th-2018-its-dangerous-to-go-alone-take-those-cats-with-you/&do=findComment&comment=3508828

1) Install 1.6.0 and Making History
2) Delete or rename or move the file PartDatabase.cfg
3) Start KSP
4) Enter the VAB or SPH
5) Place a mk2Lander
6) Right click on that part
The right-click menu is incorrect (image) and the log reports null references.

Normally, one would not delete PartDatabase.cfg, unless trying to clear a previously-modded install, particularly if mods were put in the directory used by the Steam in-place update.

This effect is noticed mostly because the first run of the common mod 'Module Manager' causes the same symptom on the first start after any changes.

This might be a bug if it reveals an unintended change to the startup sequence, in which case Squad might rather reverse the change than let modders adapt to it.

Starting KSP a second time resolves the problem, and it remains resolved on further starts.

firstPartDatabase.jpg View - affected right-click menu (224 KB) k-ohara5a5a@oco.net, 12/24/2018 09:59 PM

KSP.zip - KSP.log (55 KB) k-ohara5a5a@oco.net, 12/24/2018 09:59 PM

KSPlogWithoutMakingHistory.zip - 555-555-0199@example.com (43.7 KB) k-ohara5a5a@oco.net, 12/31/2018 03:48 AM

screenshot0.jpg View - Symptoms without Making History installed (256 KB) k-ohara5a5a@oco.net, 12/31/2018 03:48 AM

40612
40675

Related issues

Duplicated by Kerbal Space Program - Bug #20763: Right click stops working in the editor Resolved 12/26/2018

History

#1 Updated by Nebbie about 2 months ago

  • Subject changed from right-click menus fail after first creation of ParDatabase.cfg to Right-click menus fail after first creation of PartDatabase.cfg
  • Status changed from New to Confirmed
  • % Done changed from 0 to 10
  • Platform Linux added

So that's what's causing it.

#2 Updated by k-ohara5a5a@oco.net about 2 months ago

  • Subject changed from Right-click menus fail after first creation of PartDatabase.cfg to Right-click menus fail during first launch after changes to PartDatabase.cfg

#3 Updated by k-ohara5a5a@oco.net about 2 months ago

40675

The Core Game alone is enough
1) Install 1.6.0
2) Delete or rename or move the file PartDatabase.cfg
3) Start KSP
4) Enter the VAB or SPH
5) Place a LV-N engine (note the engine plume is showing)
6) Right click on that part
The right-click menu is incorrect (image) and the log reports null references.

The inflatable heat shield also auto-inflates in the VAB with the right-click option to deflate being unresponsive. A second start of KSP clears the symptoms.

#4 Updated by joshua.collins about 2 months ago

  • Duplicated by Bug #20763: Right click stops working in the editor added

#5 Updated by joshua.collins about 1 month ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.6.1
  • % Done changed from 10 to 80

#6 Updated by Nebbie about 1 month ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Tested by running after removing the 6 seat Mk3 Cockpit mod, right click on Mk2 Lander Can is working fine.

Also available in: Atom PDF