Project

General

Profile

Bug #19339

Decouplers that are created in symmetry but are seperated into different stages act as 1 when they shouldnt.

Added by Anth12 about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
07/01/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

Windows 10
KSP Steam 1.4.4 + MH 1.3

Description:
Creating a craft that uses decouplers in symmetry and then used in seperate stages has the problem that once one of the decouplers is activated all
of the other decouplers that have been moved to different stages all disappear.

Work Around: right click on the decoupler that is no longer staged to decouple.

Example Craft attached.

Look to Before and After screenshots to see the issue.

Note: This issue happens per set of decouplers that have been put into symmetry.

Symmetry Decoupler Bug.craft (37.5 KB) Symmetry Decoupler Bug.craft 555-555-0199@example.com Anth12, 07/01/2018 09:58 AM
Before.png (2.09 MB) Before.png 555-555-0199@example.com Anth12, 07/01/2018 10:00 AM
After.png (2.44 MB) After.png 555-555-0199@example.com Anth12, 07/01/2018 10:00 AM
1.4.3 On launching.png (2.01 MB) 1.4.3 On launching.png 555-555-0199@example.com Anth12, 07/01/2018 10:31 AM
1.4.3 First Staging.png (2.01 MB) 1.4.3 First Staging.png 555-555-0199@example.com Anth12, 07/01/2018 10:32 AM
1.4.3 On Second Stage.png (2.01 MB) 1.4.3 On Second Stage.png 555-555-0199@example.com Anth12, 07/01/2018 10:32 AM
1.4.3 on Third Staging.png (2 MB) 1.4.3 on Third Staging.png 555-555-0199@example.com Anth12, 07/01/2018 10:32 AM
Fixed for 1.5 A.png (3.02 MB) Fixed for 1.5 A.png 555-555-0199@example.com Anth12, 10/16/2018 04:11 AM
Fixed for 1.5 B.png (3.02 MB) Fixed for 1.5 B.png 555-555-0199@example.com Anth12, 10/16/2018 04:11 AM
36934
36935
36936
36937
36938
36939
39031
39032

History

#1 Updated by Anth12 about 1 year ago

36936
36937
36938
36939

GOG KSP 1.4.3 without Making History
GOG KSP 1.4.4 without Making History

Here are screenshots of how it works for 1.4.3 which means whatever is causing the issue started with 1.4.4.

#2 Updated by diomedea about 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Confirmed, but only stack decouplers radially attached to a part new or changed in KSP 1.4. Radial decouplers don't; neither stack ones radially attached to a "old" part.

#4 Updated by AlffromKerbal about 1 year ago

I'm wondering, that this is even working.

In my view using Linux, i cannot split symetrically added parts off the same stage. So i'd call it a bug, that this is even possible ;)

Maybe it's more a bug in the process of stopping splitability.

Or i completly missundertood.

#5 Updated by diomedea about 1 year ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#6 Updated by joshua.collins 11 months ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.5.0
  • % Done changed from 30 to 80

Please recheck this in 1.5.0.

#7 Updated by Anth12 11 months ago

39031
39032

Windows 10
KSP Steam 1.4.5 + MH 1.3
KSP Steam 1.5 + MH 1.5

The craft in my main save that showed this bug now works correctly again

The test craft I used for this bug report works as intended now as per pics supplied

Resolved.

Thank you

#8 Updated by joshua.collins 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF