Project

General

Profile

Bug #17828

Part pictures in top row of VAB list display only their bottom half

Added by Nebbie about 3 years ago. Updated about 2 years ago.

Status:
Closed
Severity:
Normal
Assignee:
-
Category:
Camera
Target version:
Start date:
03/07/2018
% Done:

100%

Version:
Platform:
Linux, OSX, Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Happens for all parts.

screenshot176.png (2.43 MB) screenshot176.png Flea SRB with cutoff icon Nebbie, 03/07/2018 04:09 AM
screenshot179.png (2.38 MB) screenshot179.png [email protected] Nebbie, 03/07/2018 04:38 AM
screenshot0.png (2.32 MB) screenshot0.png Look at the bottom of the parts list kaa253, 03/16/2018 08:27 AM
Player.log (2.08 MB) Player.log [email protected] kaa253, 03/16/2018 08:38 AM
Capture d’écran_2018-03-16_18-36-15.png (1.32 MB) Capture d’écran_2018-03-16_18-36-15.png Truncated thumbnails in first line of editor menu Linlux, 03/16/2018 05:43 PM
KSP.log (267 KB) KSP.log My game log Linlux, 03/16/2018 05:44 PM
screenshot0.png (1.12 MB) screenshot0.png [email protected] SamHall, 04/27/2018 05:19 AM
KSP.log (324 KB) KSP.log [email protected] Anth12, 04/30/2018 06:29 PM
settings.cfg (29.7 KB) settings.cfg [email protected] Anth12, 04/30/2018 06:29 PM
screenshot1.png (2.51 MB) screenshot1.png [email protected] Anth12, 04/30/2018 06:30 PM
output_log.txt (3.63 MB) output_log.txt [email protected] Anth12, 04/30/2018 06:32 PM
settings.cfg (29.8 KB) settings.cfg [email protected] sdfjh, 05/01/2018 11:24 AM
KSP.log (1.49 MB) KSP.log [email protected] sdfjh, 05/01/2018 11:24 AM
screenshot588.png (2.42 MB) screenshot588.png 1.4.3, AA disabled Nebbie, 05/05/2018 07:14 PM
34153
34156
34520
34526
35808
35884
36022

Related issues

Related to Kerbal Space Program - Bug #18114: Part icons missing in Science FacilityResolved03/18/2018

Related to Kerbal Space Program - Bug #17899: component layout problem!Resolved03/08/2018

Has duplicate Kerbal Space Program - Bug #17871: Top row has top half cut off of part thumbnails in VAB.Duplicate03/07/2018

Has duplicate Kerbal Space Program - Bug #17872: Top Icons in VAB and SPH are cut in halfDuplicate03/07/2018

Has duplicate Kerbal Space Program - Bug #18020: (Linux) Part icons overlap Vessel price / CoM stringDuplicate03/13/2018

Has duplicate Kerbal Space Program - Bug #18462: VAB/SPH parts icon clippedDuplicate04/08/2018

Has duplicate Kerbal Space Program - Bug #18626: Duplicate - Parts in the Vehicle Assembly Building are only half showing upDuplicate04/19/2018

Has duplicate Kerbal Space Program - Bug #18751: parts display abnormal in VAB/SPHDuplicate05/01/2018

History

#1 Updated by Nebbie about 3 years ago

  • File screenshot179.png screenshot179.png added
  • Subject changed from Part icons in list display only their bottom half to Part pictures in top row display only their bottom half
34156

Correction: it only applies to the top row apparently.

#2 Updated by Nebbie about 3 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10
  • Platform OSX added

Looks like this is common to Unix-like systems (OpenGL issue?), based on the two other reports of it.

#3 Updated by Nebbie about 3 years ago

  • Subject changed from Part pictures in top row display only their bottom half to Part pictures in top row of VAB list display only their bottom half

#4 Updated by Nebbie about 3 years ago

  • Platform Windows added

Most recent duplicate issue report is from someone using Windows.

#5 Updated by Nebbie about 3 years ago

  • Version changed from 1.4.0 to 1.4.1

Still happening in 1.4.1

#6 Updated by Squelch about 3 years ago

  • Status changed from Confirmed to Investigating
  • % Done changed from 10 to 20
  • Expansion Core Game added

Thank you for reporting this. This does appear to be an openGL problem, and we are already tracking this internally. On Linux Ubuntu systems, the problem can go away when windowed and then resized. It's not a solution, but does make the problem harder to diagnose.

Forcing openGL on the Windows platform is not supported at this time.

#8 Updated by Squelch about 3 years ago

  • Has duplicate Bug #17871: Top row has top half cut off of part thumbnails in VAB. added

#9 Updated by Squelch about 3 years ago

  • Has duplicate Bug #17872: Top Icons in VAB and SPH are cut in half added

#10 Updated by jack_mustang about 3 years ago

I confirm this also affects Windows with DX9, with DX11 or DX12 it's a different bug #17827

#11 Updated by kaa253 about 3 years ago

34520

I have now seen that with longer part lists including mod parts the part icons also overlap the GUI elements at the bottom of the window.

[KSP Version]: 1.4.1.2089 (LinuxPlayer) en-us ====================================

Desktop is 1920 x 1080 @ 60 Hz
New context 0x2a5e4f8 created with attributes:
Initialize engine version: 2017.1.3p1 (02d73f71d3bd)
Forcing GfxDevice: OpenGL Core
GfxDevice: creating device client; threaded=1
Renderer: GeForce GTX 750 Ti/PCIe/SSE2
Vendor: NVIDIA Corporation
Version: 4.5.0 NVIDIA 384.111
GLES: 0

#12 Updated by Linlux about 3 years ago

34526

Confirmed on fresh install on Ubuntu 16.04.4.
With intel integrated graphic card.

Kerbal Space Program - 1.4.1.2089 (LinuxPlayer) en-us

#13 Updated by Linlux about 3 years ago

  • Platform OSX, Windows added

#14 Updated by Squelch about 3 years ago

  • Has duplicate Bug #18020: (Linux) Part icons overlap Vessel price / CoM string added

#15 Updated by Squelch about 3 years ago

  • Related to Bug #18114: Part icons missing in Science Facility added

#18 Updated by rduran about 3 years ago

Still happening on 1.4.2.2110 (Linux)

#19 Updated by Squelch about 3 years ago

  • Status changed from Investigating to Being Worked On
  • % Done changed from 20 to 30

#20 Updated by Squelch about 3 years ago

  • Has duplicate Bug #18462: VAB/SPH parts icon clipped added

#21 Updated by wumpkin about 3 years ago

Still happening on 1.4.2.2110 (WindowsPlayer 64x)

#22 Updated by Squelch about 3 years ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.3
  • % Done changed from 30 to 80

This should now be fully working at all Anti alias settings on all platforms.

#23 Updated by Squelch about 3 years ago

  • Has duplicate Bug #18626: Duplicate - Parts in the Vehicle Assembly Building are only half showing up added

#24 Updated by SamHall about 3 years ago

35808

Squelch wrote:

This should now be fully working at all Anti alias settings on all platforms.

agreed, but it doesn't look like we're there just yet I'm afraid.

#25 Updated by Squelch about 3 years ago

  • Category changed from Gameplay to Camera

Could you attach your settings and log files, and indicate which platform/OS version please?

#26 Updated by Anth12 about 3 years ago

35884

Steam KSP 1.4.3 + MH
Windows 10

AA is off

#27 Updated by Squelch about 3 years ago

  • Has duplicate Bug #18751: parts display abnormal in VAB/SPH added

#28 Updated by Squelch about 3 years ago

  • Status changed from Not Fixed to Being Worked On
  • % Done changed from 50 to 30

Thanks for confirming, and the problem has been identified.

#29 Updated by sdfjh about 3 years ago

i was asked for thoes files

#30 Updated by Anth12 about 3 years ago

I know. didnt mean anything bad by it. Its just that people when it comes to bug reports
sometimes dont come back. It had been 3 days and I had a bit of time on my hands and was able to replicate the problem
and get them the log files etc

#31 Updated by Nebbie about 3 years ago

36022

Working fine now, AA on or off, on Linux on 1.4.3.

#32 Updated by nestor about 2 years ago

  • Status changed from Being Worked On to Ready to Test
  • % Done changed from 30 to 80

#33 Updated by Anth12 about 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Fixed as of 1.4.4, cant replicate it in any other version with AA off (never happened with AA on)

Resolved

#34 Updated by joshua.collins about 2 years ago

  • Status changed from Resolved to Closed

#35 Updated by infinite_monkey about 2 years ago

This Bug has been reintroduced in 1.5 and has not been solved as of 1.7!

#36 Updated by Anth12 about 2 years ago

hmmmm, Testing

#37 Updated by Anth12 about 2 years ago

Maybe at a lesser Resolution....

#38 Updated by Anth12 about 2 years ago

Sorry. I cant make the bug happen again in 1.7.0 AA off AA on. I made some of the categories to make those little crosses pop up. tried different resolutions.
Tried it in a lesser resolution at full screen.

I cant get it to do it. You screen shot shows you are using mods...I dont know.

Upload your settings.cfg and I will test that.

#39 Updated by infinite_monkey about 2 years ago

@Anth12 I just realized that I didn't specify that I only have this problem on Linux - sorry for that, I was convinced this was specified in the bug description, but I guess that was in one of the duplicates I read first... Did you test it on Linux as well? This is on a 1920 x 1200 resolution.

#40 Updated by Anth12 about 2 years ago

I dont have Linux unfortunately

#41 Updated by Robert.Keech 11 months ago

  • Related to Bug #17899: component layout problem! added

Also available in: Atom PDF