Project

General

Profile

Bug #15391

Struts/Fuel lines clipped inside of parts cause craft explosions

Added by Yargnit almost 4 years ago. Updated over 2 years ago.

Status:
Closed
Severity:
High
Assignee:
-
Category:
Physics
Target version:
Start date:
05/27/2017
% Done:

100%

Version:
Platform:
Windows
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

The new strut/fuel line models cause physics to freak out and or explode upon vessel loading if the strut (I believe specifically the second end placed) is clipped inside of another part.

Attached is a simple 6 part craft with a central fuel tank, that has smaller tanks radially attached to it. the radial tanks are then gizmo'd in to allow struts to be places so they are inside the model. If this craft is loaded to the flight scene it will explode. If you delete the struts and launch the craft again it will work just fine. Fuel lines appear to do similar, though sometimes not quite as aggressively.

This also means that any craft in existing saves from 1.2.2 that are already launched and have struts clipped inside will explode the 1st time the craft is loaded in the flight scene in 1.3, potentially destroying peoples long term ongoing saves.

Strut Explosion.craft (14.3 KB) Strut Explosion.craft [email protected] Yargnit, 05/28/2017 04:21 AM
Strut Craft.craft (12.9 KB) Strut Craft.craft [email protected] JohnTAss, 05/28/2017 04:36 AM
Glados-EF-TankerTest.craft (157 KB) Glados-EF-TankerTest.craft Craft File for Testing ImJeffafa, 05/28/2017 05:32 AM
Strut Testing.craft (167 KB) Strut Testing.craft The Right craft file ImJeffafa, 05/28/2017 05:38 AM

History

#1 Updated by JohnTAss almost 4 years ago

I can confirm that this happens to me as well. Craft file attached.

#3 Updated by ImJeffafa almost 4 years ago

I am also testing this strut thing and I have 4 fuel tanks radially attached to a srb for support and 8 struts in 4x symm going inbetween the tanks at the top and bottom of them, putting a panel flushed with the top of the tanks makes them jump through the fairing which is close to the tanks causing an explosion.
https://gyazo.com/f87f9757eac724d691ddd1c98f1e9fab like this but I have the no crash damage on in this gif and this is what the payload looks like https://gyazo.com/c490bec2258610c2b64dbb8ea8722333

Edit: Wrong Craft File uploaded, Strut Testing.craft is the right one

#4 Updated by swjr-swis almost 4 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

1.3.0.1804 Win x64

Confirmed explosive potential with the uploaded craft when the struts are left in place, no explosion when struts removed.

#5 Updated by Yargnit almost 4 years ago

Adding another note, since fairings (unless inline) are solid until you deploy them, struts now (at least with some configurations) detonate inside of fairings even if they aren't clipped inside any actual objects. I haven't had time to thoroughly test multiple scenarios of this but I did come across it this evening.

#6 Updated by bewing almost 4 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to Not Applicable
  • % Done changed from 10 to 80

#7 Updated by Anth12 over 3 years ago

GOG 1.3.0.1804 Clean Install
Steam 1.3.1.1836 Clean Install

Using the crafts attached to this bug report I can reproduce the bug in 1.3.0.1804 but cant reproduce it in 1.3.1.1836

Fixed

#8 Updated by Anth12 about 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

I have the ability to resolve this here now

#9 Updated by joshua.collins over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF