Project

General

Profile

Bug #27284

Mun retrieve contract, explosion when using claw to target.

Added by [email protected] 3 months ago. Updated 3 months ago.

Status:
New
Severity:
Low
Assignee:
-
Category:
Physics
Target version:
-
Start date:
02/15/2021
% Done:

0%

Version:
Platform:
Windows
Expansion:
Breaking Ground
Language:
English (US)
Mod Related:
Yes
Votes:
Arrow u r green
Arrow d r red

Description

Tried to take solid fuel booster from surface of mun to kerbin.
When used claw to solid fuel booster it leads to explosion of whole ship, every time.

Unfortunately i have mods installed and therefore i can't confirm this without mods.

Notable thing: Target is very high slope surface, so that might cause it.

https://www.youtube.com/watch?v=1C5JQvdS-4s

If i try this same save game without mods to confirm this, do we count it as no mods?

will die.sfs (1.37 MB) will die.sfs [email protected], 02/15/2021 06:08 PM

History

#1 Updated by [email protected] 3 months ago

Here is save. For me it seems that contract retrievable part is heavily bugged. sometimes we explode, sometimes when docking it just floats away but claw says i have it on my arm. This one is used save from mod version of ksp, ran once without mods and saved it here.

Trying to hold back my emotions here. :D

#2 Updated by [email protected] 3 months ago

It is notable too than before arriving to targets physics range, target were floating about 30meters above surface, where it then started dropping to surface and rolling down when approaching.

#3 Updated by Anth12 3 months ago

Remove the mods and try again is my recommendation. I am having a problem, but nothing like that

The claw issue I am having is the following:
1. It thinks its grabs the SRB
2. The screen shakes
3. I retract the piston connected to the claw
4. the Claw isnt actually attached but has the release option

#4 Updated by Anth12 3 months ago

Made a new bug report relating to what I found testing this bug: #27285

#5 Updated by MisterDoctor 3 months ago

I had this happen almost exactly like your video. I very cautiously tried to grab the piece (a MK1 Lander can) with a robotic arm and claw. As soon as the claw made contact, it switched vehicle perspectives to a random piece of debris that immediately crashed into the ground (I'm not sure if it was from the ship exploding or not but I suspect it was; apparently whatever happens as the claw connects is so sudden and extreme that you don't get to see it). I got milestones for first docking on the Mun. I was not able to change my perspective back to what was left of the original vehicle from the map screen, so I returned to the tracking station. From there I was able to return to what was left of the ship; as soon as it loaded, parts of it (the arm) immediately exploded when I got there.

It's possible that the piece of debris that I switched to before it crashed was the claw itself, like in your video; but I didn't see it since it crashed before I knew what was happening.

The second time I attempted this grab it did not happen.

The only mod I have is the contract configurator and contract packs.

Also available in: Atom PDF