Project

General

Profile

Bug #25720

Pixel lights drop performance of the game significantly.

Added by dok_377 28 days ago. Updated 26 days ago.

Status:
Need More Info
Severity:
Low
Assignee:
-
Category:
Graphics
Target version:
-
Start date:
07/06/2020
% Done:

0%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I'm not really sure if this is a bug or what, but my game is experiencing extreme slowdowns and lag when the lights on my craft hit the surface of the planet (any planet with the new shader actually, I tested this on the Mun as well).

I don't think this is my computer's fault, I have a pretty powerful graphics card (geforce GTX 1060 6g) that is supposed to be more than enough to run all the graphics of the game without a hitch. I also noticed that this issue is related to the angle of the camera relative to the ground when the lights are on. It's not related to mods at all, I tested this with a freshly downloaded install as well. I think this started happening when the new planet shaders were introduced or when the new version of the Unity engine was implemented, not quite sure on that one. I will attach screenshots that show the difference in performance and also the simple craft file to test this on. Just load it and hit launch, this craft is moved to the side of the editor behind the walls, so it will load on the grass. You will need some program to measure frames per second to actually see the performance change when you toggle the lights.

2020-07-06_183605.png (1.14 MB) 2020-07-06_183605.png Modded install, difference in performance with changing camera angle screenshot. dok_377, 07/06/2020 04:00 PM
2020-07-06_183559.png (1.66 MB) 2020-07-06_183559.png Modded install, difference in performance with changing camera angle screenshot. dok_377, 07/06/2020 04:00 PM
2020-07-06_183615.png (679 KB) 2020-07-06_183615.png Modded install, difference in performance with changing camera angle screenshot. dok_377, 07/06/2020 04:00 PM
2020-07-06_183610.png (1.32 MB) 2020-07-06_183610.png Modded install, difference in performance with changing camera angle screenshot. dok_377, 07/06/2020 04:00 PM
2020-07-06_183625.png (1.68 MB) 2020-07-06_183625.png Modded install, difference in performance with changing camera angle screenshot. dok_377, 07/06/2020 04:00 PM
2020-07-06_185804.png (579 KB) 2020-07-06_185804.png Unmodded install, difference in performance screenshot for the attached craft file. dok_377, 07/06/2020 04:05 PM
2020-07-06_185809.png (1.11 MB) 2020-07-06_185809.png Unmodded install, difference in performance screenshot for the attached craft file. dok_377, 07/06/2020 04:05 PM
Light Test.craft (31.1 KB) Light Test.craft Craft file. dok_377, 07/06/2020 04:10 PM
Light Test.sfs (97.4 KB) Light Test.sfs Save file. dok_377, 07/06/2020 04:10 PM
KSP.log (406 KB) KSP.log Ksp.log dok_377, 07/06/2020 04:11 PM
Player.zip (47.5 KB) Player.zip Player.log dok_377, 07/06/2020 04:12 PM
53419
53420
53421
53422
53423
53424
53425

History

#1 Updated by dok_377 28 days ago

And again, the Player.log for some reason refuses to attach, so I zipped it.

#2 Updated by dok_377 28 days ago

  • Description updated (diff)

#3 Updated by RafaHdz 26 days ago

  • Status changed from New to Need More Info

I had this issue happen to me once but when I went back to older versions to try to repro ot there and then came back to the latest, I couldn't reproduce it anymore. I think it had to do with missing files so we need someone else giving it a try.

#4 Updated by dok_377 26 days ago

I'm pretty sure I validated all of the game files through Steam and it made no difference, but I also agree that this needs more info. To figure out the cause, at least, although I'm almost certain it's the new terrain shaders.

Also available in: Atom PDF