Project

General

Profile

Bug #25470

UI Scaling bugs breaks map view

Added by douglas 12 months ago. Updated 3 months ago.

Status:
Not Fixed
Severity:
Low
Assignee:
-
Category:
Controls and UI
Target version:
Start date:
05/31/2020
% Done:

50%

Version:
Platform:
Linux
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

There are actually two issues here.

1. UI scaling settings don't automatically take effect even when saved. You have to open up the settings, then click "Apply" each time the game launches (saved settings changes not being applied properly when the game launches has been a reoccurring issue on Linux).
2. When the UI scale is adjusted, map icons, and nav point markers end up being drawn way off from where they should be. See attached image. This is extremely consistent, and incredibly annoying on a 4k display with UI scaling set to 200%.

Screenshot_2020-05-30_05-25-49.jpg (1.13 MB) Screenshot_2020-05-30_05-25-49.jpg 4k image. Map view showing floating markers and nav points douglas, 05/31/2020 07:45 AM
4k at 160 UI Scaling.jpg (883 KB) 4k at 160 UI Scaling.jpg Example at 160% UI scale, also at 4k. Doesn't happen at 150% UI scale douglas, 05/31/2020 08:15 AM
Player.log.gz (140 KB) Player.log.gz douglas, 05/31/2020 08:18 AM
52804
52805

History

#1 Updated by douglas 12 months ago

52805

The 150% UI scale default doesn't have this floating UI element effect, but anything above 150% does.

#3 Updated by Technicalfool 12 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#5 Updated by victorr 10 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.10.0
  • % Done changed from 10 to 80

We've made some changes in this latest version and would like some feedback on this issue.

#6 Updated by douglas 10 months ago

The UI scaling is fixed, however all the graphics settings aren't being loaded when KSP starts up. The only thing that is loading is the screen resolution and full screen options. Detail levels, and UI scaling isn't being applied on startup (going to settings and hitting "Apply" right after startup will apply all saved settings).

#7 Updated by steve_v 9 months ago

While UI scaling no longer borks mapview, said UI scaling is not being applied at startup. As such I consider this very much not fixed.
See #24306, #24810 & #24907.
Game settings have been broken since 1.8.0, and the problem was reported ~9 months ago. Are you actually going to do something about this or what?

#8 Updated by steve_v 9 months ago

  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50

#9 Updated by victorr 4 months ago

douglas wrote:

The UI scaling is fixed, however all the graphics settings aren't being loaded when KSP starts up. The only thing that is loading is the screen resolution and full screen options. Detail levels, and UI scaling isn't being applied on startup (going to settings and hitting "Apply" right after startup will apply all saved settings).

Are these graphic settings you are mentioning in Linux? We have other reports of game settings in Linux not being persisted.

#12 Updated by douglas 3 months ago

victorr wrote:

douglas wrote:

The UI scaling is fixed, however all the graphics settings aren't being loaded when KSP starts up. The only thing that is loading is the screen resolution and full screen options. Detail levels, and UI scaling isn't being applied on startup (going to settings and hitting "Apply" right after startup will apply all saved settings).

Are these graphic settings you are mentioning in Linux? We have other reports of game settings in Linux not being persisted.

This was just happening in Linux. the issue was that game settings were being saved, they just weren't all being applied after they were loaded again. Clicking "apply" fixed it. So far this seems to be fixed in 1.11

#13 Updated by douglas 3 months ago

This can be closed. This seems to work now.

Also available in: Atom PDF