Project

General

Profile

Bug #25079

Can't pass the Security check

Added by KerbalabreK about 1 year ago. Updated 2 months ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
UI
Target version:
Start date:
03/25/2020
% Done:

100%

Platform:
Windows
Expansion:
Core Game
Language:
English (US), 简体中文 (Chinese Simplified)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I can't pass the security check because it isn't there! So I can't create an account on the forum. Living in China now.
I can't even report the problem on the forum because it needs security check. I'm not asking for help here and I'm pretty sure it's a bug from the forum or the security check service provider.
I'm sorry that it may not be a proper place to report this but it's my only way to report this issue.

批注 2020-03-25 082613.png (38.5 KB) 批注 2020-03-25 082613.png Here's the screenshot KerbalabreK, 03/25/2020 01:32 AM
批注 2020-04-03 110556.png (88.1 KB) 批注 2020-04-03 110556.png KerbalabreK, 04/03/2020 03:14 AM
51888
51968

History

#1 Updated by MisterDoctor about 1 year ago

I've heard that reCaptcha often doesn't work in China because it's run by Google which is often blocked.

Some info about it here:

https://stackoverflow.com/questions/57827914/google-recaptcha-in-china
https://www.quora.com/Since-Google-reCAPTCHA-does-not-work-in-China-how-do-Chinese-websites-prevent-bots-and-denial-of-service-attacks

Google's suggestion is to use www.recaptcha.net instead of www.google.com but it apparently doesn't work anymore. It would be up to the KSP Devs to use a different Captcha or else you could maybe use a VPN or proxy.

#2 Updated by Technicalfool about 1 year ago

  • Status changed from New to Investigating
  • Assignee set to Technicalfool
  • % Done changed from 0 to 20

Passing this to tech support.

#4 Updated by ManeTI about 1 year ago

  • Assignee changed from Technicalfool to ManeTI

#5 Updated by KerbalabreK about 1 year ago

If the bug fixing needs any help, please contact me.

#6 Updated by ManeTI about 1 year ago

  • Status changed from Investigating to Ready to Test
  • Target version set to Not Applicable
  • % Done changed from 20 to 80

Hello, indeed looks like a problem with google in China, we have set up a new Captcha from a different provider (KeyCaptcha).

#7 Updated by KerbalabreK about 1 year ago

51968

The problem has gone. I'm now able to create an forum account. Thanks alot!!!!!!!

#8 Updated by ManeTI about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF