Project

General

Profile

Bug #24945

Mk2 Drone Core is causing massive drag to the part behind it. (pre 1.9 origin)

Added by Anth12 about 1 year ago. Updated 10 months ago.

Status:
Resolved
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
03/01/2020
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Important information:

I believe this issue has been around for a while. Someone on twitch told me about it.

Pictures show massive drag if the mk2 Drone Core is a part of the vessel compared to if it isnt.

mk2 drone core.png (2.54 MB) mk2 drone core.png Anth12, 03/01/2020 05:01 AM
No mk2 drone core.png (2.32 MB) No mk2 drone core.png Anth12, 03/01/2020 05:02 AM
No mk2 Drone Core.craft (51.8 KB) No mk2 Drone Core.craft Anth12, 03/01/2020 05:04 AM
mk2 Drone Core.craft (55 KB) mk2 Drone Core.craft Anth12, 03/01/2020 05:04 AM
51596
51597

History

#1 Updated by Anth12 about 1 year ago

  • Subject changed from Mk2 Drone Core is causing massive drag to the part behind it. (pre 1.9) to Mk2 Drone Core is causing massive drag to the part behind it. (pre 1.9 origin)

#3 Updated by rachel.britton about 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#4 Updated by [email protected] about 1 year ago

This problem exists in version 1.3.1, and probably since the beginning of the 1.05 drag model. The mk2 drone core has holes that extend from front to back, so KSP treats it like smaller-cross-sectional-area part in the stack of other mk2 parts.

One workaround is to change two 2.0-m² areas into 2.5-m² areas like the other mk2 parts with a Module Manager patch:
@PART[mk2DroneCore] {
DRAG_CUBE {
cube = Default, 0.378,0.565,1.355, 0.378,0.565,1.355, 2.495,0.963,0.212, 2.495,0.963,0.212, 0.610,0.901,0.7, 0.610,0.901,0.7, 0,0,0, 2.5,0.25,1.5
} }

#5 Updated by victorr 10 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.10.0
  • % Done changed from 10 to 80

We've made some changes in this latest version and would like some feedback on this issue.

#6 Updated by [email protected] 10 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#7 Updated by Anth12 10 months ago

Agreed. Good work guys

Also available in: Atom PDF