Project

General

Profile

Bug #24856

Rover issues on Duna related to #24848. #24848 is resolved, Therefore this bug is resolved as well.

Added by tomtucker2010 about 1 year ago. Updated 8 months ago.

Status:
Resolved
Severity:
Low
Assignee:
-
Category:
Controls and UI
Target version:
Start date:
02/14/2020
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Hi,

Since I upgraded to 1.9 I am having issues with rovers gliding across the surface with next to no control. Even when brakes are applied it still states I am moving at 25mps even though I am stationary

Friction On Landing.png (1.98 MB) Friction On Landing.png Anth12, 02/16/2020 06:27 AM
Friction After Quicksave.png (1.79 MB) Friction After Quicksave.png Anth12, 02/16/2020 06:27 AM
quicksave.sfs (260 KB) quicksave.sfs Anth12, 02/16/2020 06:36 AM
51406
51407

History

#1 Updated by Anth12 about 1 year ago

Not enough information to be helpful. What wheels are causing that issue?

#2 Updated by LordofBunnies about 1 year ago

I am have the same issue on both Ike and Duna. RoveMax Model XL3 wheels. The rover was working fine the day before, but won't hold still after the update. Also, it doesn't accelerate like before when trying to move, especially trying to climb. It acts very similar to trying to drive on the ice lakes at Minmus.

#3 Updated by Anth12 about 1 year ago

Most likely related to #24848

Friction settings for the Mun were at 0.25 instead of 8.2.

To counter the issue increase the friction.

I will confirm this after actually testing this on Duna

#4 Updated by Anth12 about 1 year ago

51406
51407

Friction On Landing.png: Friction set to 1.0 on landing on Duna for the first time (after using set orbit and then manually deorbiting)

Friction After Quicksave.png: Friction autosets to 0.37

Confirmed and definitely related to #24848

#5 Updated by Anth12 about 1 year ago

  • Subject changed from Rover issues on Duna related to #24848 to Rover issues on Duna related to #24848. #24848 is resolved, Therefore this bug is resolved as well.

Tested on Duna for 1.9.1

No Longer sliding. This can be set to Ready to Test and then Resolved

#6 Updated by just_jim 8 months ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#7 Updated by just_jim 8 months ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.10.1
  • % Done changed from 30 to 80

#8 Updated by just_jim 8 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF