Project

General

Profile

Bug #24840

KSP 1.9 broke the ability to edit a second manuever node with GUI 'knobs'.

Added by Dunbaratu over 1 year ago. Updated about 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Controls and UI
Target version:
Start date:
02/12/2020
% Done:

100%

Version:
Platform:
Linux, OSX, Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Prior to KSP 1.9, I was able to do the following. Now I cannot in KSP 1.9:

Step 1 - Add a maneuver node at some future spot of your orbit. It doesn't matter what the maneuver node is as long as it's something nonzero. Something basic like +10 dV retrograde will do.

<Do NOT execute the maneuver yet. Just leave it in your future.>

Step 2 - Add a second maneuver node at some point farther in the future, along the brown dotted line that represents the orbit you will have after the maneuver node from step 1.

Step 3 - Try to alter that second maneuver node in any way using the GUI draggable knobs: the prograde, retrograde, normal, anti-normal, radial-in, or radial-out knobs. Prior to KSP 1.9, you could. Now in KSP 1.9, you can't. The second maneuver node is stuck as dV=0 and can't be changed through the GUI.

<Note that you can change the second maneuver node through the type-in fields in the lower-left of the screen, just not by pulling the maneuver node's knobs.>

screenshot8.png (1.83 MB) screenshot8.png Starting orbit Dunbaratu, 02/12/2020 10:19 PM
screenshot9.png (1.86 MB) screenshot9.png Step 1 - first manuever node Dunbaratu, 02/12/2020 10:19 PM
screenshot10.png (1.86 MB) screenshot10.png Step 2 - second maneuver node Dunbaratu, 02/12/2020 10:19 PM
screenshot11.png (1.86 MB) screenshot11.png Step 3 - pulling second node's normal knob - no effect. Dunbaratu, 02/12/2020 10:19 PM
screenshot12.png (1.86 MB) screenshot12.png Step 3 - pulling second node's radial-in knob - no effect. Dunbaratu, 02/12/2020 10:19 PM
screenshot14.png (2.03 MB) screenshot14.png This was by typing in the value 300 into the 'normal' field. This DID work. Dunbaratu, 02/12/2020 10:19 PM
51326
51327
51328
51329
51330
51331

History

#3 Updated by just_jim over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#4 Updated by just_jim over 1 year ago

  • Assignee set to just_jim

#5 Updated by AHHans about 1 year ago

  • Platform Linux added

#6 Updated by roboliver1011 about 1 year ago

Not only can Manuever 2 node not be edited with the GUI knobs, it cannot have its timing changed by dragging it along the orbit path. Once you place the node, its timing is fixed.

#7 Updated by niftyfingers about 1 year ago

I'm getting the same problem. Dragging the GUI knobs does nothing for me in 1.9, and the maneuver node can't be dragged along.

#8 Updated by willfrancis3 about 1 year ago

  • Platform deleted (Linux)

#9 Updated by willfrancis3 about 1 year ago

  • Platform Linux added

#10 Updated by willfrancis3 about 1 year ago

Same here. Very frustrating. May put it down until fixed.

#11 Updated by atcdev about 1 year ago

  • Platform OSX added
  • Expansion Breaking Ground, Making History added

Same issue on MacOS with stock KSP + standard expansions.

#12 Updated by atcdev about 1 year ago

One further update on this. It is happening for me in 100% of cases. I'm sure everyone says this but it's a truly frustrating bug.

#13 Updated by niftyfingers about 1 year ago

atcdev wrote:

One further update on this. It is happening for me in 100% of cases. I'm sure everyone says this but it's a truly frustrating bug.

Agreed

#14 Updated by boolybooly about 1 year ago

While you are fixing this bug I would like to draw your attention to the problem with planetary encounters not being predicted reliably because it is probably related to the node code and is really getting shockingly bad now and deserves priority attention. :)

https://bugs.kerbalspaceprogram.com/issues/24415?next_issue_id=24412&prev_issue_id=24416

#15 Updated by Dunbaratu about 1 year ago

I just got the KSP 1.9.1 patch downloaded and tried this. It looks like it is fixed. Editing the second (and third, etc) manuever node now works properly.

I'd change the status to "resolved" but it isn't under my control to do so yet, as it hasn't been set to "ready to test" by SQUAD as I type this.

#16 Updated by victorr about 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Assignee deleted (just_jim)
  • Target version set to 1.9.1
  • % Done changed from 10 to 80

We've made some changes in the latest build and would like some input on this issue please. Thanks.

#17 Updated by Neilski about 1 year ago

victorr wrote:

We've made some changes in the latest build and would like some input on this issue please. Thanks.

Yes, it's fixed now in 1.9.1.

#18 Updated by Neilski about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#19 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF