Project

General

Profile

Bug #24820

buttons on axis in Graphical Maneuver editor grow when clicking

Added by jayvey over 1 year ago. Updated 9 months ago.

Status:
Resolved
Severity:
Low
Assignee:
-
Category:
Controls and UI
Target version:
Start date:
02/10/2020
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Steps to replicate:
It doesn't happen all the time, but once it happens then it happens throughout the game.
1. Open Graphical Maneuver editor in the Maneuver Mode (bottom left)
2. Rapidly click on one of the prograde/retrograde/normal/antinormal/radial in/ radial out/advance/delay buttons on the graphical axis

Result:
Button whil expand and grow without limit and will fully cover the screen. Other buttons on the graphical axis become unusable.

Fixes:
- restart game
- reload save file
- switch vessel

Notes:
Toggling map mode does not fix the issue.
When it happens the button animation seems less snappy compared to normal.
I have this happen on two separate systems with different save files, both windows 10 64, both steam version from around version 1.7 and up.
No mods.

DxDiag.txt (81 KB) DxDiag.txt Pc specs jayvey, 02/10/2020 10:20 AM
ksp_graphical_maneuver_editor_bug.mkv (3.69 MB) ksp_graphical_maneuver_editor_bug.mkv Me consistently clicking the prograde button jayvey, 02/10/2020 10:20 AM

History

#1 Updated by Sidney.Christian about 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#3 Updated by victorr 10 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.10.0
  • % Done changed from 10 to 80

We've made some changes in this latest version and would like some feedback on this issue.

#4 Updated by jayvey 9 months ago

Have been playing a little bit and so far so good, haven't tested it a lot so will let know if it happens again, otherwise fix seems to be working.
Button animation feels more direct and snappy when you click it, not laggy like before.

#5 Updated by jayvey 9 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

After playing a bit more I consider the issue to be fixed, thank you :)

Also available in: Atom PDF