Project

General

Profile

Bug #24733

Extended landing gear does not block hatch for EVA...

Added by abc over 1 year ago. Updated 5 months ago.

Status:
Resolved
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
01/25/2020
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

To repeat:

1) Place Mobile Processing Lab MPL-LG-2 in VAB

2) Place any Landing Gear on the default hatch (left side from default VAB view)
-> the Engineer's Report notes the hatch is blocked except for the smallest landing gear

3) Launch with a kerbal inside and click EVA
-> the kerbal appears in or overlaping the landing gear

Workaround: Rotate the Mobile Processing Lab so that the covered hatch is not the one used by default. The side without the flag is the default hatch.

If the landing gear is retracted the hatch is blocked and the other hatch used.

I hadn't noticed before but it seems that kerbals can normally walk through extended landing gear, at least in 1.8.1 (not sure if this is a new thing?).

Since there is a workaround it is maybe not worth fixing, although it can be annoying to rotate the Mobile Processing Lab if this is noticed after stuff is placed or to deal with the wrong hatch being used if it isn't noticed until after launch, so if it is an easy fix it would be helpful. Another possibility would be a one hatch variant of the Mobile Processing Lab to make it more obvious which hatch will be used (I don't think there is any other part where a second hatch could easily be blocked by landing gear).

History

#1 Updated by steve_v over 1 year ago

abc wrote:

I hadn't noticed before but it seems that kerbals can normally walk through extended landing gear, at least in 1.8.1 (not sure if this is a new thing?).

Removing collision detection between EVA kerbals and extended landing gear was the "fix" (scarequotes most assuredly intended) for https://bugs.kerbalspaceprogram.com/issues/9638.
Unsurprisingly, it now comes back to haunt us...

#2 Updated by christy.theus about 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#4 Updated by victorr 5 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.11.0
  • % Done changed from 10 to 80

We've made some changes to the game in this latest version and would like to have some feedback on this issue. Thanks.

#5 Updated by abc 5 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Thanks! I see that if there is extended landing gear on both sides then EVA is still possible through one of them (flag side this time), but it is now visually obvious that it shouldn't be possible to EVA in the cases where the Kerbal appears in the landing gear so the most surprising behavior is gone and I think the bug should be considered resolved (I guess with the largest landing gear it seems visually possible for a Kerbal to get out that way in some cases). The one slightly surprising behavior is that if there are landing gear on both sides but only the one on the non-flag side is extended then it isn't possible to exit via the other, while it is if the flag side is extended and the other closed. However, having landing gear on both sides seems like it should be so much less common that I'm guessing it isn't worth adjusting for. Similarly, if there is a solar panel on the flag side and extended landing gear on the other side then it is not possible to EVA while it is if the solar panel is on the non-flag side. But since visually it doesn't look like it should be possible to EVA in most cases I think the difference is unlikely to cause confusion in practice.

Also available in: Atom PDF