Project

General

Profile

Bug #9638

EVA Kerbals, on the surface, destroy LT-05 landing strut on contact.

Added by steve_v over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Physics
Target version:
-
Start date:
05/01/2016
% Done:

100%

Version:
Platform:
Linux
Expansion:
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

Walking into an LT-05 micro landing strut (at any speed) with an EVA Kerbal causes it to jump suddenly, (occasionally the foot will move from ground contact to atop the kerbals head in what appears to be a single frame, othertimes it just bounces violently), causing the gear to be insta-destroyed from "overstress". On a low gravity body this will send the craft and the kerbal flying apart at considerable velocity.

Repro: walk into an LT-05 with a kerbal. Tested on pad and Minmus surface. The attached craft is similar to the vessel I first encountered this with, and reproduces this reliably for me, though a pod with some legs works just as well.

Log & craft file attached, vid here: https://www.dropbox.com/s/2dlyx5b54hfypfx/LT-05_01.ogv?dl=0

If this is a dupe, sorry. There are so many landing-leg / wheel related reports here I can't find anything.

Player.log (489 KB) Player.log 555-555-0199@example.com steve_v, 05/01/2016 08:06 AM
Untitled Space Craft.craft (77.4 KB) Untitled Space Craft.craft 555-555-0199@example.com steve_v, 05/01/2016 08:06 AM

History

#1 Updated by steve_v over 3 years ago

Update: checking the other legs, they all produce the same unexpected violent forces if a kerbal contacts the foot. The larger legs don't explode, presumably due to higher stress tolerance.

#2 Updated by Pluto239 over 3 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

I have encountered this as well... with hilarious results. Certainly a bug: though I suppose exploding landing gear does sound like a very "Kerbal" thing.

#3 Updated by electron2059 over 3 years ago

I have also had this bug using the windows version. Think I first noticed it in the release 1.1 and also in 1.1.1. and 1.1.2

#4 Updated by Apollo13 over 3 years ago

I have reported this problem as well, including the pre-release.

#5 Updated by krimsalt over 3 years ago

I have had this issue with the LT-1.. simply walking in any proximity to them causes them to explode

#6 Updated by tater over 3 years ago

This happens on Mac as well, with ALL the landing legs.

#7 Updated by TriggerAu over 3 years ago

  • Status changed from Confirmed to Needs Clarification
  • % Done changed from 10 to 0

#9 Updated by Squelch about 3 years ago

  • Status changed from Needs Clarification to Ready to Test
  • % Done changed from 0 to 80
  • Version changed from 1.1.2 to 1.2.0

this was addressed and should be fixed in KSP 1.2

#10 Updated by JPLRepo almost 3 years ago

  • Status changed from Ready to Test to Closed
  • % Done changed from 80 to 100

Closing as this was fixed in 1.2.0

Also available in: Atom PDF