Project

General

Profile

Bug #24435

Docking Ports on same vessel will not Undock by Action Key

Added by XLjedi over 1 year ago. Updated 3 months ago.

Status:
Ready to Test
Severity:
Low
Assignee:
Category:
Parts
Target version:
Start date:
11/27/2019
% Done:

80%

Version:
Platform:
Windows
Expansion:
Breaking Ground
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

The example craft demonstrates a hinged door that uses a docking port junior to secure the door when closed.

To close the door, the hinge motion and undock command is assigned to Action Group 1. When the door is closed, the docking port locks the door in place. The bug occurs when you press Action Key 1 a second time to open the door. The "Undock" command will not execute with the action key assignment.

I have tried assigning various combinations of "Undock", "Decouple Node", and "Same Vessel Interaction" to action key groups but nothing works. You can right-click the docking ports on the hinge to manually "Undock" the port, but action keys will not trigger the event. I have tested it with Docking Port Jr and the next-larger Clamp-o-Tron docking port and they both behave the same way.

I have also tried assigning the "Undock" and "Decouple Node" to separate action groups and it still will not trigger the undock event.

History

#1 Updated by XLjedi over 1 year ago

This only occurs when the docking ports are on the same vessel. For instance, I have no problem docking and undocking two different vessels with action keys. I can even mount a subassembly on a craft at design time and it will undock fine by action key in-game.

#2 Updated by XLjedi over 1 year ago

The "Same Vessel Interaction" property of "Yes/No" is also curious in that it seems to do absolutely nothing. ...or at least nothing noticeable as it relates to this specific bug. Would be helpful to know what the intention of that property setting is?

#3 Updated by just_jim over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#6 Updated by just_jim over 1 year ago

  • Assignee set to just_jim

#7 Updated by StevenLawyer over 1 year ago

I know this has been confirmed, but I wanted to report that, even if I separately build the part and then merge it to the primary vessel or save it as a sub-assembly and add it, I'm not consistently able to use the action keys to undock it. I have a hinge with a docking port jr. to secure the hinged component. The only way I can make an action key undock is to make the docking port jr. the root part of the hinged component, add it to the main vessel from the docking port jr connection that I want to action key, and then let the other end of it connect on load-up (through a standard docking port). Then I can action key separate the docking port juniors the first time by using "decouple node" (makes sense, since the subassembly's root part is the docking port jr). After that, however, it will not consistently let go with action keys--I've tried including both decouple node and undock for both ports.

#8 Updated by XLjedi about 1 year ago

Very disappointing this still has not been addressed in 1.9.1.

Why are we not allowed to undock own-vessel ports via action group key assignment???

#9 Updated by XLjedi about 1 year ago

Any feedback or movement on this one at all?

No point in creating custom loading bays/ramps if this will never work.

#10 Updated by Anth12 11 months ago

Seems to be a lot more interaction with the bugtracker by squad over the last few versions.

Lets see what they do with 1.10

#11 Updated by just_jim 10 months ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#12 Updated by just_jim 10 months ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.10.0
  • % Done changed from 30 to 80

We've made some more changes in this latest 1.10.1 version and would like some feedback on this issue. Thanks.

#13 Updated by Battlefield_Ace 3 months ago

I am still encountering this issue in game version 1.11.0.3045. My craft file is attached. I'm using docking port jr.s to lock a large cargo door in place, however I cannot undock them with an action group nor with the robotics controller.

Also available in: Atom PDF