Project

General

Profile

Bug #23909

The game doesn't save settings at all.

Added by dok_377 over 1 year ago. Updated over 1 year ago.

Status:
Closed
Severity:
Normal
Assignee:
Category:
Application
Target version:
Start date:
10/16/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US), Fran├žais (French)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

When you restart the game, it just resets all the settings to defaults. It almost looks like it completely ignores the settings file and owerwrites it everytime you start the game.

Steps to reproduce:

1. Download the game from scratch.
2. Launch it and observe how it launches. It should launch in windowed mode with music in the main menu.
3. Go to settings and reconfigure the game. Set it to fullscreen, set the resolution, set the music volume to 0. Hit apply and accept.
4. Quit the game and launch it again.

It launches in fullscreen as it should. But then...
Music starts to play again! Now you are wondering what is going on and go to the settings again.

5. Set the volume of the music to 0 AGAIN. Hit apply.

And now the game is in windowed mode again and almost all the settings are reset to default.

KSP.log (483 KB) KSP.log The log file before game restart, the game is configured and working correctly. dok_377, 10/17/2019 12:35 AM
Player.log (914 KB) Player.log The log file from the appdata/locallow before game restart, the game is configured and working correctly. dok_377, 10/17/2019 12:35 AM
KSP.log (393 KB) KSP.log The log file after the game restart. dok_377, 10/17/2019 12:40 AM
Player.log (736 KB) Player.log The log file from the appdata/locallow after the game restart. dok_377, 10/17/2019 12:40 AM
settings.cfg (35.1 KB) settings.cfg dok_377, 10/17/2019 12:57 AM

History

#1 Updated by dok_377 over 1 year ago

  • Description updated (diff)

#2 Updated by dok_377 over 1 year ago

  • Description updated (diff)

#4 Updated by dok_377 over 1 year ago

Here are the log files.

#5 Updated by dok_377 over 1 year ago

I configured the game during the first log recording. During the second log recording I just launched the game, went to the settings menu and pressed apply button. The game then immediately went into the windowed mode and all the settings were set to default again.

#6 Updated by dok_377 over 1 year ago

#7 Updated by Vandest over 1 year ago

  • Expansion Breaking Ground, Making History added
  • Language Fran├žais (French) added
  • Language deleted (English (US))

Same for me and my friend. Game resetting settings after restart the game even if I set the settings.cfg file to "read only"(after saving my new settings, to keep them). So the game don't read this file, and restart with the default settings. That's all for now, this is need more investigation.

#8 Updated by dienteclaro over 1 year ago

  • Language English (US) added

Switched the game to English and still have the issue.

#9 Updated by nestor over 1 year ago

We are already working on a fix but in the meantime the work around for this issue is changing your Regional Format to English (US).

#10 Updated by nestor over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#11 Updated by nestor over 1 year ago

  • Severity changed from Low to Normal

#12 Updated by dienteclaro over 1 year ago

Thanks, changing region will do it for now ! Good luck on your next fixes.

#13 Updated by IbanLoL over 1 year ago

nestor wrote:

We are already working on a fix but in the meantime the work around for this issue is changing your Regional Format to English (US).

One additional information: changing regional format is not working for me. I even tried to revert windows back to a previous build, and also to test the game on a fresh install, still not working. Also, it's not just settings that are reset. The game seems to start for the first time everytime. Unity Analytics windows pops up at launch everytime, big vessels time warp warning pops up in flight for every new instance of the game launched, even if you clicked "don't show again" previously.

If you need any kind of log or info from my setup (if it helps), feel free to ask.

In the meantime, as I don't change too many of the settings, I just re-set them after every game launch...

#14 Updated by just_jim over 1 year ago

  • Assignee set to just_jim

#15 Updated by vrampal over 1 year ago

Looks like the following issues are related:

https://bugs.kerbalspaceprogram.com/issues/23909
https://bugs.kerbalspaceprogram.com/issues/24035

Settings saved in US locale but loaded in system locale.

#16 Updated by dok_377 over 1 year ago

This bug is fixed in 1.8.1.

#17 Updated by just_jim over 1 year ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#18 Updated by just_jim over 1 year ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.8.1
  • % Done changed from 30 to 80

This is ready to test

#19 Updated by dienteclaro over 1 year ago

The game settings now seems to launch properly with my default region format on windows, thanks !

#20 Updated by dok_377 over 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#21 Updated by chris.fulton over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF