Project

General

Profile

Bug #23491

Chutes not deploying after exiting undeployed fairing

Added by CatastrophicFailure over 1 year ago. Updated about 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
08/31/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Chutes are displaying "cannot deploy while stowed" message after using an action group to deploy fairing and other actions.
Reference Moho 1B-A1 craft.

Load craft
Go to launchpad
ABORT!!!
Wait 'til burnout, hit 0
Capsule drops away
Hit space for chutes, "cannot deploy" message
Unhappy Kerbals

Expected behavior: Once capsule is free and separate from fairing, cutes should deploy as normal.

Use key 9 to deploy fairing separately after burnout, then 0, chutes will deploy properly.

However, behavior was NOT noticed on simplified craft, reference "Chute test.craft." As before, load>launch>ABORT!!!>burnout, hit 0>chutes deploy normally.

Moho 1B-A1.craft (565 KB) Moho 1B-A1.craft Bugged craft CatastrophicFailure, 08/31/2019 06:57 PM
Chute test.craft (37.1 KB) Chute test.craft Simplified craft, works properly CatastrophicFailure, 08/31/2019 06:57 PM
ChuteFairing.craft (25 KB) ChuteFairing.craft simpler, without M.H., 1.8.0 [email protected], 10/20/2019 10:22 PM

History

#1 Updated by just_jim over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#3 Updated by [email protected] over 1 year ago

This could possibly be a duplicate of #21915 so maybe the workarounds described there will be useful here, until it is fixed.

#4 Updated by [email protected] over 1 year ago

  • Subject changed from Chutes not deploying after deploying fairing via action group. to Chutes not deploying after exiting undeployed fairing

The title disagreed with the description; if you deploy the fairing (AG9) then the chutes do deploy.

'Moho 1B-A1 craft' has the fairing deployment (AG9) separate from decouplers (AG0) that release the pod from the fairing.
'Chute test' has faring deployment and decouplers both in the same action group (AG0) so it works in the same way as 'Moho' does when you hit AG9 and then AG0.

The behavior is consistent; if you don't open that fairing KSP won't let you deploy the chutes.
This is bug #21915, but the workarounds there don't work on the Moho craft.

#5 Updated by victorr over 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.8.0
  • % Done changed from 10 to 80

We've made some changes in the latest version and would like some feedback on this issue. Although I think the ship attached will need some rearranging of the action groups. Thanks.

#6 Updated by [email protected] over 1 year ago

The attached simpler craft still shows the solar panels and chutes refusing to deploy after dropping the fairing.
There might be something I'm missing, though, that solves the problem in the situation of the original report.

#7 Updated by [email protected] about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

This was not fixed in 1.8.0, but in version 1.8.1, the chutes deploy as desired after an un-deployed fairing has separated from the craft.
The solar panels in 'ChuteFairing.craft' deploy as well.

#8 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF