Project

General

Profile

Bug #23302

Volume does not change when you zoom out from active craft anymore

Added by Raidernick almost 2 years ago. Updated about 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Audio
Target version:
Start date:
08/05/2019
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

This has been a feature in KSP long enough that I don't even remember why it was introduced. Though now it appears that when you zoom out from a craft the volume(e.g. engine volume) will no longer decrease like it did in previous versions. If this is a bug, please fix it. If it was removed in ksp 1.7.x, I cannot even fathom a good reason you guys could have for removing this feature but please add it back.

History

#1 Updated by Raidernick almost 2 years ago

  • Subject changed from Volume does not change when you zoom out from craft anymore to Volume does not change when you zoom out from active craft anymore

#2 Updated by Raidernick over 1 year ago

I would like to clarify that the issue is that increasing the distance from your vessel does not decrease the volume of the sound from any parts producing it as it did in all previous versions of the game.

#3 Updated by Laihela over 1 year ago

I can confirm this, and it's not just when you zoom out, the volume of sounds does not decrease with distance to other vessels either. This is especially prominent/annoying if you like to set up dogfights with BDArmory, because you will hear all the engines of every plane all the time with full volume.

#4 Updated by [email protected] over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Sometime between 1.7.0 and 1.7.3 the fading of the engine sound when zooming out was lost.

#5 Updated by kaa253 over 1 year ago

  • Platform Linux added

This bug is present under Linux as well. Please fix.

#8 Updated by damonvv over 1 year ago

Can confirm it is also present in KSP 1.8.x

#9 Updated by Raidernick over 1 year ago

Yes it is still present in 1.8.x please fix this it is extremely annoying...

#10 Updated by victorr about 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.9.0
  • % Done changed from 10 to 80

We have made changes in this last release and would like your feedback please.

#11 Updated by Anth12 about 1 year ago

This bug isnt as simple as it seems.

Some engines in 1.7.3 do fade out depending on distance and some dont.

The whiplash doesnt change volume and stays at 100% no matter what in 1.7.3 (not good)
The aerospike does change volume and varies according to distance in 1.7.3 (normal)

From what I have seen of 1.9.0 so far I havent had any problems other than the ambient sounds for entry effects and high air speed don't seem to change.

Do all of the parts that create sound need to be tested?

#12 Updated by Anth12 about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

OK I tested a LOT of parts to do this bug report justice after figuring out that 1.7.3 had the problem with some engines and not others.
I will say this is resolved even though I know that ambient sounds arent because this was more about engines/parts. if anyone picks up the ambient sounds good luck.

All parts tested correctly in regards to fading in and out according to distance to the part.

Tested the parts below:
Twitch, Spark, Thumper, Rapier, Shrimp, Mite, Juno, Wheesley , Panther (both modes), Goliath, WhiplashMastodon,RhinoTwin-Boar, Ant, Spider, Terrier (revamped), Terrier (old), Nerv, Reliant, Swivel, Cheetah 2 variants, Bobcat 2 variants, Thud, Puff, Skiff 2 variants, Skipper Revamped 3 variants, Skipper, OldWolfhound 2 variants, Poodle Revamped, Poodle Old, Mainsail Revamped 3 variants, Mainsail Old, Kodiak 3 variants, Hammer Revamped 3 variants, Hammer Old, Flea Revamped 3 variants, Flea old, Cub, Kickback, Thoroughbred, Clydesdale, Vector, Mammoth, Sepratron, Pollux, Launch Escape System, Place-Anywhere 7 Linear RCS Port, RCS Thruster Block revamped, RCS Thruster Block old, Vernor Engine Revamp, LT-2 Landing Strut, LT-1 Landing Strut, LT-05 Micro Landing Strut, LY-10 Small Landing Gear, LY-35 Medium Landing Gear, LY-60 Large Landing Gear, LY-99 Extra Large Landing Gear, New Science Experiments

#13 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF