Project

General

Profile

Feedback #22832

Rotor Blade Separation

Added by XLjedi 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Parts
Target version:
Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

As the Rotor.03 part spins (torque increases) the attached blades pull away from the spinning rotor increasing the overall blade arch diameter and causing ground strikes or other unwanted and destructive effects. Attached is a very simple RotorTest.craft file example. Launch the craft from the SPH and notice as you increase throttle, the blades separate from the hub.

RotorTest.craft (16.6 KB) RotorTest.craft XLjedi, 06/09/2019 09:36 PM

History

#1 Updated by XLjedi 4 months ago

  • Subject changed from Rotor Blade Seperation to Rotor Blade Separation

#2 Updated by Anth12 4 months ago

  • Expansion Core Game added

Adding Core Game because this issue has been there for years.
Its something I have seen when a craft is under physwarp on entering the atmosphere.
The craft will separate parts from each other when the craft is undergoing high Gs, and then move back into their original position when the Gs go back to normal.

Also seen it happen on EJ_SAs attempts at helicopters using krakentech before BG came out.

Its not a BG issue in my opinion but with rotating parts it will be more obvious now for anything rotating quickly.

So I say its confirmed for the core game...

#3 Updated by Anth12 4 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#4 Updated by Geschosskopf 4 months ago

  • Tracker changed from Bug to Feedback

Anth12 wrote:

Adding Core Game because this issue has been there for years.
Its something I have seen when a craft is under physwarp on entering the atmosphere.
The craft will separate parts from each other when the craft is undergoing high Gs, and then move back into their original position when the Gs go back to normal....

I agree. This is just the natural result of KSP's stretchy, wobbly joints being subjected to much higher stress than normal. As such, it's not a bug so I changed this to "feedback". But I heard that the devs did not intend the BG rotors to be used as props anyway, so I don't expect this to change. It's just what happens when you put parts in an extreme situation.

#5 Updated by dvarjas@gmail.com 4 months ago

It only makes me wonder, what are the rotors for, if not for propellers? This issue could also be solved by adding specifically purpose-built propeller parts to the game, which are a single part and behave well under high rotation speeds.

#6 Updated by Kirk 4 months ago

I've noticed that propellers work much better if the separation occurs more then when it occurs less (due to rigid attachment) so maybe we don't really want this to change at all XD

#7 Updated by chris.fulton 3 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.3

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.3.2594?

#8 Updated by XLjedi 3 months ago

I'm pleased to see that in my limited testing...

The new rotor blades do not detach from the hub! So it appears there is a way to fix this and it's not just a Unity physics issue. I will be working with the new rotor and prop blade parts now instead of the ailerons which do still separate from the hub in the attached sample craft. This may no longer be an issue now that we have proper blades to work with.

#9 Updated by diomedea 3 months ago

  • Status changed from Ready to Test to Resolved

Thanks for testing and showing results!

#10 Updated by chris.fulton 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF