Project

General

Profile

Bug #22733

Autostruts don't recognize grandparent parts across symmetry and strut only per one side.

Added by dok_377 almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

In KSP versions before 1.7.1 autostruts in symmetry strutted parts not only per side, but across as well. Now this doesn't seem to work anymore, autostruts only strut parts per side, not across. That may result in breaking of many crafts built prior version 1.7.1 and this change at this point doesn't seem wise if you want to minimize update impact on the game. See attached pictures for example.

2019-06-02_031307.png (1.38 MB) 2019-06-02_031307.png Before 1.7.1 dok_377, 06/02/2019 12:19 AM
2019-06-02_030147.png (1.47 MB) 2019-06-02_030147.png In 1.7.1 dok_377, 06/02/2019 12:19 AM
46995
46996

History

#1 Updated by 5thHorseman almost 2 years ago

Had I noticed this before 1.7.1 I'd have reported it as a bug. The part on the other side is not the grandparent of the mirrored part.

#2 Updated by dok_377 almost 2 years ago

5thHorseman wrote:

Had I noticed this before 1.7.1 I'd have reported it as a bug. The part on the other side is not the grandparent of the mirrored part.

I still don't know if that's a bug or not. Should I change it to a bug report?

#3 Updated by Azimech almost 2 years ago

5thHorseman wrote:

Had I noticed this before 1.7.1 I'd have reported it as a bug. The part on the other side is not the grandparent of the mirrored part.

I'm very surprised you didn't notice. You'd report it as a bug, everyone else immediately recognized it as a feature and started to build this way.

I probably have 100+ designs on KerbalX relying on this feature, so yeah ... this is a bug.

#4 Updated by dok_377 almost 2 years ago

  • Tracker changed from Feedback to Bug
  • Subject changed from A question about autostruts. to Autostruts don't recognize grandparent parts across symmetry and strut only per one side.
  • Description updated (diff)
  • % Done set to 0

Changing this to a bug report, as I also don't believe this was intentional and it indeed does seem strange to change well known behavior of autostruts at this point.

#6 Updated by dok_377 almost 2 years ago

Looks like it got fixed in 1.7.2. Would be grateful if someone closed this report.

#7 Updated by nestor almost 2 years ago

  • Status changed from New to Ready to Test
  • Target version set to 1.7.2
  • % Done changed from 0 to 80

#8 Updated by dok_377 almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#9 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF