Project

General

Profile

Bug #22683

Piston extension limit breaking when reverting back to editor.

Added by dok_377 almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
05/30/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Steps to reproduce:

1. Take every piston.
2. Limit the extension.
3. Launch craft.
4. Revert back to editor.

After these steps extension limit just sticks to whatever value you set it to and completely breaks the part. It can even be done several times. The only way to fix that is to take a new part, craft reloading doesn't work.

Video demonstration: https://youtu.be/Xdt2EoSrpWM

History

#1 Updated by Technicalfool almost 2 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#3 Updated by DV-13 almost 2 years ago

Seems to be fixed in 1.7.2.

#4 Updated by nestor almost 2 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.2
  • % Done changed from 10 to 80

#5 Updated by dok_377 almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Seems to be working as intended now. Changing to Resolved at this time.

#6 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF