Project

General

Profile

Bug #22241

Parachutes destroyed on quickload and staging in unsafe conditions

Added by Kasuha almost 2 years ago. Updated about 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
Category:
Physics
Target version:
Start date:
05/13/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Reproduction steps:

1/ Load the attached quicksave. Notice the top parachute on the rocket is immediately destroyed (was staged before quicksaving in unsafe conditions so it remained primed).
Expected behavior: parachutes saved in primed state should not be destroyed on quickload in unsafe conditions and should stay in primed state until conditions meet the deployment settings.

2/ Press Space to stage one of the parachutes on attached booster. Notice the parachute gets primed but does not deploy and is not destroyed.

3/ Press Space again after booster flameout. That stages the other booster's parachute and decouples both boosters from the rocket. Notice the parachute gets destroyed on both boosters.
Expected behavior: parachutes decoupled from main ship, both pre-primed and primed on decoupling, should not be destroyed when decoupled in non-safe conditions and should stay in primed state until conditions meet the deployment settings.

quicksave.sfs (916 KB) quicksave.sfs Kasuha, 05/13/2019 08:17 PM

History

#1 Updated by Robert.Keech over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#3 Updated by Robert.Keech over 1 year ago

  • Assignee set to Robert.Keech

#4 Updated by victorr about 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.9.0
  • % Done changed from 10 to 80

#5 Updated by victorr about 1 year ago

We have made changes in this last release and would like your feedback please.

#6 Updated by Anth12 about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Testing the quick save both the top parachute and the ones attached to the side boosters work as intended now on loading. Resolved

#7 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF