Project

General

Profile

Bug #20847

Control surfaces suddenly become erratic after several minutes in flight.

Added by Klapaucius about 2 months ago. Updated about 2 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Bug Tracker
Target version:
-
Start date:
01/07/2019
% Done:

0%

Version:
Platform:
Windows
Expansion:
Making History
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

DESCRIPTION OF EVENT
After several minutes of calm flight with timewarp engaged, the plane suddenly became erratic. The control surfaces (FAT-455) started flapping back and forth with no input from me. While with timewarp, instability is not unprecedented, I have never in the past not been able to regain control by disengaging time warp.

This time, I disengaged timewarp and cut the engines, but I could not get the control surfaces to work properly. It seemed I finally regained control at the last moment, but it was not enough time to recover the dive.

VIDEO LINK
I have video of this, and it is probably much easier to understand what I am talking about if you see it. The link is here:

[[https://youtu.be/yvtIop-dEqQ]]

FURTHER DETAILS
While the video shows my original modded install, I did retest this on a non-modded install of the game with the same result.

Also, I then tried flying the plane without using timewarp. I had SAS engaged, and the plane was flying itself rather nicely. I pressed S to give it a bit of a nose up, and that seemed to start the whole process over again. The flaps started to fluttter, and nothing I could do (including turning off SAS) would allow me to regain normal control.

I built this plane over a year ago, and I have never had any issues with it until this latest KSP version (though I have not flown it for a while).

HOW TO REPLICATE (craft file attached below)

1. Take off from KSC with stability on.
2. Engage afterburners (action group 1)
3. Fly west (the direction is most certainly irrelevant)
4. Let plane fly itself for a bit.
5. Bug occurred at 7 Kerbal minutes into flight. I do not think there is a fixed number on this, but certainly there were no control issues during takeoff and first few minutes of flying in my tests.
6. Either plane will start to lose control on its own OR trying to adjust trim with WASD keys will initiate problem.

If anything is unclear, feel free to contact me at . Thank you very much for your assistance.

Flying Wing Stanislaw.craft - Craft file (64.4 KB) Klapaucius, 01/07/2019 09:36 AM

History

#1 Updated by Vycma about 2 months ago

I noticed something similar with my crafts years ago and filed some reports (https://bugs.kerbalspaceprogram.com/issues/9460 and https://bugs.kerbalspaceprogram.com/issues/9407), but it doesn't seem to have been addressed.

It seems to have something to do with how the pitch / roll / yaw direction of a control surface is determined based on the distance and orientation of the control surface to the center of mass (which changes during flight), with consequences for SAS and manual override, both of which naturally do not take this dependency into account, leading to erratic flight behaviour.

EDIT

Nope, behaviour has not changed since. All things being equal, some control surfaces closer to the COM will pitch in the opposite direction than those further away.

Also available in: Atom PDF