Project

General

Profile

Bug #20734

SM-25 Service Module Cutaways in VAB

Added by KingPhantom 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Camera and Graphics
Target version:
Start date:
12/20/2018
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Making History
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

The SM-25 Service Module Cutaways are not hidable in VAB anymore. You can click the option but nothing happens.

20734.jpg View - Looks like this for some of us, for whom it works (96.1 KB) k-ohara5a5a@oco.net, 12/24/2018 09:27 PM

20374_after_PartDatabase_change.jpg View - Looks like this when built on the first start with a new PartDatabase.cfg (105 KB) k-ohara5a5a@oco.net, 12/24/2018 10:20 PM

screenshot1.png View - 555-555-0199@example.com (2.06 MB) black-two-, 12/28/2018 09:53 PM

screenshot0.png View - 555-555-0199@example.com (2.06 MB) black-two-, 12/28/2018 09:53 PM

screenshot2.png View - 555-555-0199@example.com (2.06 MB) black-two-, 12/28/2018 09:53 PM

screenshot3.png View - 555-555-0199@example.com (2.05 MB) black-two-, 12/28/2018 09:53 PM

screenshot989.png View - 1.6.1 after a part database change (2.43 MB) Nebbie, 01/09/2019 11:40 PM

40611
40614
40644
40645
40646
40647
40891

History

#1 Updated by panarchist 2 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#2 Updated by klesh 2 months ago

KingPhantom wrote:

The SM-25 Service Module Cutaways are not hidable in VAB anymore. You can click the option but nothing happens.

I’m not seeing this. Mine has a “shroud” button which shows the interior. I think 1.5 and earlier had a different text than “shround” for the button, what does yours say OP?

#3 Updated by Nebbie 2 months ago

  • Platform Linux added
I see four options:
  1. Shroud (On/Off)
  2. Enable Cutaway (On/*Off*)
  3. Shroud (Enabled/Disabled)
  4. Shroud (Enabled/Disabled)

None of them seem to change anything in the VAB.

#4 Updated by k-ohara5a5a@oco.net 2 months ago

40611

The feature still works for me (on Windows 10). The menu looks like what is attached.

#6 Updated by k-ohara5a5a@oco.net 2 months ago

Unless I build the craft in the first-start of KSP after deleting PartDatabase.cfg (or, presumably, the first-start with Module Manger installed or first after any mod changes). In that case, I get the buggy menu as-described (new image attached).

Reloading the affected craft on the next start of KSP still shows damaged right-click menus, but replacing the affected parts resolves the problem.

I added #20758 to describe the quirks on first-start-with-new-PartDatabase in general.

#7 Updated by black-two- about 2 months ago

There's definitely something going on with the SM-25. I've had all sorts of problems with it, like deploying the doors in orbit completely bunks staging, not all options showing up in the menu and if they do show up they don't do anything, and sometimes the module (and all branches attached to it) starting "dancing around". Literally. It spins and moves around the VAB on its own, which is weird.

#8 Updated by black-two- about 2 months ago

40644
40645
40646
40647

To piggyback on my previous post (because I couldn't figure out how to add images with an edit) these are taken a few seconds apart. And I'm sorry if I'm hijacking this entry, but I figure since it's related to the SM-25 it was okay.

#9 Updated by joshua.collins about 2 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.6.1
  • % Done changed from 10 to 80

#10 Updated by Nebbie about 1 month ago

40891

Tested and working in 1.6.1.

#11 Updated by Nebbie about 1 month ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF