Project

General

Profile

Bug #18782

The kerman in the fairing will still be calculated resistance

Added by gdmf about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Physics
Target version:
Start date:
05/03/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

The kerman in the fairing or Service bay will still be calculated resistance even if the kerman is sitting on a chair.

20180503121840_1.jpg (185 KB) 20180503121840_1.jpg 555-555-0199@example.com gdmf, 05/03/2018 04:22 AM
bug.craft (36.9 KB) bug.craft 555-555-0199@example.com gdmf, 05/03/2018 02:55 PM
screenshot14.jpg (92.2 KB) screenshot14.jpg 555-555-0199@example.com k-ohara5a5a@oco.net, 06/30/2018 11:40 PM
35965
36926

Related issues

Related to Kerbal Space Program - Bug #18105: Seated Kerbals Not Ocluded In Cargo/Materials Bays/Fairings.Closed03/17/2018

History

#1 Updated by jclovis3 about 1 year ago

There are a lot of objects that will continue to have resistance if you move them into another object. The unreal ability to overlap tanks, engines, and just about any other object does not make one object lie inside the other for wind drag calculations. You will see this if you try to push parts into the skin of the ship and zoom in to watch the wind drag during flight.

To gain the protection from a fairing, the part (chair) needs to be attached to the base of the fairing or one of it's stacked nodes (shelves of sort). Without your craft file, it is difficult to see how exactly you have this chair situated, but I know you can't assign Kerbals to the chairs, which means he had to start from outside and climb into it somehow. This would only be possible I believe if the chair was mounted in such a way that it is calculated as being outside the fairing.

#2 Updated by gdmf about 1 year ago

#3 Updated by gdmf about 1 year ago

  • File deleted (20180503121840_1.jpg)

#4 Updated by k-ohara5a5a@oco.net about 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

This is a duplicate of https://bugs.kerbalspaceprogram.com/issues/18105
duplicate, and confirmation that it still exists in 1.4.3.

The protection of fairings and cargo bays does, in fact, extend to parts that are spatially inside them, regardless of connection to nodes, since the enhancement described here
https://forum.kerbalspaceprogram.com/index.php?/developerarticles.html/on-cargo-bays-and-part-occlusion-r156/

#5 Updated by TriggerAu about 1 year ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 10 to 100

Fixed in 1.4.4

#6 Updated by k-ohara5a5a@oco.net about 1 year ago

36926

The craft provided in the original post shows the same behavior in version 1.4.4 (image attached).

After moving the Kerbal to the EAS-1 chair, a quicksave/quickload before launch gives desired behavior (and makes the craft much easier to fly).

#7 Updated by bewing about 1 year ago

  • Related to Bug #18105: Seated Kerbals Not Ocluded In Cargo/Materials Bays/Fairings. added

#9 Updated by joshua.collins 9 months ago

  • Status changed from Updated to Ready to Test
  • Target version set to 1.5.0
  • % Done changed from 10 to 80

#10 Updated by k-ohara5a5a@oco.net 7 months ago

Mostly fixed in 1.4.4, and now no longer needs the quicksave/quickload (mentioned above as a workaround) so completely fixed.

#11 Updated by k-ohara5a5a@oco.net 7 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#12 Updated by joshua.collins 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF